Skip navigation

Currently Being Moderated

Edge Code CC (Preview) French Release Notes Archive

Jun 11, 2013 4:21 AM

Preview 5

Configuration requise

Windows

  • Processeur Intel® Pentium® 4 ou AMD Athlon® 64
  • Système d'exploitation Windows® 7 ou Windows 8
  • 256 Mo de RAM (2 Go de RAM recommandés pour Live Development)
  • 200 Mo d’espace disponible sur le disque dur pour l’installation
  • Affichage 1280x800 avec carte vidéo 16 bits

Mac OS

  • Processeur Intel multicœur
  • Système d’exploitation Mac OS X v10.7 ou v10.8
  • 256 Mo de RAM (2 Go de RAM recommandés pour Live Development)
  • 200 Mo d’espace disponible sur le disque dur pour l’installation
  • Affichage 1280x800 avec carte vidéo 16 bits

Instructions d’installation

  • Ouvrez l’application Creative Cloud Desktop.
  • Sélectionnez Apps.
  • Sous « Trouver de nouvelles apps », faites défiler la liste jusqu’à Edge Code CC.
  • Cliquez sur Installer.
  • Creative Cloud lance alors l’installation d’Edge Code CC.

Nouveautés

  • Edition de code
    • Mise à jour de la prise en charge des dégradés par la fonction d’aperçu rapide : L'aperçu rapide des dégradés prend désormais en charge le mot-clé "to (vers)" pour le sens du dégradé ainsi que les nouveaux types de dégradé linéaire répété et de dégradé radial répété.
  • Glisser-déposer
    • Faire glisser un fichier vers la fenêtre pour l'ouvrir : Faire glisser un fichier vers la fenêtre Brackets revient au même que de cliquer sur Fichier > Ouvrir. (Cette fonctionnalité n'était préalablement disponible que pour Windows).
    • Faire glisser un dossier vers la fenêtre pour changer de projet : Faire glisser un dossier vers la fenêtre Brackets revient au même que de cliquer sur Fichier > Ouvrir un dossier.
  • Gestion des fichiers
    • Enregistrer sous : Créez un nouveau fichier à partir d'un fichier existant à l'aide du menu Fichier > Enregistrer sous…, du menu contextuel de l'arborescence de projets ou du raccourci clavier Ctrl+Shift+S ou ⇧⌘S.
    • Nouveaux documents sans titre : Fichier > Nouveau crée désormais un document sans titre instantanément. Vous n'êtes invité à saisir un nom/emplacement qu'à l'enregistrement.
  • Intégration Kuler
    • Accédez aux thèmes Kuler créés : Tous les thèmes Kuler que vous avez créés sur Kuler
  • Interface utilisateur globale
    • Piles d'animation à l'ouverture/à la fermeture de l'éditeur en ligne et de l'aperçu par survol (affichage rapide)

Modifications de l’interface utilisateur

Nouveau fichier - Fichier > Nouveau crée désormais un document sans titre (vous n'indiquez le nom et l'emplacement qu'au premier enregistrement). La commande Nouveau fichier du menu contextuel de l'arborescence de dossiers continue de fonctionner comme avant (l'emplacement est déterminé par l'élément sur lequel vous avez cliqué avec le bouton droit, le nom est immédiatement fourni). Les deux commandes ne prennent plus par défaut l'extension de fichier .js.

Nouveau dossier - A été supprimé du menu Fichier. Utilisez le menu contextuel dans l'arborescence de dossiers pour accéder à un nouveau dossier.

Mise en surbrillance en direct - Cette bascule a été déplacée du menu Fichier au menu Afficher.

 

Problèmes connus

  • #3207
  • #4362https://support.google.com/chrome/answer/106010?hl=fr.
  • Pour pouvoir utiliser Edge Inspect avec Edge Code, le terminal et l’ordinateur exécutant Edge Code doivent se trouver sur le même sous-réseau. Dans le cas contraire, l’application Edge Inspect du terminal interdira l’accès.
  • Toutes les polices Edge Web Fonts ne s'affichent pas correctement dans toutes les langues du système
  • Les indicateurs de police CSS de base peuvent apparaître à la place des indicateurs de polices Edge Web Fonts

Preview 4

Configuration requise

Windows

  • Processeur Intel® Pentium® 4 ou AMD Athlon® 64
  • Système d’exploitation Windows® 7 ou Windows 8
  • 256 Mo de RAM (2 Go de RAM recommandés pour Live Development)
  • 200 Mo d’espace disponible sur le disque dur pour l’installation
  • Affichage 1280x800 avec carte vidéo 16 bits

Mac OS

  • Processeur Intel multicœur
  • Système d’exploitation Mac OS X v10.7 ou v10.8
  • 256 Mo de RAM (2 Go de RAM recommandés pour Live Development)
  • 200 Mo d’espace disponible sur le disque dur pour l’installation
  • Affichage 1280x800 avec carte vidéo 16 bits

Instructions d’installation

  • Ouvrez l’application Creative Cloud Desktop.
  • Sélectionnez Apps.
  • Sous « Trouver de nouvelles apps », faites défiler la liste jusqu’à Edge Code CC.
  • Cliquez sur Installer.
  • Creative Cloud lance alors l’installation d’Edge Code CC.

Nouveautés

  • Edition de code

    • Renvoi à la ligne : Sélectionnez le menu Affichage > Activer le renvoi à la ligne pour activer/désactiver cette fonction (activée par défaut).
    • Fermeture automatique des accolades : Sélectionnez le menu Modifier > Fermeture automatique des accolades pour activer l’insertion automatique des caractères de fermeture ) ] } " ' (fonction désactivée par défaut).
    • Surlignage de la ligne active : Utilisez le menu Affichage > Afficher la ligne active pour surligner la ligne sur laquelle le curseur est positionné (fonction désactivée par défaut).
    • Navigation mot par mot améliorée : Le déplacement du curseur via la combinaison Ctrl+Flèches gauche/droite (Windows) ou Alt+Flèches gauche/droite (Mac) s’exécute selon un comportement plus proche de celui des autres éditeurs récents.
    • Défilement vertical via le clavier : Utilisez la combinaison Ctrl+Flèche haut/bas sous Windows ou Ctrl+Flèches haut/bas sous Mac pour faire défiler le fichier ligne par ligne.
    • Accéder à la définition : Trouvez instantanément la définition d’une fonction ou d’une propriété, où qu’elle se trouve dans votre projet.
    • Indications sur les signatures de fonction : Utilisez la combinaison Ctrl+Espace entre les caractères () d’un appel de fonction pour afficher des informations sur ses arguments et leurs types.
    • Possibilité de masquer les numéros de ligne : Pour activer/désactiver cette fonction, utilisez le menu Affichage > Afficher les numéros de ligne (visibles par défaut).
    • Performances de saisie améliorées : Edge Code réagit plus rapidement aux pressions sur les touches : sa rapidité a été augmentée de 21 % en code JavaScript et 13 % de manière générale (correction de rafraîchissements superflus et création de fenêtres d’indication de code optimisées).
    • Correction de plusieurs problèmes d’instabilité ou de perte de la position de défilement
    • Coloration du code .sh
    • Coloration du code SASS
    • Prise en charge de l’activation et de la désactivation des commentaires de ligne ou de bloc pour PHP, XML, C/C++/C#
  • Indicateurs de code

    • Système d’indicateurs de code JavaScript plus puissant : Indicateurs de code précis provenant du moteur d’inférence de types Tern. Les indicateurs de code fonctionnent aussi pour des éléments déclarés dans d’autres fichiers ainsi que des recherches en camelCase.
    • Indicateurs de code pour les entités HTML (par exemple  )
  • Edge Inspect CC

    • Ajout de l’intégration avec Edge Inspect : Affichez un aperçu de votre contenu Edge Code directement sur les terminaux connectés.
  • Edge Web Fonts

    • Accessibilité par le clavier améliorée : L’option de saisie semi-automatique de code « Parcourir les polices Web... » est maintenant accessible via le clavier et la fenêtre du navigateur Edge Web Fonts prend en charge la saisie au clavier.
    • Prise en charge de LESS : La saisie semi-automatique de code Edge Web Fonts fonctionne dans les fichiers LESS.
  • Extensions

    • Les extensions peuvent ajouter de nouveaux langages de syntaxe : Les extensions permettent d’ajouter de nouveaux types de fichiers, dans lesquels il est possible d’utiliser, notamment, la mise en évidence de la syntaxe, les commentaires de ligne et de bloc, les indicateurs de code ainsi que la fonction Atteindre la définition.
    • Installation simple d’extensions à partir d’une URL : Utilisez le menu Fichier > Installer les extensions pour procéder à l’installation à partir de l’URL d’un fichier ZIP ou d’un référentiel GitHub. Vous pouvez également utiliser l’icône d’extension se trouvant dans la barre d’outils de droite.
    • Extension manager : Il s’agit de la liste des extensions actuellement installées. La désinstallation des extensions est ainsi simplifiée.
  • Nouveau visuel pour le panneau Projet : De légères améliorations visuelles ont été apportées au panneau Projet.
  • Gestion des fichiers

    • Actualisation de l’arborescence : Effectuez un clic droit sur l’arborescence des fichiers et sélectionnez Actualiser pour mettre à jour la liste des fichiers à partir du disque. Il n’est pas nécessaire de redémarrer Brackets. (Il s’agit d’une première étape en vue de permettre une actualisation entièrement automatique, qui sera mise en place dans une version ultérieure).
    • Suppression de fichiers/dossiers : Effectuez un clic droit sur l’arborescence des fichiers et sélectionnez Supprimer pour déplacer un fichier ou un dossier complet vers la corbeille.
    • Affichage d’un fichier/dossier dans le SE : Effectuez un clic droit dans l’arborescence des fichiers ou la liste des fichiers de travail, puis sélectionnez Afficher dans le SE pour afficher un fichier ou un dossier dans l’Explorateur Windows ou Mac Finder.
  • Aperçu en direct

    • Utilisation par défaut de localhost pour la fonction Aperçu en direct avec Node : Par défaut, le module Aperçu en direct lance désormais une URL http://localhost au lieu de file://, et ce grâce à un serveur Node.js intégré. Il est toujours possible de faire pointer le module Aperçu en direct vers votre propre serveur local (en accédant à Fichier > Paramètres du projet).
    • Plus grande fiabilité de la connexion : La connexion à Chrome est plus fiable et ne nécessite plus de redémarrer Chrome sous Windows. En cas de perte de la connexion Aperçu en direct, Brackets vous indique la raison de cet échec.
    • Surlignage d’éléments dans le navigateur à partir du code HTML : Lorsque la fonction Live Development est activée, il vous suffit de déplacer le curseur au sein d’un fichier HTML Edge Code pour que l’élément correspondant soit surligné dans le navigateur. Pour désactiver cette fonction, cliquez sur Fichier > Surlignage en direct.
  • Interface utilisateur globale

    • Ouverture de fichiers par glisser-déposer : Vous pouvez ouvrir les fichiers en les faisant glisser sur l’icône du Dock (sous Mac) ou directement vers la fenêtre Edge Code (sous Windows).
    • Maintien de la position du curseur et de la position de défilement à chaque lancement : Les fichiers restés ouverts lorsque vous quittez l’application ou changez de projet sont rouverts directement au même point. Cette fonctionnalité s’applique également aux fichiers fermés puis rouverts au cours d’une même session.
    • Refonte de la barre d’outils : La barre d’outils horizontale située en haut de l’écran a été remplacée par une barre d’outils verticale afin de mieux exploiter l’espace disponible. Vous trouverez plus de détails sur ce changement ci-après.
  • Recherche

    • Performances de la fonction Ouverture rapide : La fonction est plus réactive pour les gros projets.
    • Fonction Edition rapide plus rapide et précise pour JavaScript : C’est désormais le moteur de recherche de code Tern qui fournit les informations pour les indicateurs de code et la fonction Accéder à la définition.
  • Edition visuelle

    • Aperçu rapide pour les couleurs, dégradés et images CSS : Placez le curseur sur un élément de code CSS pour afficher un aperçu contextuel des couleurs, dégradés et images.
    • Documentation rapide pour CSS : Effectuez la combinaison Ctrl/Cmd+K sur une propriété CSS pour afficher la documentation fournie par le projet Web Platform Docs.

Modifications de l’interface utilisateur

Emplacement des extensions - L’emplacement des extensions est désormais ~/Library/Application Support/Adobe/Edge Code CC/extensions sous Mac OS X et C:\Users\<nom d’utilisateur>\AppData\Roaming\Adobe\Edge Code CC\extensions sous Windows.

 

Barre d’outils - La barre d’outils horizontale blanche située au-dessus de l’éditeur a été supprimée. Les icônes (telles que l’éclair représentant le module Aperçu en direct) sont maintenant affichées dans une barre d’outils verticale située à droite. Le nom du fichier en cours de modification apparaît maintenant dans la barre de titre de la fenêtre. Ces changements permettent d’augmenter l’espace vertical disponible pour l’affichage du code. Pour en savoir davantage sur les évolutions prévues pour Edge Code en termes d’aspect visuel, référez-vous à cette maquette.

 

Icônes des extensions - L’icône d’Edge Web Fonts représente désormais un nuage contenant la lettre T. L’icône d’Edge Inspect, représentant un terminal et un œil, a été ajoutée, ainsi que celle d’Extension Manager (icône en forme de bloc).

 

Panneau projet / arborescence des dossiers  - Une nouvelle interface utilisateur plus foncée a été mise en place pour le panneau Projet, ainsi que des améliorations permettant de mieux distinguer les fichiers de travail des fichiers du projet.

 

Nouveau visuel pour les fonctions Ouverture rapide / Accès rapide à la définition, le panneau JSLint et le panneau de résultats de la fonction Rechercher dans les fichiers.

 

L’option « Paramètres du projet... » a été retirée du nouveau menu déroulant du projet.

Problèmes connus

  • #3207 : Si vous utilisez Edge Code Preview 3 ou une version antérieure après avoir utilisé au moins une fois la présente version, il se peut que certaines préférences comme les projets récents soient réinitialisées dans les versions plus anciennes. (Si vous souhaitez éviter ce problème, vous pouvez sauvegarder votre dossier de cache).
  • #3458 : La fonctionnalité d’aperçu rapide ne prend pas encore en charge la syntaxe CSS la plus récente pour les dégradés (utilisation de propriétés radial-gradient, repeating-linear-gradient ou repeating-radial-gradient avec mot-clé et sans préfixe).
  • #3570 : Mac uniquement - La fenêtre contextuelle d’aperçu rapide ne s’affiche pas après un redimensionnement de la fenêtre ou un passage en mode plein écran. Pour résoudre ce problème, placez le curseur de la souris en haut de l’écran.
  • Pour pouvoir utiliser Edge Inspect avec Edge Code, le terminal et l’ordinateur exécutant Edge Code doivent se trouver sur le même sous-réseau. Dans le cas contraire, l’application Edge Inspect du terminal interdira l’accès.

 

 
Comments (0)