Skip navigation
Currently Being Moderated

Error communicating with AdobeID server. E_AUTH_BAD_DEVICE_KEY

Jun 10, 2008 3:56 PM

Running Digital editions 1.5 on an Ibook G4 with OSX version 10.4.11

Installed digital editions, downloaded my book. Started reading, then needed to reboot machine. once I rebooted, I tried to open ADE once more, but I again had to "reactivate" the machine... once I try to reactive it I keep n getting stuck (whether I chose to authorize or not authorize the machine is irrelevant) on the same error...

Activate Digital Editions
Error communicating with AdobeID server. Please try again later.

what's going on? When can I read my book? Is your server down? does this happen often? Is this related to the version of ADE?
  • Currently Being Moderated
    Jun 11, 2008 11:24 AM   in reply to (Carolina_Tortora)
    I made a survey and majority of us concluded that you need to stop working on Digital Editions. we prefer adobe reader
    Mark as:
  • Currently Being Moderated
    Jun 13, 2008 11:58 AM   in reply to (Carolina_Tortora)

    regarding the E_AUTH_BAD_DEVICE_KEY error...

    We can't tell you -exactly- what this is, but we can give you some general direction.

    On the Mac, Digital Editions 1.5 stores an encryption key (to make sure our client to server calls are secure) in your OS X Keychain.

    If there is a problem creating this key then E_AUTH_BAD_DEVICE_KEY is the error you'd see.

    The key information is stored as an application password in your keychain. Likely causes of failure include denying access to Digital Editions, or locking your user keychain, and not entering their password when prompted.

    If you're denying access explicitly to Digital Editions, well don't do that (ha. )

    Now, you may not be doing this intentionally. The access permissions on OS X are complicated, so this could be a side effect of some other permission work. You can explicitly grant Digital Editions access to the the keychain item:

    Open Keychain Access (Applications/Utilities)
    Select Passwords from Category
    Select Digital Editions from password list
    Click info button (or press Cmd+i)
    (Dialog labeled Digital Editions should appear)
    Select Access Control tab
    Click + button
    Navigate to our install directory and select ADE 1x5
    Click Save
    Close Dialog
    Launch Digital Editions.

    Anyway, hopefully this helps you narrow the issue down.


    Bentley Wolfe
    Senior Support Engineer, Flash/Flash Player/Digital Editions
    Mark as:
  • Currently Being Moderated
    Apr 26, 2009 5:46 AM   in reply to BWolfe [ADOBE]

    hi bwolfe,


    i have exactly the same problem as carolina.

    unfortunately, i cannot use your instructions to solve the problem, because

    i cannot find digital editions in the keychain list.

    because in another forum (macuser/ apfeltalk), someone suggested to delete

    the whole keychain, so that is what i did.


    but still, to finish the setup assistant, i am asked to type in my password which

    then does not work.

    in addition to the problems with digital edititions, since the download, i am being asked every now and

    then to type in my password when only using safari - but when i just choode quit,

    i can use safari still.


    i would be most happy if you could help me to set up the DE,

    because i need to read this ebook i downloaded.


    thanks, mary

    Mark as:
  • Currently Being Moderated
    Jul 19, 2010 5:54 PM   in reply to BWolfe [ADOBE]

    Doesn't work. Digital Edition doesn't even show up in my keychain.

    Mark as:
  • Currently Being Moderated
    Aug 19, 2010 1:01 AM   in reply to (Carolina_Tortora)

    Hi, i have a posible solution...


    I had the same problem: E_AUTH_BAD_DEVICE_KEY, what I did was go to the root account and from there active the application with the data for my adobe account, once activated in root mode, enter our normal mode and activate the Digital Editions following the wizard, this time if it worked perfectly.


    Greetings and sorry for my bad English



    Mark as:
  • Currently Being Moderated
    Jan 16, 2011 1:57 PM   in reply to (Carolina_Tortora)

    I spent hours cracking this problem.  Here's the real fix:


    a.       If you see the error: E_AUTH_BAD_DEVICE_KEY then the application was unable to access your keychain. You can fix this manually (I had to):        

              i.      Open Username (the house icon) then Libraries->keychains.  Double click on login.keychain.  It will open in the Keychain access application

             ii.      Select the login keychain and unlock it by clicking on the padlock icon next to it.

             iii.      On the right side you will see a list of applications.  Double-click ‘Digital Editions’

             iv.      Select ‘Allow all applications to access this item’ and save.

             v.      Digital Editions should now be authorized.

    Mark as:
  • Currently Being Moderated
    Jan 16, 2011 6:03 PM   in reply to SpeghettiCode

    Thanks, it didn't work because my keychain was already unlocked, but it gave me an idea. I locked the keychain and wonder of wonders.... I was able to open and use Adobe Digital Editions.

    Thanks for working on it.


    Health isn't everything, but without it, you have nothing.

    Mark as:
  • Currently Being Moderated
    Jan 21, 2011 4:46 PM   in reply to jimdohr

    Does anybody out there know what to do when you get E_AUTH_BAD_DEVICE_KEY

    and my main computer is a PC and my ereader is a Nextbook 2??????


    I have more than a dozen books sitting in my borders account but my computer and/or my Borders e-library won't load any of my books - it does not recognize the device.


    Lordy, I am sorry that I bought an e-book and I'm sorry that I bought a bunch of e-books from Borders.


    I really dislike being defeated by technology.  I've spent hours on hold with Borders, can't find anybody to talk to at Adobe and Nextbook 2 is nonexistent.  I was able to load the two first books I bought, but every time I power down, the books become corrupted and I've run through all the activations that 4 different emails can possibly do and now I am so frustrated by this, I just can't get past it.



    Mark as:
  • Currently Being Moderated
    Jan 22, 2011 12:55 PM   in reply to RosaleenMaryBrigid1

    I have a Mac, had the same problem. It turned out that I had Mac's keychain UNLOCKED. When I locked it the digital reader worked. I had no luck with Adobe trying to solve the problem except many hours on the phone waiting for help. Probably won't help you though.


    Health isn't everything, but without it, you have nothing.

    Mark as:
  • Currently Being Moderated
    Jun 29, 2011 3:34 PM   in reply to (Carolina_Tortora)

    For those of you who the lock and unlock keychain wasn't working here is what I did: all of the forums say to click on digital edition under passwords, mine wasn't there. I reset the keychain to facotry settings where it asked me basically start over. I gave it the same password and locked it and my digital edition worked fine. The person above me is right, adobe was no help with this. At first they told me it was because of my firmware which was not true, there were no updates needed. Another told me I had tried logging in too many times and even went as far as to reset my password, which was unnecessary. Just reset keychain to factory settings. Hope that helps.

    Mark as:
  • Currently Being Moderated
    Oct 5, 2011 7:32 PM   in reply to (Carolina_Tortora)

    Tried all the instructions throughout this thread. All fail. Cannot keep doing the same thing. I am now addressing Adobe: Please fix.

    Mark as:
  • Currently Being Moderated
    May 1, 2012 10:22 AM   in reply to (Carolina_Tortora)

    Great advice, if you know what a key chain is or where to find Username and all the other really interesting places everyone ccgaunt says: ADOBE HELP!!!!!

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)