Skip navigation
Currently Being Moderated

Missing Fonts

Jun 15, 2007 5:29 PM

There are fonts installed on my system, which are available in Word, CorelDraw, and other applications, but they do NOT show up, at all, in the fonts list of ANY CS2 application ... InDesign, Photoshop or Illustrator. This situation might be true of OTHER fonts, but the only ones I'm conscious of are the basic four variations of Arial Narrow, and Arial Black. (Arial Black Oblique is ALSO installed, and it IS available.)

These EXACT SAME fonts WERE available in Adobe applications, as long as I was using XP. Now that I've switched to Vista, they've ceased to function.

I've tried reinstalling these fonts and rebooting. What else can I do?

Thanks!

bilglas
 
Replies 1 2 3 ... 5 Previous Next
  • Currently Being Moderated
    Jun 16, 2007 6:17 AM   in reply to (bilglas)
    I don't have Vista, but try copying the fonts (don't move them or non-Adobe apps won't see them) to C:\Program Files\Common Files\Adobe\Fonts

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 10:19 AM   in reply to (bilglas)
    I have the exact same problem. I spent 4 hours yesterday trying everything immaginable to fix this - nothing worked. Specifically, illus. can't see the Arial Narrow family. It lists Arial as the family and Narrow as a style but can't see Arial Narrow Italic, Bold, Bold Italic, etc.
    Any ideas?
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 10:24 AM   in reply to (bilglas)
    PS - Peter
    Vista won't allow me to copy the font files to C:\Program Files\Common Files\Adobe\Fonts. I tried dragging, copy/paste, threatening gestures with a baseball bat... They just won't copy - no error message - just nothing happens.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 10:46 AM   in reply to (bilglas)
    I've always found saying "Please" to be more effective than baseball bats, but I'm not dealing with Vista. That is very odd.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 11:11 AM   in reply to (bilglas)
    Because I don't have this problem I thought maybe it's a version issue.

    The four variants of Arial narrow all show up in my fonts folder as separate file, and double clicking any of them to get a sample and font data reveals that they are all OpenType with TrueType outlines (they all have the .ttf extension, if you make it show) and are version 2.3 from Monotype. As far as I know, these fonts were included with Office 2000, but I won't swear to it as they could also have been part of the Windows XP installation.

    Do you have a newer or older version on your system?

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 11:14 AM   in reply to (bilglas)
    Looking back on other threads I see this is a Vista issue, apparently, and not a CS3 issue as folks reported it with CS2 as well.

    http://www.adobeforums.com/cgi-bin/webx/.3bc3df43/0
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 11:26 AM   in reply to (bilglas)
    Hi Peter
    This problem seems to be all over the boards since at least Feb.
    I have a brand new machine with Vista pre-instaled. I had Illus CS2 installed on an XP machine and the fonts all show up there. I have a friend with CS3 and he has the same problem. So, actually it appears to be a CS2/3//Vista problem.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 11:34 AM   in reply to (bilglas)
    Did you check your font versions? I'm curious if they are the same as mine.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 11:44 AM   in reply to (bilglas)
    narrow, narrow bold, narrow bold italic = 2.37
    narrow italic = 2.30 (copied from XP machine as one of my many fix attempts)
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 11:58 AM   in reply to (bilglas)
    Al,

    Set a restore point before you try this, and then only if you are desperate, because I have no idea what will happen since you can't seem to copy fonts.

    Copy the version 2.3 fonts from your XP machine to any folder except the fonts folder. (keep in mind I don't have a Vista machine to look at).

    Use Windows to uninstall the Arial Narrow fonts from the file menu in the fonts folder (and I'd REALLY try to copy them to someplace again before doing this).

    Reboot, just to be sure the registry gets updated.

    Use Windows to install the old versions from the folder where you copied them from XP, using the fonts folder file menu command again.

    Reboot.

    Check to see if I'm a hero.

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2007 3:01 PM   in reply to (bilglas)
    Hi Peter
    I fixed it!! I read on another forum that corrupted fonts might be being read as arial so I went through and deleted about 250 of the over 400 font files on my system, including the Arial Narrow family. I then installed the older Arial Narrow family from my XP machine. That didn't fix it but then I re-installed Illus. and that did it. I have no idea which were the offending fonts (if that is indeed what the problem was) but somehow it worked.
    Thanks so much for your advice and interest.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2007 4:04 PM   in reply to (bilglas)
    If somebody else is in the same pickle, I'd suggest after replacing the fonts, you try deleting the Adobe font cache files rather than reinstalling an entire application. Alternatively, you could remove the "bad" Arial Narrow fonts, launch InDesign, and then put the good/old Arial Narrow fonts back in place.

    Regards,

    T
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2007 10:08 PM   in reply to (bilglas)
    Hi, i'm having the same trouble (with InDesign CS2, Illustrator CS2, and Photoshop CS2) of Arial Narrow embedding itself in the Arial font list with no way to access Arial Narrow Bold, Italic, and Bold Italic. However, I am running XP (Home version, had the same trouble with Pro version, both with SP2), not Vista, so this is not exclusively a Vista problem. As others have noted, all is well with the MS Office suite and other programs, so this is definitely a CS2/3 issue with the MS XP/Vista operating systems. (At the office I have Windows 2000 and the fonts show up fine with the CS2 suite. This is a pain because I telework so much and keep getting missing font alarms that I can't resolve at home.)

    I noticed that all the arial fonts on my home machine list with the Open type icon even tho they have ttf extensions. the fonts at the office were older versions, so i deleted the new ones and installed the old ones from the office, and they show up with the TT icon. Unfortunately, it didn't help. I still don't get Arial Narrow showing up independently on the font list, even after rebooting. Someone suggested deleting the Windows cache files -- i would try that but i don't know where they are. Does rebooting refresh them? i did that with no luck.

    Deleting hundreds of fonts and reinstalling programs is not my first choice of game plan; i'm on a tight deadline and don't have time to experiment, was hoping to find a reliable solution that was relatively quick and painless. Silly me? (i cant just change the document designs -- corporate standards use arial narrow. don't get me going on that one.)
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2007 3:27 AM   in reply to (bilglas)
    Search for and delete all Adobefnt*.lst files. Don not delete the Adobefnt.db file.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2007 10:53 AM   in reply to (bilglas)
    thanks, peter. i deleted the files and rebooted. no dice.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2007 11:04 AM   in reply to (bilglas)
    Try temporarily deleting the Arial Narrow fonts again and the AdobeFnt*.lst files, too. Reboot, launch InDesign, and reinstall the Arial Narrow fonts.

    Re-reading Thomas's post I think it might be important to regenerate the font cache file before installing the Arial Narrow.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 27, 2007 4:36 AM   in reply to (bilglas)
    Hey All
    Read this post from a different thread and then my post #11 above:

    "A little update on my specific problem which has been resolved, in the course of which I discovered some strange stuff that remains unresolved. It seems like when InDesign generates its font list and the Find Font dialogue box, it gets its information on what fonts are available from PostScript files, not necessarily the fonts themselves. To make a long story short, THIS was the cause of my problem.

    Here's where we stood: All InDesign documents my coworker and I attempted to open that contained Arial fonts (regular, italic, bold, bold italic) came up with an error message that these fonts were missing. They were not, the font files were right where they always had been and were even packaged with each document. Some documents were originally created by myself by copying/pasting PageMaker text and graphics, others were just brand new documents with brand new text and graphics.

    Come to find out, we had a corrupted Helvetica.ttf font on both our computers that somehow got itself associated with outdated Arial PostScript info. These Arial PostScript imposters were being displayed under Arial in InDesign both in the font list and in Find Font. The only way to see that they were being generated NOT by the Arial.ttf file(s), but in actuality the Helvetic.ttf file, was in the path information in Find Font.

    I did some testing once I discovered the discrepancy, making new files with these Arial imposters. Sure enough, no font problems for myself or my coworker. Then I packaged the test files, trying to recreate the same situation as the original documents that, once out of my computer, returned font errors. This time, instead of packaging the Arial.ttf files and then choking for one or both of us, InDesign bundled the Helvetic.ttf file and everything still worked OK on both computers. Very odd.

    In any event, we gave the corrupted Helvetic.ttf file the boot and installed a brand new version, crossing our fingers because before when we had attempted to replace the old Arial PostScript files with the newer/real ones (something that we couldnt do consistently, for unknown reasons) replacing the fonts caused massive problems with a lot of text in a lot of tables. This time there was no rocky transition. Once Helvetic.ttf was gone, InDesign loaded up the correct Arial PostScript files and gave us no error messages about fonts being missing. This is interesting, given that we had deleted the font that originally created all the instances of Arial in these documents, but not so interesting if InDesign is seeking out PostScript data, not actual font file names, when it decides what fonts are available for use.

    I still do no know how the Helvetica file could have been corrupted to return this particular result or why the problem was able to jump from one computer to another when no files were exchanged at any time this was the real horror, files that no one but myself had ever touched and were nowhere else but my computer were suddenly reporting missing fonts.

    Kudos must go to two programs, Font Xplorer, which tipped me off to multiple versions of font PostScript files hanging around, and Font Doctor, which identified the Helvetica font as corrupted. InDesign was a help in that it was the only program which displayed both the PostScript file info and the font file path (otherwise Id never have known Helvetic.ttf was generating the Arial PostScripts), but if it wasnt so picky, none of these problems would likely have surfaced in the first place, soo.. "

    I didn't have Helvetica installed and since I deleted about 200 font files I don't know which one(s) were corrupted, but the result was the same. You can delete the Adobefnt*.lst files and reboot all you want but until you get rid of the corrupted fonts, it won't help.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2007 10:12 AM   in reply to (bilglas)
    Ok same problem here. I needed arial narrow bold super bad so what I did is install Font Xplorer (props to Mr. White) and right click install on arial narrow bold.

    It showed up in illustrator.

    word.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2007 10:15 AM   in reply to (bilglas)
    > arial narrow bold super bad

    Now there's a font to crave! [grin]

    Dave
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2007 1:45 PM   in reply to (bilglas)
    I have perhaps a similar and certainly equally as frustrating a problem. I am trying to download about 10 Khmer fonts. All the fonts appear in Word and Photoshop, but only 2 of the 8 appear in InDesign CS2 on Windows XP. Any ideas?
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2007 5:44 AM   in reply to (bilglas)
    Worse, the fonts show up in Indesign 2 but Not CS2 (Windosows XP).
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2007 5:53 AM   in reply to (bilglas)
    Just to be sure, have you scrolled through the whole font list in CS2? They might be grouped at the bottom.

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2007 10:27 AM   in reply to (bilglas)
    Hey Tina, which Khmer fonts are you trying to use? My experience with both the Limon and Ekreach families is that they need to be edited in order to appear in ID. Editing fonts is a horrible, horrible idea for any stable print workflow, and may well be in violation of the licensing agreement depending on foundry, but in the case of Limon and Ekreach, it's the only way I know of to get them to function in ID.

    I'm 95% sure that Khmer fonts won't appear at the bottom of the font list in ID. If they're Khmer Unicode fonts, they're not supported by Cooltype or Uniscribe, or at least they weren't the last time I checked. If they appear in ID at all, I'd bet money that the fonts are identifying themselves as Thai fonts, and you'll have severe character drops when trying to set Khmer type.

    If they're not Unicode fonts (like the Limon and Ekreach mentioned above), then they most likely will not appear in the font dropdown because they weren't generated correctly. However, if you have a tool to edit TrueType fonts, you might be able to get them to work in a duct-taped sort of way.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2007 8:50 AM   in reply to (bilglas)
    "It seems like when InDesign generates its font list and the Find Font dialogue box, it gets its information on what fonts are available from PostScript files, not necessarily the fonts themselves."

    "...replace the old Arial PostScript files..."

    "InDesign was a help in that it was the only program which displayed both the PostScript file info and the font file path (otherwise Id never have known Helvetic.ttf was generating the Arial PostScripts)...."

    Just two clarifications: the writer is using "PostScript files" to mean "(PostScript) Type 1 font files," and these ARE actual fonts. However, they later refer to "Arial PostScripts" to mean fonts showing up in the menu regardless of what fonts are physically around. Very confusing.

    Cheers,

    T
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2007 1:43 PM   in reply to (bilglas)
    Has anybody found a solution for this? How about Adobe Support? I could not find anything on their knowledgebase.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2007 8:54 PM   in reply to (bilglas)
    I am using Limon fonts, specifically S1 and R1. S1 appears just fine (not at the bottom of the list), but not R1. And they both appear correctly in Word.

    Tina
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 4:49 AM   in reply to (bilglas)
    I found the culprit but not exactly the solution. The problem is NOT related to Vista. It also happens in machines with Windows XP. The issue is related with Office 2007. Adobe products do not recognize fonts installed by Office 2007.

    I did several tests. I installed Vista on a desktop. Arial Narrow is not installed as system font. Then I installed CS2 and Arial Narrow (version 2.35). It worked perfectly. After that I installed Office 2007. The problem appeared again: Arial Narrow displays as a variant of Arial. And if you a have a document in Word using Calibri, Distiller does NOT output the PDF because it does not find the font.

    Then I tried to remove Arial Narrow version 2.37 (installed by Office 2007) and installed Arial Narrow version 2.35. A weird thing happened: the font appears duplicated in the Windows font folder.

    I did the same tests in a desktop with Windows XP. Adobe products work fine with Arial Narrow as long as Office 2007 is not installed. Once you install Office 2007 the problem appears.

    I called Microsoft and they told me they cannot help me with this. Adobe is not helping.

    What the hell are we supposed to do?
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 4:58 AM   in reply to (Mauro_Bertuol)
    I can confirm the behavior but I'm not quite sure it's a bad thing going
    forward. I far prefer to see these font styles linked properly to their
    families.

    Whether this was intentional or not, I don't know.

    You might want to take this over to the type forum where the real font
    gurus hang out. There may be some insight into this over there.

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 5:13 AM   in reply to (bilglas)
    The problem is that I cannot apply the following styles:
    Arial Narrow Bold
    Arial Narrow Italic
    Arial Narrow Bold Italic

    The only thing that I can apply is Arial Narrow itself. I would not mind if all the arial narrow styles would appear under Arial. The problem is that I cannot use the 3 styles above.

    Also, how do you explain that the new fonts installed by Office 2007 as Calibri are not recognized by Distiller?
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 5:14 AM   in reply to (bilglas)
    >I far prefer to see these font styles linked properly to their
    families.

    And I doubt that anyone would be complaining if ALL the narrow variants were showing up with the plain variants. It's the missing italic and bold variants that seems to have people (rightly) steamed.

    Interesting that this is an Office 2007 issue. One more reason not to upgrade.

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 5:20 AM   in reply to Peter Spier
    Ah yes...I do see the problem now.

    Interesting. I'm guessing there's some type of bug there, but I'm not
    enough of an expert in font technology to to even guess who's fault this is.

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 5:38 AM   in reply to Peter Spier
    I never should stepped into this thread. Ignore everything with the
    exception of confirming the behavior. :(

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 5:41 AM   in reply to (bilglas)
    >I'm guessing there's some type of bug there, but I'm not enough of an expert in font technology to to even guess who's fault this is.

    But we can take a stab at who is in a better position to ignore or break an existing standard. ;)
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 6:29 AM   in reply to (bilglas)
    Could you post a link to putting the genie back into the bottle, please.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 7:59 AM   in reply to (bilglas)
    I FOUND THE SOLUTION!

    1) Log into any computer running Windows XP, locate and copy the 4 Arial Narrow files:
    ARIALN.TTF - 132 KB
    ARIALNB.TTF - 136 KB
    ARIALNBI.TTF - 136 KB
    ARIALNI.TTF - 139 KB
    Please note that the extension is TTF, not OTF (installed with Office 2007) and the size is smaller (Arial Narrow OTF size is over 170KB)

    2) Copy the files to the following folder: C:\Program Files\Common Files\Adobe\Fonts

    3) Open any Adobe product (I have tested with Illustrator CS2, Indesign CS2 and Indesign CS3). You will now see both Arial and Arial Narrow listed. However, Arial Narrow (Regular) is listed under Arial.You will see:

    ARIAL and the variants:
    Narrow
    Regular
    Italic
    Bold
    Bold Italic
    Black
    ARIAL NARROW and the variants:
    Italic
    Bold
    Bold Italic

    Therefore if you wish to use Arial Narrow Regular you have to select Arial and the variant Narrow. For the the other Arial Narrow variants, select Arial Narrow and the variant you want to use.

    Please let me know if this worked for you. Good luck!
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2007 9:28 AM   in reply to (bilglas)
    I'd like to add to my earlier post speculating about responsibility.

    As I'm not a font expert, nor knowledgeable about how Adobe products get information about what fonts are loaded in the system, I suppose it is possible that this is similar to the problems people report about various Adobe apps "breaking" their PDF workflow.

    In those cases it has been suggested that the problems are caused by third-party developers' failures to properly implement the postscript standard. In fairness, it is not impossible, however unlikely, that Adobe could also be guilty of such a lapse, and that the newer fonts are making use of code in a new, but compliant, way which was not anticipated.

    Peter
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2007 11:23 AM   in reply to (bilglas)
    Thanks you Mauro. That did the trick.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 29, 2007 5:33 AM   in reply to (bilglas)
    BRILLIANT! It now works perfectly!

    Thanks!
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2007 7:21 AM   in reply to (bilglas)
    It works!! Thank you Mauro!
     
    |
    Mark as:
1 2 3 ... 5 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)