Skip navigation
Currently Being Moderated

Restart numbering not working for numbered lists created w/ paragraph style

Feb 20, 2008 3:04 PM

Issue: Numbered lists created with a paragraph style continue numbering from elsewhere in the document.
OS: Windows XP SP2
Software: InDesign CS3
Details: I would like numbered lists to begin with #1 rather than continuing numbering from elsewhere in the document.

If I highlight the list in question, then choose Type > Bulleted and Numbered Lists, the option to restart numbering is grayed out.

If I double click on the paragraph style and examine the Bullets and Numbering options the mode is "continue from previous number." If I change the mode to "Start at 1" every item in my numbered list has the number '1'.

I have no character styles applied and no overrides or local formatting applied.

Seems like the opposite problem from the discussion below:
http://www.adobeforums.com/webx/.3c055d95/2

Thanks,

Josh G.
Portland, OR
 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Feb 20, 2008 3:17 PM   in reply to (JoshG)
    You need a different paragraph style for the first item in a list.

    --
    Kenneth Benson
    Pegasus Type, Inc.
    www.pegtype.com
     
    |
    Mark as:
  • Currently Being Moderated
    Feb 20, 2008 7:43 PM   in reply to (JoshG)
    Or, if there's another style that will always appear between the lists (eg, body text), make that style level 1 with no numbers and make your list level 2 with "restart after previous level" enabled.
     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2008 6:17 AM   in reply to (JoshG)
    A couple of other tips...

    Make sure you use Paragraph styles

    Make sure you name the lists (don't use the default name unless doing a continuous list document wide)

    For a numbered list, make two styles, both part of the same named list:

    One style, name NumList (for example) and set to continue from previous number;

    The second style, name NumList1 and based it one the first;
    set this style to (re)start the count at 1

    Use a character style to format the numbers if desired.

    I have a ID file with different numbered list examples at:
    <http://www.ideastraining.com/PDFs/IDCS3_NumberingExamples.zip>
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2008 9:48 AM   in reply to (JoshG)
    A quick way to reset the numbers to start from 1 for that list is select the particular list, then
    under Para control panel:
    - hit the little bullets button
    -and then hit the numbered list button again

    this appears to start them from 1 for that list without having to do the above steps.

    It worked for me.
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2008 9:31 PM   in reply to (JoshG)
    None of these suggestions work, or even make sense. Sorry.

    I have the same problem as posed by Josh G. It seems this is a serious defect in ID with no way, sensible or ridiculous, of having a series of numbered lists, say ten or twenty lists, each list starting with 1 and ending with whatever.

    Even creating a new paragraph style for each list fails to accomplish this. Fooling with "Mode" and "Restart Numbering" just gives all items in list the same number -- 1. This is pathetic.

    Or what am I missing? I'm from Missouri.

    Show me.

    (please ;-)

    Thanks.

    regards,

    stevenjs
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 13, 2008 4:11 AM   in reply to forTheTimeBeing
    It's certainly not intuitive but it does work. The trick is to create a
    numbered list style that has no number and use that to restart the
    numbering.

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 13, 2008 4:15 AM   in reply to (JoshG)
    I answered you in one of your threads but I'm using a newsreader and
    don't have a link handy.

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 13, 2008 4:15 AM   in reply to (JoshG)
    None of these suggestions work, or even make sense. Sorry.

    I have the same problem as posed by others. It seems this is a serious defect in ID with no way, sensible or ridiculous, of having a series of numbered lists, say ten or twenty lists, each list starting with 1 and ending with whatever.

    Even creating a new paragraph style for each list fails to accomplish this. Fooling with "Mode" and "Restart Numbering" just gives all items in list the same number -- 1. This is pathetic.

    Or what am I missing? I'm from Missouri.

    Show me.

    (please ;-)

    Thanks.

    regards,

    stevenjs
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 14, 2011 1:29 PM   in reply to forTheTimeBeing
    Please don't post the same complaint multiple times. Ask a specific
    question.

    --
    Kenneth Benson
    Pegasus Type, Inc.
    www.pegtype.com
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 29, 2008 6:59 PM   in reply to (JoshG)
    I would like to make a list of Top 20″ items with the number in a different color, a different and larger font than the rest of the list is there a way to do that?

    Karen
    Indesign CS3
    MAC
    Tiger
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 29, 2008 8:34 PM   in reply to (JoshG)
    Create a character style and specify that in the numbers dialogue.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2008 6:59 AM   in reply to (JoshG)
    "The trick is to create a numbered list style that has no number and use that to restart the numbering"

    This doesn't seem to work. When a list doesn't display any numbers, InDesign fails to recognize it as a numbered list, and can't use it to restart lower leveled lists.

    Please, if anyone has a suggestion as how to solve this - enlighten us!
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2008 7:15 AM   in reply to (Johan_Snällfot)
    > This doesn't seem to work.

    It does work. Bob's suggestion was to create a numbered list style, not
    a list with no numbers. Set up a style that uses List Type > Numbers,
    and Numbering Style > Format > None. Set it to a lower level than your
    numbered list level and make sure List > [Listname] is the same in both
    styles, where [Listname] is the name you've used for your numbered lists.

    --
    Kenneth Benson
    Pegasus Type, Inc.
    www.pegtype.com
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2008 7:48 AM   in reply to (JoshG)
    >Set it to a lower level than your numbered list level

    I think you mean a lower-numbered list level, which is a higher-level level, right?

    Regards,

    Peter Gold
    KnowHow ProServices
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2008 9:16 AM   in reply to peter at knowhowpro
    > I think you mean a lower-numbered list level, which is a higher-level level, right?

    You lost me. I get "lower-numbered" list level, but I don't understand
    "higher-level level". The only "level" I was writing about is the Level
    field in Bullets and Numbering.

    You need (at least) two paragraph styles: a numbered list style, and a
    style that resets the numbering in the numbered list style. The "reset"
    style can be any style you want. It just has to consistently show up
    anywhere between the end of one list and the beginning of the next. Both
    styles should have numbering turned on, but the reset style doesn't
    necessarily have to display a number. The reset style could be Body Text
    (with no numbers) if Body Text always shows up between numbered lists.

    In the Bullets and Numbering tab of Paragraph Style Options, the reset
    style should have a lower Level than the numbered list style. So if the
    numbered list style has a Level of 2, the reset style should have a
    Level of 1.

    --
    Kenneth Benson
    Pegasus Type, Inc.
    www.pegtype.com
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2008 4:41 AM   in reply to (JoshG)
    Hi, Kenneth:

    >n the Bullets and Numbering tab of Paragraph Style Options, the reset
    style should have a lower Level than the numbered list style. So if the
    numbered list style has a Level of 2, the reset style should have a
    Level of 1.

    Sorry if I was unclear. Your first post was ambiguous to me, but your description above is quite precise.

    My point was that level 1 is the highest level in a hierarchical text structure, like an outline, or chapter - section - subsection document. But, it's the lowest-numbered level.

    Regards,

    Peter Gold
    KnowHow ProServices
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 27, 2008 12:45 PM   in reply to (JoshG)
    "Set up a style that uses List Type > Numbers, and Numbering Style > Format > None."

    Thanks! I was so focused on trying to remove the number character from the text-field bellow (which appearantly makes InDesign ignore numbering completely), I totally missed that option.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2008 6:42 AM   in reply to (JoshG)
    Seriously...

    "but the reset style doesn't necessarily have to display a number"

    I really can't get this to work. When I have numbering visible on the level 1 list, the next paragraph (with level 2 assigned) restarts its numbering.

    However, as soon as I hide the number in the level 1 list, the restart fails.

    Can anyone confirm that this works? What am I doing wrong?
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2008 8:11 AM   in reply to (Johan_Snällfot)
    Yes, I've already confirmed that this works. I use it daily to number
    chapter endnotes. Note head (that says "Notes to Chapter Five") is the
    reset style. The notes number themselves restarting at 1 after every
    note head.

    Show me screencaps of the Bullets and Numbering tab of both paragraph
    styles (the style for the numbered list paragraph and the style for the
    "reset" paragraph) and I'll try to figure out what you're doing wrong.

    Or send me your file and tell me what are the names of the list style
    and the reset style. kbenson at pegtype dot com

    --
    Kenneth Benson
    Pegasus Type, Inc.
    www.pegtype.com
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2008 2:38 PM   in reply to (JoshG)
    I've also been using this since I got CS3. Try this:

    Numbered list: List Style = Numbers; List = [Enter specific list name]; Level = 2; Format = 1, 2, 3, 4... [or your choice]; Number = ^#.^t [or whatever you want]; Character Style = [Your choice]; Mode = Continue from Previous Number; Restart Numbers After = Any Previous Level.

    Body Text (or other style): List Style = Numbers; List = [Enter same specific list name]; Level = 1; Format = None; Number = [Blank]; Character Style = None; Mode = Start At 1.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2008 1:51 AM   in reply to (JoshG)
    Thanks a bunch guys! Problem was, I hadn't set the "invisible" list to [Start at 1]. I can't say that I understand the rationale behind this behavior but it sure seems to work!
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2008 3:13 AM   in reply to (JoshG)
    >I can't say that I understand the rationale behind this behavior.

    It's nothing mysterious - you're just restarting the list after a higher-level style, just like going back to (a) after 2 in the sequence 1, (a), (b), (c), 2, (a) ... . If a numbering feature doesn't let you restart the numbering, it's not much good.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2008 2:43 AM   in reply to (JoshG)
    Yeah, I get the principle, but why is it necessary to set the top level list to [Start at 1]? Anyways, thanks again for all the help!
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2008 7:43 AM   in reply to (Johan_Snällfot)
    > why is it necessary to set the top level list to [Start at 1]?

    I don't think that it is. Mine is set for Start at 0. For a list that
    displays no numbers, does it really matter what number it starts
    counting at?

    --
    Kenneth Benson
    Pegasus Type, Inc.
    www.pegtype.com
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2008 10:34 AM   in reply to (JoshG)
    I am revisiting this because I have an almost-similar question.

    I have a document in which every paragraph is numbered.

    1 (Level 1)
    1.1 (Level 2)
    1.2
    1.2.1 (Level 3)
    1.2.2
    ...
    1.4
    1.5
    1.5.1
    1.1

    For no apparent reason, my numbering resets itself after section 5. I haven't changed the paragraph styles at all. If I pull the problem level up to the paragraph above it (e.g., 1.5.2), it works fine but the next Level 2 resets itself to 1.1.

    "Continue Numbering" is not an option. Neither is "Clear Overrides." I tried selecting all paragraphs, removing the numbering, and then clicking the numbering button again, and that just wreaked havoc. All the numbering in the document went kablooie. ("Kablooie" = Technical Term.)

    In the past, "Clear Overrides" or remove/add numbering has worked for me. Not today. Any suggestions? Thanks!
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2008 12:21 PM   in reply to (Lynn_Anslow)
    Could be a bit of corruption in the document. Export it to INX and try
    opening that.

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2008 12:42 PM   in reply to (JoshG)
    Actually, I changed everything to a Level 2, then went through and reformatted all the Level 3s. That seems to have worked.

    There's either some corruption in the document, in the software, or in my computer.

    Sometimes InDesign likes to turn the section numbers into Greek characters. Never the same document twice.

    Oh well. Do you know of any ID3 consultants in the Washington, DC area? My bosses want to bring in someone who knows what they're doing, just to finish the darn manual. Because clearly I haven't got what it takes.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2008 12:48 PM   in reply to (Lynn_Anslow)
    Are you looking for a designer or consultant?

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2008 1:02 PM   in reply to (JoshG)
    A consultant, I guess. Not a trainer. Someone who can come in and look at the document and, once they've stopped laughing, fix all the mistakes and make it ready for "Publishing" in PDF format.
     
    |
    Mark as:
  • Currently Being Moderated
    Jul 28, 2008 1:11 PM   in reply to (Lynn_Anslow)
    I'm in New Jersey and should be able to help. Contact me offlist by
    clicking on my name and going to my website.

    Contact info is there.

    Bob
     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2010 2:55 PM   in reply to David Creamer

    David C,

    Could you tell me what format those numbering samples are? I unzipped th IDCS3_Numbering samples, but don't know which format to choose for Numbering Exmples.indd--htm, html, or pdf nor that file's relatinship to the _MACOSX

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2010 3:25 PM   in reply to yenelli

    This is a really old thread and david may not be watching anymore, so...

     

    The zip file contains a CS3 .indd file that opens with InDesign. There's no HTML or PDF involved. Just ignore the _MacOSX folder. It's useless on PC and should be invisible to Mac users, but it needs to be extracted along with the .indd on the Mac.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2010 3:27 PM   in reply to Peter Spier

    When you open the file you'll probably get a missing plugin warning for History.IndesignPlugin. You can just ignore it and say OK and the file will open fine.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2010 3:28 PM   in reply to Peter Spier

    THX, Peter!

    RoboHelp has the same problem, perhaps this example will help, but I can't get to it without InDesign

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2010 6:59 PM   in reply to (Dominic_Hurley)

    Thanks, This Really Helped me.

     

    Thank u very much.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 7:02 AM   in reply to (Kenneth_Benson)

    People keep changing the subject before the question is answered.  I am having the same problem - I have used InDesign for many years and have not had this problem before - it is very unpleasant - especially on a deadline, and I can understand his frustration.  It ONLY happens when I use Paragraph Styles, not when clicking the Numbered List button.  I would forgo using the Paragraph Syles altogether when using the Numbering List, but sometimes I need to change the spacing, and I'd like it to look consistent.  I think I am going to have IT re-load InDesign.

     

    This is a sample what I get:

     

    1.Er aliquis nonu

    1. Msan ulput ulla alisi te minis adiam vel ut lore magnis dolummodion ullandrem augait, cons eumsan velit nisl ullandio eum velendre core doloreet nonullaor aliquis erilisim venibh el et lum inci te molum

    1.Odionsent la core consendre ver si.

    1. Ex eugiat nullaorem vel inci blam eu feu feuip ex exer suscil duis duisit ad dit wisit nibh et nummy nis auguer

     

     

    Cindy

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 7:08 AM   in reply to Contributor37013

    Without seeing your settings there's no way to diagnose it. Can you upload the file somewhere?

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 7:09 AM   in reply to Contributor37013

    Looks like your style is set to always start at 1 rather than continue from previous. Numbered lists are tricky (I still struggle with teh beause I seldom use them). Have you read the help about them?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2010 6:42 AM   in reply to Peter Spier

    I want it to start at 1 every time.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)