Skip navigation
Currently Being Moderated

Adobe Reader Firefox Plugin

Dec 26, 2007 3:13 PM

I am running Fedora 8 (kernel 2.6.23.9) with Adobe Reader 8.1.1 on a Core 2 Duo with 2 gigs of ram. When I use the Firefox browser (2.0.0.10) to read a PDF document, a process named acroread is started. I assume this is done by the Adobe Reader Firefox plugin. After you leave the document the acroread process begins to use 40-60 percent of the CPU and never ends. Exiting the browser does not stop the acroread process. It continues to run away. After a couple of attempts the kill command will end this acroread process. At one time I had four of these runaway processes running at once. I assume that every time I entered a PDF document in the browser it starts a new acroread process. This problem does not happen when you use the Adobe Reader outside of the browser on local PDF files. Is there something I can collect to help solve this problem? Is this a known problem?
 
Replies
  • Currently Being Moderated
    Mar 11, 2008 2:56 PM   in reply to (Rick_Immel)
    Apparently this is an ongoing problem. I'm using Fedora 2.6.24.3-12.fc8 on an old 1/2gig 500Mhz Pentium III. When I ended the Firefox browser, I didn't kill the acroread process and eventually it locked up Linux. It looks to me like a bad memory leak and a runaway process. I had to a hard boot - twice. Is there a bug report available? Could this be a Firefox problem?
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2008 4:33 PM   in reply to (Rick_Immel)
    This is also a problem on openSUSE 10.3 running acroread 8.1.2 from firefox (everything's 64-bit as far as I know).
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 24, 2008 1:56 PM   in reply to (Rick_Immel)
    Some of our users on Fedora 8 with 8.1.2 are seeing this too. Others are not though. Don't yet know what the difference is. strace seems to indicate that it is continuously communicating with the X server.
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2008 4:26 AM   in reply to (Rick_Immel)
    I experience this problem almost on a daily basis on Fedora 8 and I typically access hundreds of PDFs every day for work, so its really beginning to annoy me. If I catch the problem early I have just enough time to kill it before it devours 4Gb of RAM and eats my machine alive.
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2008 9:46 AM   in reply to (Rick_Immel)
    Experiencing same memory leak problem on Fedora 8 Kernel 2.6.24.3-34 x86_64, glibc 2.7-2,
    with FireFox 2.0.0.08, 2.0.0.10, 2.0.0.12, and 2.0.0.13
    and AdobeReader 8.1.1 and 8.1.2

    b Observations when running any version of FireFox:
    *1-when reading a pdf file, System Monitor displays a new process called "ld-linux.so.2";
    *2-when getting off the pdf file, process "ld-linux.so.2" remains active;
    *3-when reading a new pdf file, another "ld-linux.so.2" is started;
    *4-when closing FireFox, one or several "ld-linux.so.2" processes remain active and become runaway processes;
    *5-these "ld-linux.so.2" runaway processes eat-up about 1MB per second until system freezes.

    b Another observation:
    *When starting Adobe Reader, System Monitor does not display "acroread", it displays "ld-linux.so.2"
    Adobe Reader launcher uses a script called "acroread"; this script launches the binary either directly
    or through "/lib/ld-linux.so.2".

    b Further observations:
    *1-In FireFox, when Adobe Reader is launched through "/lib/ld-linux.so.2", it becomes a runaway process.
    *2-On the other hand, when Adobe Reader is launched directly,
    ]-System Monitor displays "acroread"
    ]-acroread always terminates as it supposed to do.

    b Solutions:
    * 1-add a symbolic link as follows:
    ]ln -s ld-linux.so.2 /lib/ld-lsb.so.3

    *2-or install Package redhat-lsb as follows:
    ]yum install redhat-lsb

    b Conclusion:
    It appears that "/lib/ld-linux.so.2" is not handling the "term signal" received from FireFox when exiting a pdf page. When Adobe Reader is started directly, it does handle the "term signal" received from FireFox and terminates correctly.

    b Outstanding Question:
    Is "/lib/ld-linux.so.2" supposed to handle the "term signal"? If so, this is where the bug is because it does not. If not, why is it used to launch Adobe Reader?
    Home my many hours of investigations can help someone.

    b Note

    Sorry. Problem is NOT entirely solved here! Still some memory leaks at times.
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2008 10:17 PM   in reply to (Rick_Immel)
    This problem appears to be due to nspluginwrapper. After the recent Fedora 8 update to nspluginwrapper-0.9.91.5-18.fc8.i386.rpm, this problem became quite severe for me, with acroread not even rendering the document in Firefox until the mouse was moved in and out of the window a time or two. Downgrading to nspluginwrapper-0.9.91.5-17.fc8.i386.rpm solved that but did not completely solve the cpu/memory issue. While I don't have a solution, I did find that the following very rough workaround works:

    1. Start firefox.
    2. Go to /usr/lib/mozilla/plugins-wrapped
    3. chmod 0 nswrapper_32_32.nppdf.so
    4. chattr +i nswrapper_32_32.nppdf.so

    This forces the use of /usr/lib/mozilla/plugins/nppdf.so instead of the wrapped version, which seems to work quite well on my computer. acroread stays running but doesn't go nuts with its X11 connection and also serves any page needing to display a PDF instead of invoking multiple processes.
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 21, 2008 12:35 PM   in reply to (Rick_Immel)
    Thanks Greg, this problem has annoyed me for a while (on fedora 8 ), I've tried different solutions but none of them worked.
    The problem is now resolved with your workaround!
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2008 2:43 PM   in reply to (Rick_Immel)
    You shouldn't have items in your /usr/lib/mozilla/plugins-wrapped directory whose form is nswrapper_32_32.*.so. There should be links to the real 32-bit plugins in /usr/lib/mozilla/plugins instead. There should be items of the form nswrapper_32_64.*.so in /usr/lib64/mozilla/plugins-wrapped, though, if you are running 64-bit firefox on 64-bit linux.

    I'm not sure about Fedora, but on 64-bit RHEL, you can do (as root)

    mozilla-plugin-config -r
    setarch i386 mozilla-plugin-config -i -v
    mozilla-plugin-config -i -v

    You only need that second step if you are running 32-bit Firefox on a 64-bit platform. But it won't work if you don't have the 32-bit version of nspluginwrapper installed.

    On 32-bit RHEL, I imagine the sequence would be

    mozilla-plugin-config -r
    mozilla-plugin-config -i -v

    Then do "ls /usr/lib*/mozilla/plugins-wrapped" to see what you've got.

    Or better yet, if you are running 32-bit Linux, odds are you don't need nspluginwrapper at all, so remove it! The firefox startup script will detect its existence and use the plugins-wrapped plugin directory rather than the vanilla plugins, which is unnecessary on 32-bit Linux.
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)