Skip navigation
chuckee
Currently Being Moderated

Font showing up bolder on some pages

Apr 18, 2009 8:12 PM

Hi,

when I generate a PDF file from my Indesign file, some of the pages end up with the font being noticeably thicker than others.

Please see the attached PDF - pages 4, 7, 8, 10 and 15 have this bolder-looking text on them.

My whole actual PDF file is over 100 pages and this sort of problem occurs on about 25-35% of the pages.

I have no idea what could be causing this.

Any ideas?

 

Thanks

Chuckee

Attachments:
 
Replies
  • Currently Being Moderated
    Apr 18, 2009 8:30 PM   in reply to chuckee

    Your PDF is still queued, two hours later, but I'd be willing to bet this is a transparency issue. Transparency affects how text is rendered on the screen. It shouldn't affect how it's rendered when printed (although this has also been reported). It's difficult to explain to clients.

     

    The fix I've read about is to put text on a higher layer than the transparent object, but I haven't been able to make this work. Last time I ran into this I put an empty 99% stroke opacity text box on the master page so that every page had this effect. Better bolder on every page than bolder on some pages.

     

    Ken Benson

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2009 11:33 PM   in reply to Kenneth Benson

    Turning everything bold is a bit extreme And not very satisfactory. I find the layers solution works well.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2009 4:10 AM   in reply to chuckee

    As Ken said, this is a display issue having to do with how transparency is rendered. That transparency can be in the form of a layered or transparent image, or (since jpegs don't support either of those features) some effect, such as a drop shadow applied in InDesign, which is why adding a transparent item to the master page will work to make all of the text render the same on screen.

     

    While there are some occasional reports, I think, of the emboldened type printing on a desktop printer, I don't recall seeing any reports of the same on a press.

     

    Peter

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2009 7:27 AM   in reply to chuckee

    chuckee wrote:

     

    Peter - the jpegs that I have inserted do not have any effects at all applied to them.

    Also, the PDF I generate is for electronic viewing only so it is important that I have the text look the same on every page and the bolder text just looks bad, so I don't want to have the bolder text on every page.

    The transaprency needn't be applied to the jpeg, or even be on the same page in a multipage spread, to cause this.

     

    The only way I know to prevent this is to use only non-transparent images and never use any effects. As one of my former professors used to say, "That's a design decision."

     

    Peter

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2009 7:40 AM   in reply to chuckee

    A quick way to check for transparency is to open the Pages panel and look for

    chequerboards.

    --

    Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2009 7:59 AM   in reply to chuckee

    Is this confidential? Can you package the file and zip it, then send me a private message (click my name or avatar to go to my profile, then use the actions panel) with a link to a server location? you can use yousendit.com, for example.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2009 8:01 AM   in reply to chuckee

    Has some but not all of the text been turned to outlines?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2009 12:18 AM   in reply to chuckee

    Yes, it was unlikely, but in my own experience, if I'm focussed on one thing, I find it very easy to overlook something else very obvious. I can easily imagine myself getting more and more focussed on issues such as transparency, text on uppermost layers, etc., and completely overlooking two "obvious" possibilities:

     

    (1) Text that has been converted to outlines (i.e. it consists of vector paths rather than editable text) tends to look a bit heavier in PDFs (to my eyes).

    (2)  A previous user might have tried to achieve a bold effect by applying a very thin but non-zero stroke to a font that doesn't have its own bold typeface.

     

    Apologies if you are unlike me, and always check the obvious first!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2009 3:01 AM   in reply to chuckee

    A long shot

     

    What can happen is that you have images with that have transparency.

     

    And you have transparency flattner preset that says Convert Text to Outlines.

     

    When it hits a page with transparency it converts the text to Outlines. Which makes the glyphs bolder.

     

    To see if this is the problem check the Transparency Flattner Presets and see what one you're using and if Convert Text to Outlines is applied.

     

    If it is, then turn it off.

     

    Everything else here is spot on. Put text on a higher layer. Make sure it's not coverted to outlines. Make sure there are no strokes on the text.

     

    The Strokes on the text is also a likely candidate - because the Low and Medium Flattner Presets have Convert All Strokes to Outlines. Only the High preset has the Convert All Strokes to Outline turned off.

     

    Hope that helps somehow.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2009 6:07 AM   in reply to chuckee

    One more suggestion: My battles with transparency turning text dark (which, as in your case, is critical since my end-product is the online PDF) were resolved when I stopped Exporting to PDF from InDesign and began Printing to PDF.

     

    Dave

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2009 8:47 AM   in reply to chuckee

    Chuckee sent me the file and I've been looking it over.

     

    The file is non-facing pages and most pages do not contain any transparency. On my Windows system the type looks normal on those pages until I switch to Overprint Preview, at which point it gets slightly bolder, an expected behavior that has been around forever.

     

    I've tried exporting and printing to PDF, and the only pages that appear darker to me are the exported pages with unflattened transparency (I cheated for testing by duplicating a page with with an image, then making that image 99% opaque).

     

    I looked at the file history, and I note that it was originally a CS2 document. I'd recommend you export to .inx from CS3 to remove the missing plugins references. It's also a Mac doc, and I'm on Windows. I have some vague memories that this issue behaves differently on the two platforms, and that may in fact be what Chuckee is seeing. I'm inclined to suggest trying an export to PDF/X-1a to see if that helps.

     

    I was going to ask why this wasn't set up as facing pages, but I've just remembered that you said it was going to be distributed as an on-screen PDF, not printed. My personal inclination would still be to make facing pages now to mirror your page borders, and then it would be ready to re-purpose for print when it becomes wildly popular. You can set the file properties in the PDF to open as a two-page spread with single cover page.

     

    Not much help, I'm afraid.

     

    Peter

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2009 5:09 AM   in reply to chuckee

    As I said, this may look different on Mac than it does on PC. They use different schemes for rendering type.

     

    In my testing pages with transparency ALWAYS show emboldened type in InDesign, and ALL pages show it if you switch to overprint preview. I think this has to do with the overprint preview engine, which I don't claim to understand.

     

    When I export to PDF using a preset like [Press Quality] with a compatibility of  Acrobat 5, which leaves the transparency live, those pages with transparency look darker on screen in the PDF. If I use a setting like PDF/X-1a that flattens transparency (Acrobat 4 compatibility) I don't see the darkening. Printing to PDF instead of exporting also will always flatten transparency.

     

    The downside to flattening transparency is it can lead to other screen artifacts like stitching -- thin white lines around regions in the file -- on screen and in low resolution printing. For your file I don't think that's going to be a major issue as for the most part you don't have transparency on top of other objects.

     

    To get a feel for what you should see, make a two-page file, and set both pages identically. Add a small color filled rectangle somewhere on both pages, and on one set the opacity of the rectangle to 99%. That's enough to make that page show transparency problems, but not to make the object visually different on screen in most cases. Now make a PDF using a variety of settings and printing/exporting. When you view the PDFs, look at the pages separately and jump back and forth. If the type is the same you won't se anything as you shift, if one is bolder it will jump out at you. Jump from flattened to unflattened versions the same way.

     

    Does that help?

     

    Peter

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2009 6:23 AM   in reply to chuckee

    If you're going to pay someone, ask Peter instead of some stranger on Elance.

     

    Ken Benson

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2009 6:35 AM   in reply to Kenneth Benson

    I'm not sure if you're suggesting paying me, or asking for a recommendation, and I appreciate the thought in either case , but I'm afraid it wouldn't do much good.

     

    I'm pretty sure this is a platform-specific issue, and probably not solvable, at least not by me, and I don't know anyone who isn't likely to already be looking here who would be able to do any better.

     

    Can Chukee post a link to some of the trial PDFs that show the problem that were exported using PDF/X-1a preset and any settings but that were printed rather than exported? Just two pages each, on that shows and one that doesn't (but the same two pages in each file). That will confirm, perhaps the platform connection.

     

    Peter

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2009 6:39 AM   in reply to chuckee

    It occurs to me that it might help to move this over to the Acrobat forums. There are a lot of smart folks over there, too, and most of them know ID as well, at least as far as exporting.

     

    Be sure to link back to this thread so they can see what's been discussed already, and post a link here to the new thread so we can find it and subscribe. If they have a solution, I'd LOVE to learn about it (and so would quite a few other peple around here).

     

    Peter

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2009 9:32 AM   in reply to chuckee

    I've downloaded your samples, and I must say this is all very strange. Looked at on my monitor, all of the pages in each document seem to match each other in darkness (which I expected since both are flattened), but the exported sample "seems" slightly darker to me than the printed sample. Combining the two files into one, however, and looking at the same page side by side in the same window, there is virtually no difference in darkness, or perhaps the printed page is slightly darker. This could be due to different settings between the exported and printed versions --  the colors are definitely slightly different.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2009 11:13 AM   in reply to chuckee

    All the text here looks equally dark to me (in Acrobat 7, Windows XP).

     

    Ken Benson

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 26, 2009 9:39 PM   in reply to chuckee

    This is starting to sound very much like a software issue... question would be whether it's an app or maybe a video driver.

     

    How are you viewing this? What version of Acrobat? You aren't perchance viewing the PDFs using Apple's "Preview" app, are you?

     

    Also, check to make sure you have the latest drivers for your video card.

     

    Regards,

     

    T

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 26, 2009 9:40 PM   in reply to chuckee

    (Oops, forum problem, forgive double post.)

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 26, 2009 11:12 PM   in reply to chuckee

    To me, this just looks like an artifact of screen re-drawing (not sure what the technical terms for it is). If you use the scroll arrows to get the dark text, then use the scroll wheel to move some of it off -- then back on -- to the screen, the re-drawn bit is no longer darker.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 27, 2009 4:53 AM   in reply to chuckee

    Sorry, no difference here on Windows XP with Acrobat 9. It would be nice to here from some other Mac users.

     

    I was going to ask the same question about Preview, but you've answered it...

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2010 3:22 PM   in reply to chuckee

    I've had today a similiar problem and I've wasted several hours "debugging" it so maybe my solution will help somebody. First of all my problem was kind of "opposite" - the pages with transparent png/psd had slimmer, jagged text + the pasted transparent image looked kind of bleak - aftery many tries the thing that workded for me  was putting on every page (through master page) a small transparent (0.01%) rectangle - all the pages got then original correct form of text.

     

    This bug is really terrible and occurs from what I've read since CS3 (I'm using CS5) - I cannot believe that Adobe haven't dealt with it yet...

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2010 3:30 PM   in reply to chodorowicz_

    It's not really a "bug". Because of the transparency, your PDF viewer (Acrobat?) switches to another drawing algorithm: slower, because it has to calculate the correct color to display per pixel, but more accurate. For text-only pages, Acrobat uses a faster algorithm.

     

    If you switch on "Overprint Preview" in your Acrobat, you should see everything the same.

     

    It's also possible you accidentally put something transparent over text -- that causes the text (and all other vector data) underneath it to be rasterized. You should try to avoid this, as it probably will show up in print (especially if you forgot to export with a high resolution setting for Transparency Flattening).

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2010 7:07 AM   in reply to [Jongware]

    Many thanks for these explanations. It surely makes more sense now (and the "overprint preview" in Acrobat worked as you said). But still, I believe that this behaviour of Indesign+Acrobat is very confusing and difficult to debug, especially for novice users. I think there should be some setting in Indesign export options to force the same rendering algorithm for all pages.

     

    Thanks again!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points