Skip navigation
Currently Being Moderated

Google Analytics for AS2

May 12, 2009 12:38 PM

Hi,

 

I created a web site in Actionscript 2 and have been asked to add Google Analytics to it. This is the first person who has asked me to do this and when I log into Google Analytics, they only provide the code for Actionscript 3. Apparently there used to be just Actionscript 2 code there but for a while it has just been AS3. I am told that the old code still works and I know that someone out there must have it. Can anyone help me out with it?

 

Thank you,

-Jan

 
Replies
  • kglad
    72,189 posts
    Jul 21, 2002
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 12, 2009 3:39 PM   in reply to janst

    you're welcome.

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 6:56 AM   in reply to janst

    copy and paste logging.as

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 7:22 AM   in reply to janst

    and did you add the ga javascript with your ua number to your html page?

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 10:18 AM   in reply to janst

    that's not your ua number.

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 12:23 PM   in reply to janst

    ok.  (but your number is public information -  anyone that loads your html page in a browser can view your ua number.)

     

    so, what problem do you see?

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 1:21 PM   in reply to janst

    no, it doesn't.

     

    what problem do you see?

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 2:09 PM   in reply to janst

    has it been 48 hours since you started testing?

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 18, 2009 9:44 PM   in reply to janst

    the first 2 paramenters in trackGA() are always required but you're not always sending 2 parameters.

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 19, 2009 10:20 AM   in reply to janst

    sometimes your using:

     

    trackGA("button/pressed/video");

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 19, 2009 1:57 PM   in reply to janst

    per your comments, an action is required.

     
    |
    Mark as:
  • kglad
    72,189 posts
    Jul 21, 2002
    Currently Being Moderated
    May 19, 2009 4:59 PM   in reply to janst

    in logging.as look at trackGA().  there are two parameters that are required and, i think, 2 that are optional.

     

    if 2 are required, you must pass 2 each time trackGA() is called.  you're not doing that.

     

    and there may be more errors beyond that.  i only check until i find an error.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points