Skip navigation
q8twins
Currently Being Moderated

no sound when i work in after effect

May 19, 2009 1:54 AM

Hi all ,

 

When ever i work in after effect cs3 . i dont get the sound while working in after effect . i want to play my movie in after effect with sound so i can put some good sounds in my movie but i can only see the movie playing without sound . what should i do , can any one help me?

 
Replies
  • Currently Being Moderated
    May 20, 2009 5:37 AM   in reply to q8twins

    I am sure the problem you're experiencing is covered in the links above.

     

    To play back a section of your AE composition with audio, you need to build a RAM preview first (numeric keypad 0 or the button on the right of the Time Controls, to start building it).

    The "spacebar play" doesn't play at full frame rate and it doesn't play audio.

     

    To preview audio only, press the numeric keypad . (dot)

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2009 4:18 PM   in reply to q8twins

    Khaled:

    Just so that it's clear, you invoke RAM previews by pressing 0 in the numeric keypad, not the 0 key in the main section of the keyboard. And you can also play back just audio by pressing ".", also in the numeric keypad.

     

    If your keyboard doesn't have a keypad (for example, it's a laptop keyboard), you can play just audio by going to Composition > Preview > Audio Preview (Here Forward). Or you can invoke a RAM preview by pressing the large button at the right end of the Time controls panel (or go to Composition > Preview > RAM Preview).

     

    The only thing you could check in Preferences (Audio Hardware) is which output to use in your computer's audio card.

     
    |
    Mark as:
  • Currently Being Moderated
    May 24, 2009 10:36 PM   in reply to Adolfo Rozenfeld

    If Mr. Rozenfeld's suggestions don't work, please provide some info about your audio hardware. This may be a generic configuration problem after all. Apart from that, I could only think of problems with the audio streams in the file, e.g. them being compressed in a weird way or being on the wrong channels in a multichannel file. Can you even play the movie normally on your system with sound?

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2009 9:52 AM   in reply to q8twins

    I'm not sure if I understand you. If it's from a camera that uses DVD-R, it's most likely AVCHD or a form of MPEG-2 and since apaprently it gets into Premiere, why not just simply export a WAV file from there? There is no requirement for the sound to be contained in a movie file, you can just as well line up everything again in AE...

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2009 11:23 AM   in reply to Mylenium

    If you have a Decklink card, then it's possible that After Effects is sending the audio through the Decklink's audio outputs instead of your computer's line out port. Do you have your audio monitoring system connected to the Decklink as well? If not, you could go to the Audio Hardware preferences and change what audio output to use with AE. Or maybe it's the other way around - Decklink cards can be configured to act as the system sound card, but maybe AE is sending the audio output through the basic sound card. That you could also change in the Audio Hardware preferences.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Sep 25, 2011 10:36 AM   in reply to Adolfo Rozenfeld

    hello i have done the same and it works but when i save the movie to desktop and play it, it laggs so much and there is not sound no matter what player I used and by the way im on mac using after effects cs5 from the master collection

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2011 10:55 AM   in reply to anishdamasta

    anishdamasta,

     

    Did you follow the instructions here to get audio output?

    FAQ: Why is there no audio (sound) in my output file?

     

    Regarding lagging on playback, see this:

    "FAQ: Why is my output file huge, and why doesn't it play back smoothly in a media player?"

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points