Skip navigation
G_S_SAINI
Currently Being Moderated

Security error accessing url" faultCode="Channel.Security.Error" faultDetail="Unable to load WSDL

Dec 3, 2008 10:39 PM

HI

I am using a webservice(.net webservice) that is on my localhost and using it in flex application that is also on my system. Means both the webservice and flex application are on the same system.
But when i gives the reference of the webservice using the system ip and run the application by the flex builder it generates the error as:

mx.messaging.messages::ErrorMessage)#0
body = (Object)#1
clientId = "DirectHTTPChannel0"
correlationId = "24CD6542-F141-1A05-BA35-00A108CB30A0"
destination = ""
extendedData = (null)
faultCode = "Channel.Security.Error"
faultDetail = "Destination: DefaultHTTP"
faultString = "Security error accessing url"
headers = (Object)#2
messageId = "CC123DF0-0E6C-05FF-7894-00A109676283"
rootCause = (flash.events::SecurityErrorEvent)#3
bubbles = false
cancelable = false
currentTarget = (flash.net::URLLoader)#4
bytesLoaded = 0
bytesTotal = 0
data = (null)
dataFormat = "text"
eventPhase = 2
target = (flash.net::URLLoader)#4
text = "Error #2170: Security sandbox violation: http://localhost:3000/MYCIMS/flex_bin/Design.swf cannot send HTTP headers to http://myip/MyServer/AdminWS.asmx."
type = "securityError"
timestamp = 0
timeToLive = 0

I have put crossdomain.xml file in the root of the localhost and made every changes possible in the crossdomain.xml file but the application is not running.
Please somebody provide an effective solution, I have spend lots of time to resolve the problem but its not being....

Thanks in advance
Gopi Saini
 
Replies
  • Currently Being Moderated
    Dec 7, 2008 6:44 AM   in reply to G_S_SAINI
    when you use the ip instead of "localhost", flash player recognize it as a different host. either change the wsdl address to localhost or put a crossdomain.xml file under you web root
     
    |
    Mark as:
  • Currently Being Moderated
    Dec 23, 2008 7:26 AM   in reply to G_S_SAINI
    Hi G S Saini did you ever resolve this issue?
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2009 7:37 AM   in reply to G_S_SAINI
    Can you post your x-domain file here? also, can you use a http proxy, such as the charles debug proxy, to see if the x-domain file is indeed fetched. it could be just a permission issue with the file.
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 22, 2009 8:00 PM   in reply to G_S_SAINI
    Hi..

    replace crossdomain.xml
    if test success then apply to your security setting
    ---------------------------------
    <?xml version="1.0"?>
    <!DOCTYPE cross-domain-policy SYSTEM "/xml/dtds/cross-domain-policy.dtd">
    <cross-domain-policy>
    <site-control permitted-cross-domain-policies="all"/>
    <allow-access-from domain="*" to-ports="*" />
    <allow-http-request-headers-from domain="*" headers="*"/>
    </cross-domain-policy>
    ---------------------------------
     
    |
    Mark as:
  • Currently Being Moderated
    Feb 8, 2009 9:28 AM   in reply to gstarclub
    Hi Saini,

    Did you resolve this issue yet? I tried putting the crossdomain.xml in my web server but that didn't help!!
     
    |
    Mark as:
  • Currently Being Moderated
    Feb 8, 2009 12:54 PM   in reply to G_S_SAINI
    make sure crossdomain.xml is acecssible at
    http://localhost/crossdomain.xml

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2009 8:58 AM   in reply to G_S_SAINI

    Hello, no update about this problem? I've tryed to find thw solution on the web but all people with the same problem.

     

    On my machine I can put the crossdomain.xml on the root of IIS but if I need to put my application on another server and i cannot put the file on the root of IIS (for many ISP I'd have this problem) what can I do? Is this a bug about flex?

     

    thanks in advance

    andrea

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2009 6:25 PM   in reply to Masa84

    It's the expected behavior if you have an app in any hosting you get access

    to a your website wwwroot in there you can place anything you want. Unless

    you're trying to access info from a domain you don't own or manage.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 29, 2009 8:29 AM   in reply to G_S_SAINI

    Try to change the directory structure under your Apache/j2ee server. I was having similar issues when accessing it on Unix server. But when I put the swf file directly under the root, it allowed the access and no more security error.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 15, 2009 7:29 PM   in reply to G_S_SAINI

    hiii.......

    Thanks to u all....You all save my Day......

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 2:52 AM   in reply to G_S_SAINI

    Thanks guys, the solution worked for me.

     

    Web Development Sydney | Led Downlights

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 13, 2009 11:26 AM   in reply to leddownlights

    I had the same error and crossdomain.xml worked. Thanks a lot for your help.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2010 7:30 AM   in reply to G_S_SAINI

    Awesome, this post helped me too.


     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2010 9:26 AM   in reply to G_S_SAINI

    thanks a lot, this solved also our problem...

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2011 6:47 AM   in reply to gstarclub

    My Flex application calls a DotNet Web service and throws a security error despite the presence of the crossdomain.xml. I tried all kinds of suggestions until this one worked.  Apparently just specifying the allowable domains and headers is not enough.  The extra settings in this file must be the trick.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 24, 2011 12:41 AM   in reply to G_S_SAINI

    Hi,

     

    guyz can you please read my posts at http://forums.adobe.com/message/3986954#3986954

     

    i am using flash builder using httpservices to call twitter and it works fine if am testing on localhost but once i close the flash builder it generates error and stop showing tweet message

     

    error am getting i.e.

     

    ============

    local error i.e. http://localhost/fb/cg7/

    ============

     

    Fault 0 (Error):

    [Server.Error.Request]

     

    FAULT MESSAGE: faultCode:Server.Error.Request faultString:'HTTP request error' faultDetail:'Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL:http://localhost:37813/1/users/show.xml?screen_name=charagh?hostport=a pi.twitter.com&https=N&id=7DC25F2C-E9EC-2E95-1389-34C9A2061624"]. URL:http://api.twitter.com/1/users/show.xml?screen_name=charagh'

     

    FAULT DETAILS: Error: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2032: Stream Error. URL: http://localhost:37813/1/users/show.xml?screen_name=charagh?hostport=a pi.twitter.com&https=N&id=7DC25F2C-E9EC-2E95-1389-34C9A2061624"]. URL: http://api.twitter.com/1/users/show.xml?screen_name=charagh

     

    FAULT STRING: HTTP request error

     

    ============

    online error i.e. http://charag.com/fb/cg7/

    ============

     

    Fault 0 (Error):

    [Channel.Security.Error]

     

    FAULT MESSAGE: faultCode:Channel.Security.Error faultString:'Security error accessing url' faultDetail:'Destination: DefaultHTTP'

     

    FAULT DETAILS: Destination: DefaultHTTP

     

    FAULT STRING: Security error accessing url

     

    i placed crossdomain.xml

     

    i.e.

    <?xml version="1.0"?>

    <!DOCTYPE cross-domain-policy SYSTEM "/xml/dtds/cross-domain-policy.dtd">

    <cross-domain-policy xsi:noNamespaceSchemaLocation="http://www.adobe.com/xml/schemas/PolicyFile.xsd">

     

    <allow-access-from domain="charag.com"/>

    <allow-access-from domain="*.charag.com"/>

     

    <allow-access-from domain="a1.twimg.com"/>

     

    <allow-access-from domain="*.twitter.com"/>

    <allow-access-from domain="twitter.com"/>

    <allow-access-from domain="api.twitter.com"/>

    <allow-access-from domain="search.twitter.com"/>

    <allow-access-from domain="static.twitter.com"/>

     

    <site-control permitted-cross-domain-policies="master-only"/>

    <allow-access-from domain="a1.twimg.com"/>

     

    <allow-http-request-headers-from domain="*.twitter.com" headers="*" secure="true"/>

     

    </cross-domain-policy>

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 16, 2011 1:00 AM   in reply to Asim Kh

    It could be that the error,"Security error accessing url" faultCode="Channel.Security.Error" is thrown when the web service to be accessed is not of the same protocol. It worked for me when the web service was published on the same protocol as the request.

     

    I tried to resolve the issue by modifying the cross-domain.xml in the root of iis with allow-access-from domain, but could not resolve.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points