Skip navigation
Guardian452
Currently Being Moderated

Dreamweaver Saving Problem - Access Denied

Jul 9, 2009 11:12 AM

Lately I've been having problems saving with Dreamweaver CS3 on my 64bit Vista system.

 

The error that I get says "Access to C:\Users\Bob\Desktop\MECHANICALAPE\MFC13C.tmp was denied."

 

To remedy this I have to save on the desktop. For a couple seconds to a minute there will be a duplicate file in the folder I wanted to save in, I have to wait till this goes away. Then I can drag the file that I saved on the desktop to this folder, and only then be able to test it with my stylesheets/etc... Instead of saving it on the desktop, I can also save it with a different name, but I still have to wait till the other file goes away to rename it to what I originally wanted.

 

As you can imagine this makes everything ridiculously slow. I've looked online and lots of people have similar problems, but I have yet to find a solution. Anyone have a clue?

 

In advance, much appreciated.
-Bob

 

*Additionally, trying to open the files with notepad is also problematic now. I am told access denied, and then the file will disappear altogether!

 
Replies
  • Currently Being Moderated
    Jul 9, 2009 11:42 AM   in reply to Guardian452

    This is to do with the file permissions problem on vista.

    You will have to change the permissions on your files (or hard drive, but this often does not filter through to all directories).

     

    Right click on your hard drive - select properties - security, then edit the permissions.

    (You may have to repeat the above for various directories).

     

    PZ

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2009 10:51 PM   in reply to pziecina

    I'm having the same exact issue, Vista 64.

    I use Dreamweaver CS3 daily and till this morning everything was fine.

    Suddenly began getting the symptoms described above, access denied, then file disappears.

     

    Already tried 25 different ways of taking ownership and full permissions on a single file, entire folders and the entire D:\ drive where I normally work.  Enabled the Vista Administrator account (hidden and disabled by default on Vista), and tried every ownership, permission possibility I could think of from that account also.

     

    Nothing fixes it so far.

     

    It's definitely a permissions issue though.

     

    I confirmed that the issue DOESN'T exist when I sign in as Administrator and use Dreamweaver.

    Signed in as myself (with Administrator rights), the problem exists.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 26, 2009 12:11 AM   in reply to ParureticDave

    I too have this issue and regardless of what permissions I set on the file, folder whatever, I get the problem sporadically, there is no rhyme or reason to why it happens.

     

    I posted about this a while ago here:

    http://forums.adobe.com/thread/437359

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 26, 2009 1:39 PM   in reply to Nadia-P

    Nadia,

    This issue is now resolved for me.

    I can create the issue and cure the issue at will.

     

    The problem was Vista Explorer's preview option.

     

    When I turn it on the issue occurs.

    Turn option on:   Organize / Layout / Preview Pane

    Open Dreamweaver and a sacraficial file, edit and try to save it...BINGO...access denied, file disappears etc.

     

    Turn off the Preview Pane and issue is cured.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2009 8:20 AM   in reply to Guardian452

    I witnessed this issue too, real pain... thanks for the tip above, much appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2009 6:04 AM   in reply to ParureticDave

    Tested your suggestion and tried about 5 different times, but I didn't get one locked file while the view pane was 'on'.

     

    Hmm... I'll experiement with this over time and see if it is the issue... as I said originally, there is no rhyme or reason for this stooopidness  :-)

     

    Thanks for the tip - hopefully it may help other people, but for me, I'm on the fence until I test further.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2009 2:20 PM   in reply to Guardian452

    Upgrading to Windows 7 64-bit, I found that Dreamweaver cannot update files created in earlier sessions because of the Windows 7 User Access Control.I found this when I tried an approach of saving my edits into a new file, deleting the old file, and saving the new file under the old file's name.

     

    Selecting Edit/Delete on right-clicking a file in Dreamweaver's Files window a got a dialog box saying File Access Denied: You'll need to provide administrator permission to delete this file (I am an administrator on this workstation). Clicking on Continue, the screen dims and the User Access Control window pops up, asking "Do you want the following program (Dreamweaver) to make changes to this computer?" After clicking on Yes, the file is deleted but the permission must be granted separately for each subsequent file.

     

    This is a slow workaround, but it works. Nothing in the Windows Explorer window or file permissions in Windows made a difference.

     

    I'm not sure if this is one of those "Windows Undocumented Features" or a poor programming handshake between Adobe and the operating system, but I commend this to someone's attention to find and fix the cause, or to share a more direct workaround.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2010 9:43 AM   in reply to Guardian452

    The problem for me in Vista was that "User Account Control" was turned ON. I had a "permission denied" problem in Eclipse when I tried to create a new project. I went into The Security Center Control Panel and turned OFF "User Account Control", Restarted the computer, and all my permissions problems went away.

     

    Windows is so dumb sometimes.

     

    -G

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2010 1:44 AM   in reply to ParureticDave

    I can confirm the solution is to do with preview pane in Vista 32 bit. the problem affects notepad and dreamweaver but not other editiors. For example wordpad works fine. It is also only confined to files of type .htm ot .html.  .php are not effected .

    preview pane introduces a security hole which allows external uses to see details of your computer. Microsoft have obviously attempted to plug this but in my opinion very badly.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2011 6:34 AM   in reply to terence.buckle

    Anyone know if there's a way to recover a file that's gone missing due to this issue?

     

    My one copy is gone and it looks like the Windows System Restore is from too long ago to help.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points