Skip navigation
Currently Being Moderated

When using vanishingpoint filter,photoshop crashed in windows 7

Sep 12, 2009 7:41 PM

Here are some problems with my photoshop!

 

I open a file, copy a layer and type, then copy the text.

 

and choose the vanishingpoint filter, when I paste the text and move it , photoshop crashed.

 

 

OS:Windwos 7 RTM 760016385

Adobe Photoshop CS4 Extended
Thanks for your attention!
 
Replies
  • Currently Being Moderated
    Sep 12, 2009 8:14 PM   in reply to hjyknight

    Did you update CS4 to 11.0.1?

     

    Also what did the crash message say?

     

    What does the windows 7 event log read?

     

    What about video card drivers? Did you update those?

     

    On a side note: Your a systems evaluator as you have a copy of the RTM correct? How do you like the RTM vs the RC? (just wondering)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2009 5:43 AM   in reply to hjyknight

    Had the same problem with Windows 7 64-bit and Photoshop CS4 and solved it by disabling OpenGL drawing.

     

    This however indicates that something is wrong with your video card's drivers and as such should be properly gotten rid off by using driver cleaner provided by Guru3D. Then just install the newest set of whql drivers for your card and voilá vanishing point should work without crashing now.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2009 9:57 AM   in reply to hjyknight
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 8:18 AM   in reply to hjyknight

    Hi,

     

    I'm using updated Drivers as well as updated Software (11.0.1).

     

    The vanishingpoint filter crashes when I copy my selection to the Filter Dialog or seconds later when I move the selection inside the created grid.

     

    System:

    Windows Home Premium 64bit

    Photoshop 11.0.1

    Nvidia Geforce 8800 GTS 512MB

    Nvidia 191.07 Driver

     

    Does anyone know a workaround (I have tried running as administrator, running 32bit version and different file formats as well as a couple of older drivers - no luck so far).

     

    Thanks for reading,

    Marcus

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 8:52 AM   in reply to hjyknight

    Forgot one question...

     

    Can someone confirm that the vanishing point filter is working with Radeon GPUs under Windows 7 64Bit? I desperatly need that filter and consider buying a Radeon 5770 if it works then.

     

    Greetings,

    Marcus

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 8:57 AM   in reply to hjyknight

    Wow, I thought I was the only one. I have the exact same problem! As soon as I move something like an image over a box that has its vanishing point grid setup, photoshop crashs immediately and offers no explanation or choices.

     

    I have Photoshop CS4, and it is updated to 11.0.1. I recently upgraded to Windows 7 and this is when I started experiencing these problems, though I had not used a vanishing filter before I upgraded. I have a fairly recent laptop, with a ATI Radeon HD 3200 graphics card. Its drivers updated messy like the person previously said, so I downloaded the driver sweeper program, cleaned out all the ATI drivers and then reinstalled the most current version. I thought this would fix the problem, but it has not.

     

    I also have tried disabling openGL and this does not fix the problem either. I am at a loss what to do, it really is not that big of a deal though since it is an isolated problem. My thing is that I am actually in a Photoshop class, and my homework for this week is to use vanishing filters, which is why I have never used them before. The lesson I am doing is straight out of the Adobe Photoshop CS4 Classroom in a Book, lesson 9 advanced layering. If anyone reading this has this book, Photoshop is crashing for me when I try to put the logo on the box, but the shape art image worked fine. Which doesn't make sense, how does the vanishing filter work and then not work afterwards.

     

    If anyone needs more info on my system I will happily provide. Thanks Nick

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 10:03 AM   in reply to Nicho247

    Hi Nick,

     

    what Version of Windows 7 did you install? How much RAM is installed and how much of it do you allow Photoshop to use? I have 8GB installed and tried a lot of different settings (including 2GB for Photoshop and 100% for Photoshop) - no luck.

     

    From all I read it seems to be a problem in Windows 7 64Bit and since you have a Radeon it does not seem to be a GPU related problem.

     

    Thanks 4 your help,

    Marcus

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 10:17 AM   in reply to Marcus Rudolph

    Home Premium 64-bit, I bought the 30$ student upgrade, previously had Vista-64...

     

    I got 3250mb of ram and I let Photoshop use 80%, so 2600mb. Maybe it is my processor? I don't know...I got an AMD Turion X2 Ultra Dual-core.


     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 10:41 AM   in reply to Nicho247

    Well, seems to be Windows 7 64Bit since I got an Core2Quad Q9750 (and prozessor related issues have become rare these days).

     

    Thanks 4 your quick answer,

    Marcus

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2009 9:18 PM   in reply to Marcus Rudolph

    I had exactly the same problem. Updated to latest drivers etc. to no avail. The thing that worked for me was changing from the Windows 7 Aero theme in the personalisation settings to Windows 7 Basic. This seems to have done the trick. Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2009 10:07 PM   in reply to joanna.p

    wow thanks joanna! i went into the personalization settings and just clicked on the windows 7 basic setting. opened up photoshop and now the vanishing point stuff works. amazing that these two things were somehow related...im hoping now that i can get some credit back for my homework since my teacher gave me 0/25 for this weeks stuff.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2009 10:23 PM   in reply to Nicho247

    That's great. Glad to help.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2009 11:16 PM   in reply to Nicho247

    Nicho247 wrote:

     

    ...since my teacher gave me 0/25 for this weeks stuff.

    That's a good one! Hope you make it up now!!

     

    Cheers and all the best

     

    shunith

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2009 9:13 AM   in reply to joanna.p

    AWESOME!

     

    It works and solves this problem. I have been working with the filter for quite some time today and no crash occured.

     

    Million THX to joanna.p

     

    I just wonder how this can happen - how can Aero and Photoshop interact like that?

    Anyhow somebody at Microsoft or someone at Adobe (maybe both) should do their homework so others can do theirs...

     

    Thx again,

    Marcus

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2009 9:56 AM   in reply to hjyknight

    If a person is running Windows 7 in 64 bit mode and PS CS4 in 64 bit mode the .exe compatibility settings cannot be changed in the .exe properties. That is normal and the aero will have to be shut off in windows. It is a windows 7 64 bit thing and nothing to do with the software.

     

    If a person is running windows 7 in 64 bit mode and PS CS4 in 32 bit mode then the .exe compatibility settings can be changed to Disable Visual Themes. When 32 bit PS CS4 is started(with Disable Visual Themes selected)  the windows display will automatically go to basic. When PS CS4 is closed the screen will revert back to Aero.

     

    Some microsoft software that is 32 bit is written to check for aero and if it can run in that mode. If not then the software will change the theme to basic all by itself.

     

    If the software won't change the aero settings then it is, of course, up to the user to play with the settings to get the best performance. Windows 7 aero is a little different then Vista's. PS CS4 was not written with Windows 7 in mind. People are finding little speed bumps here and there but it goes with the turf of OS upgrading. 

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 29, 2009 4:22 AM   in reply to dec9
    When 32 bit PS CS4 is started(with Disable Visual Themes selected)  the windows display will automatically go to basic. When PS CS4 is closed the screen will revert back to Aero.

    Sorry, it needs to be "Disable desktop composition", not "Disable visual themes", at least on Windows 7, I didn't test it on Vista.

     

    Attached is a zip file which contains an Auto-It script called ThemeSwitcher.exe -  it can be used to switch to the Basic Desktop theme even when CS4 already is running (before the vanishing point filter is used).

    It switches to the basic theme and back to the former theme as soon you end CS4 - works for 32bit and 64bit Windows 7. Note that PS have to be started already otherwise the script only switches between both themes immediately.

     

    Even it won't harm you computer, use it at your own risk.

     

    Or you might create a new shortcut on the desktop and paste this

    c:\windows\system32\rundll32.exe Shell32.dll,Control_RunDLL desk.cpl desk,@Themes /Action:OpenTheme /File:"c:\windows\resources\Ease of Access Themes\basic.theme"

    to it.

    Which switches from the current theme to basic and also works for all versions of Windows 7. But you need to close the desktop theme window manually or leave it open for switching back to your former theme manually.

     

    regards, Ablichter

    Attachments:
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 11, 2010 9:48 AM   in reply to joanna.p

    I've been having the exact same problem, always crashing in Win7 x64 using the 64-bit exe of PS CS4 Extended

    when using the Vanishing Point filter. Great to find a fix; too bad there's no way to patch it up. Still, it's an easy switch from Aero to Basic and back, so I'll just have to remember to do it every time I use the filter.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2010 10:10 AM   in reply to hjyknight

    Thanks going to Windows Basic worked. Was pissing me off.

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2010 6:34 PM   in reply to dec9

    Thank you for explaining that. It makes perfect sense!

     
    |
    Mark as:
  • Currently Being Moderated
    May 19, 2010 6:34 PM   in reply to joanna.p

    Awesome! Thanks for posting this!!


     
    |
    Mark as:
  • Currently Being Moderated
    Jun 7, 2010 3:16 PM   in reply to hjyknight

    Thanks man!  This works brilliantly!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2010 2:55 AM   in reply to joanna.p

    Thanks, it works perfect.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points