Skip navigation
mpaniak
Currently Being Moderated

Adobe Reader 9 highlights text when scrolling in terminal server

May 29, 2009 6:30 AM

Running a terminal server with WIndow 2003.  Have Adobe 9 Reader installed.  When a pdf is opened, it will look correct.  However, when one uses the scroll bar on the right to see more of the document, text can be highlighted and change colors constantly when scrolling.

 

Test it outside of terminal server and it works fine.  This issue did not happen with other versions of Reader.  I have attached two samples one clean and one highlighted. 

 

Any help is appreciated

Attachments:
 
Replies
  • Currently Being Moderated
    Jun 1, 2009 12:41 AM   in reply to mpaniak

    Hi,

     

    Im having the same problem but with version 8.0.0. Im updating but not sure if this will solve the problem.

     

    If you select text and unselect sometimes it solve it, but scrolling again it highlight again.

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2009 2:51 AM   in reply to Naishel

    Hi again,

     

    Googling i've found a solution

     

    http://www.jasonslater.co.uk/2008/01/08/corrupt-text-display-in-acroba t-and-terminal-services/

     

     

    "going into Edit -> Preferences -> Page Display -> and switching off Smooth Text in the Rendering group - the problem goes away."

     

    Thanks and i hope this solve your problem with version 9 too.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 5, 2009 2:14 PM   in reply to mpaniak

    I have a custom deployment of Adobe Reader 9.1.3 and with certain PDF's it randomly highlights in various colors blocks of text.  Scrolling up and down alters the highlighted area semi randomly.  Printing the document is fine.  I should note that being logged in to the terminal server console or rdp into it these types of documents are fine.   When using a thin client (in this case a boundless capio) with a low color resolution capability the issue is present.  Using some other thin clients with a higher color/resolution capability do not have the issue.

     

    The stated workaround of Edit>preferences> Page display category> Rendering>smooth text  changed from default of for Laptop/LCD screesn to None does correct the issue for us.

     

    What I would really like to know however, is how to automate turning this off post deployment or even how to adjust this setting in building the deployment in the first place  (either through adobe customization wizard or through an msi editor like orca).

     

    Thanks,

    Paul

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 16, 2009 9:42 AM   in reply to ErluUndomiel

    Okay. Here is what I found. These settings are changed\saved under the User settings in the registry. Here is the key the changes are made to:

     

    \\HKCU\Software\Adobe\Adobe Reader\9.0\Originals

     

    When "NONE" is selected from Adobe Reader - Edit - Preferences - Page Display - Rendering, three DWORD values are added to the above mentioned registry key. These are:

     

    Value Name - Value Data
    bAntialiasText - 0
    benableDDR - 0
    iAntialiasThreshold - 12

     

    I have added these lines to a login script that adds the necessary DWORD values to default the "Rendering" to NONE.

     

    reg add "HKCU\Software\Adobe\Acrobat Reader\9.0\Originals" /V bAntialiasText /T REG_DWORD /F /D 0
    reg add "HKCU\Software\Adobe\Acrobat Reader\9.0\Originals" /V benableDDR /T REG_DWORD /F /D 0
    reg add "HKCU\Software\Adobe\Acrobat Reader\9.0\Originals" /V iAntialiasThreshold /T REG_DWORD /F /D 12

     

    Cheers!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 16, 2009 10:47 AM   in reply to RichJWilson

    Very cool. Thanks for the info!

     

    Date: Fri, 16 Oct 2009 10:42:24 -0600

    From: forums@adobe.com

    To: strobel_paul@hotmail.com

    Subject: Re: Adobe Reader 9 highlights text when scrolling in terminal server Adobe Reader 9 highlights text when scrolling in terminal server

     

    Okay. Here is what I found. These settings are changed\saved under the User settings in the registry. Here is the key the changes are made to:

     


    HKCU\Software\Adobe\Adobe Reader\9.0\Originals

     

    When "NONE" is selected from Adobe Reader - Edit - Preferences - Page Display - Rendering, three DWORD values are added to the above mentioned registry key. These are:

     

    Value Name - Value Data

    *bAntialiasText - 0

    benableDDR - 0

    iAntialiasThreshold - 12*

     

    I have added these lines to a login script that adds the necessary DWORD values to default the "Rendering" to NONE.

     

    *reg add "HKCU\Software\Adobe\Acrobat Reader\9.0\Originals" /V bAntialiasText /T REG_DWORD /F /D 0

    reg add "HKCU\Software\Adobe\Acrobat Reader\9.0\Originals" /V benableDDR /T REG_DWORD /F /D 0

    reg add "HKCU\Software\Adobe\Acrobat Reader\9.0\Originals" /V iAntialiasThreshold /T REG_DWORD /F /D 12*

     

    Cheers!

    >

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2010 4:13 PM   in reply to ErluUndomiel

    I'm using adobe reader 9.40 and have been dealing with this ever since I upgraded to 9.

     

    The work around is go to Edit --> Preferences --> Page Display

     

    than uncheck "Use 2D graphics acceleration"

     

    than uncheck "Smooth line art" and "Smooth images"

     

    Sure am glad that got resolved .... what a pain !!

     

    : )

     

    b

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points