Skip navigation
anoweb
Currently Being Moderated

Content Assist Error

Jun 30, 2009 3:53 AM

While using Flash Builder 4 beta things will be working fine and then all of a sudden I get a popup error saying:

 

"Content Assist" did not complete normally.  Please see the log for more information.

java.lang.NullPointerException

I'm not sure where the log file is, but if I restart Eclipse (i.e. Flash Builder) things will work again, for a little while, then the error comes back.
Any ideas?

 
Replies
  • Currently Being Moderated
    Jul 1, 2009 6:49 AM   in reply to anoweb

    Hi,

     

    I have this error too. In my case it helps to remove and add the Flas SDK 4 to the project. Unfortunately this error message is thrown every 30 seconds, so I have to set the SDK all the time instead of do some coding.

     

    The result is I use FB3.

     

    @Adobe guys: any ideas?

     

    Regards,

    Christoph

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 6, 2009 9:54 AM   in reply to anoweb

    The log file is in your workspace/.metadata/.log. You can also access it in the UI at:

     

    Help > About Eclipse Platform > Configuration Details > View Error Log

     

    If you can find the error message still, please file a bug. Thanks!

     

    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2009 9:38 PM   in reply to Jason San Jose

    HI,I had get this error to.

    And this is the log file . Is there any method to fix it?thanks.


    !ENTRY org.eclipse.ui 4 4 2009-09-25 12:32:13.878
    !MESSAGE "Content Assist" did not complete normally.  Please see the log for more information.

     

    !ENTRY org.eclipse.ui 4 0 2009-09-25 12:32:13.878
    !MESSAGE java.lang.NullPointerException
    !STACK 0
    java.lang.NullPointerException
        at com.adobe.flexbuilder.codemodel.internal.asdoc.ClassCommentRef.<init> (ClassCommentRef.java:36)
        at com.adobe.flexbuilder.codemodel.internal.tree.ClassNode.getDynamicCom mentRef(ClassNode.java:698)
        at com.adobe.flexbuilder.codemodel.internal.tree.BaseDefinitionNode.getC omment(BaseDefinitionNode.java:273)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProposa l.<init>(ActionScriptCompletionProposal.java:145)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.getTypeProposal(ActionScriptCompletionProcessor.java:654)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.createProposalsFromDefinitions(ActionScriptCompletionProcessor.java :903)
        at com.adobe.flexbuilder.dcrad.core.DCRADContentAssistProcessor.createPr oposalsFromDefinitions(DCRADContentAssistProcessor.java:131)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.createLocalVariableProposals(ActionScriptCompletionProcessor.java:7 53)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.computeCompletionProposals(ActionScriptCompletionProcessor.java:109 1)
        at com.adobe.flexide.mxml.core.editor.MXMLActionScriptCompletionProcesso r.computeCompletionProposals(MXMLActionScriptCompletionProcessor.java: 161)
        at com.adobe.flexbuilder.dcrad.core.DCRADContentAssistProcessor.computeC ompletionProposals(DCRADContentAssistProcessor.java:103)
        at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompleti onProposals(ContentAssistant.java:1832)
        at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeP roposals(CompletionProposalPopup.java:556)
        at org.eclipse.jface.text.contentassist.CompletionProposalPopup.access$1 6(CompletionProposalPopup.java:553)
        at org.eclipse.jface.text.contentassist.CompletionProposalPopup$2.run(Co mpletionProposalPopup.java:488)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        at org.eclipse.jface.text.contentassist.CompletionProposalPopup.showProp osals(CompletionProposalPopup.java:482)
        at org.eclipse.jface.text.contentassist.ContentAssistant.showPossibleCom pletions(ContentAssistant.java:1660)
        at org.eclipse.jface.text.source.SourceViewer.doOperation(SourceViewer.j ava:835)
        at org.eclipse.jface.text.source.projection.ProjectionViewer.doOperation (ProjectionViewer.java:1533)
        at com.adobe.flexide.editorcore.editor.FlexSourceViewer.doOperation(Flex SourceViewer.java:158)
        at org.eclipse.ui.texteditor.TextOperationAction$1.run(TextOperationActi on.java:131)
        at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        at org.eclipse.ui.texteditor.TextOperationAction.run(TextOperationAction .java:129)
        at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
        at org.eclipse.ui.commands.ActionHandler.execute(ActionHandler.java:185)
        at org.eclipse.ui.internal.handlers.LegacyHandlerWrapper.execute(LegacyH andlerWrapper.java:109)
        at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
        at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(Para meterizedCommand.java:508)
        at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(Handle rService.java:169)
        at org.eclipse.ui.internal.keys.WorkbenchKeyboard.executeCommand(Workben chKeyboard.java:470)
        at org.eclipse.ui.internal.keys.WorkbenchKeyboard.press(WorkbenchKeyboar d.java:824)
        at org.eclipse.ui.internal.keys.WorkbenchKeyboard.processKeyEvent(Workbe nchKeyboard.java:880)
        at org.eclipse.ui.internal.keys.WorkbenchKeyboard.filterKeySequenceBindi ngs(WorkbenchKeyboard.java:569)
        at org.eclipse.ui.internal.keys.WorkbenchKeyboard.access$3(WorkbenchKeyb oard.java:510)
        at org.eclipse.ui.internal.keys.WorkbenchKeyboard$KeyDownFilter.handleEv ent(WorkbenchKeyboard.java:125)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1191)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1002)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1027)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1012)
        at org.eclipse.swt.widgets.Control.traverse(Control.java:3658)
        at org.eclipse.swt.widgets.Control.translateMnemonic(Control.java:3502)
        at org.eclipse.swt.widgets.Composite.translateMnemonic(Composite.java:10 65)
        at org.eclipse.swt.widgets.Control.translateMnemonic(Control.java:3520)
        at org.eclipse.swt.widgets.Display.translateMnemonic(Display.java:4401)
        at org.eclipse.swt.widgets.Display.filterMessage(Display.java:1205)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3469)
        at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2405)
        at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2369)
        at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2221)
        at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:500)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.ja va:332)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.jav a:493)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEAppli cation.java:113)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandl e.java:194)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runAppli cation(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Ec lipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.ja va:368)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.ja va:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl. java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces sorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 2, 2009 2:58 AM   in reply to anoweb

    Hi,

     

    I have the same error too ... => I can't use Flash Builder for my work on Flex 4, so i use Flex Builder 3.

    But have you a fix for this problem ?

     

    For informations :

    I use the last version of Flash Builder, and Java.

    I try to update Eclipse but the error still exist.

     

    ML

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2009 12:01 AM   in reply to anoweb

    Same error for me and all the members of my team.

    In particular cases, it keeps throwing me the null pointer exception while using content assist via CTRL+Space.

     

    This is really annoying my Flex 4 development. Is there a workaround?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2009 8:25 AM   in reply to Alconis-MY9GnN

    Have you seen this error in Beta 2? If so, please file a bug with a reproducable case. In some cases though, a clean workspace fixes the problem. Not the best workaround, but it's worth a try.

     

    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2009 8:30 AM   in reply to Jason San Jose

    What I really meant to say is, please add your comments and workspace log to this bug http://bugs.adobe.com/jira/browse/FB-21566.

     

    It's been a tough one to track down, it doesn't happen for everyone. Any additional info you can provide would be great: project type, SDK version (and build number if you're using a nightly), file type, and library path would all be helpful here.

     

    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2009 12:12 AM   in reply to Jason San Jose

    this bug never appeard in this two days when i used it.I think it's been fix now.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2009 12:31 AM   in reply to ZhouTao

    No, it's not been fixed. I'm still experiencing it with Flash Builder Beta 2 following configuration :

     

    Adobe Flash Builder Standalone: version 4.0.0.253292

    Flex 4.0.0 SDK: build 10485

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2009 2:22 PM   in reply to Alconis-MY9GnN

    Any libraries on your library path? If you're willing/able, please send us your project as an FXP or your workspace .metadata folder for the log and Eclipse/FB caches.

     

    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2009 11:53 PM   in reply to Alconis-MY9GnN

    I am having the same problem. Did you find any solution to it?

    Thanks, Carmen

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2009 12:49 AM   in reply to AdelaCampean

    Are any of you using subclipse for versioning? Maybe that is the problem...

    On the project I am using subclipse I have this error. On another project where I am not using subclipse I do not have the error.

    Anyway... any suggestion would be very very appreaciated!

    thank you

    C

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 9, 2009 1:40 PM   in reply to AdelaCampean

    https://bugs.adobe.com/jira/browse/FB-21566

     

    Repeating on the bug comments and on the beta forum...

     

    PLEASE try a clean workspace. In detail:

     

    1) Export the project as an FXP from the workspace that has the problem

    2) File > Switch Workspace > Other..., choose a new, empty folder

    3) Import the FXP

    4) Try code hints

     

    We have in the past seen problems with workspace caches. If we can rule this out, it would help us a lot. I'm trying my best to reproduce the issue, but with no success. The error indicates that a class in your project has no ancestor project...which normally isn't possible unless a cache has gone bad. Again, I need more help since I can't reproduce this. Thanks guys.

     

    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 13, 2009 1:23 AM   in reply to Jason San Jose

    With a clean workspace it's the same (Beta 2)

     

    !ENTRY org.eclipse.ui 4 4 2009-10-13 10:15:27.339
    !MESSAGE La commande "Assistant de contenu" ne s'est pas exécutée normalement.  Pour plus d'informations, consultez le journal.

     

    !ENTRY org.eclipse.ui 4 0 2009-10-13 10:15:27.339
    !MESSAGE java.lang.NullPointerException
    !STACK 0
    java.lang.NullPointerException
        at com.adobe.flexbuilder.codemodel.internal.asdoc.ClassCommentRef.<init> (ClassCommentRef.java:36)
        at com.adobe.flexbuilder.codemodel.internal.tree.ClassNode.getDynamicCom mentRef(ClassNode.java:779)
        at com.adobe.flexbuilder.codemodel.internal.tree.BaseDefinitionNode.getC omment(BaseDefinitionNode.java:334)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProposa l.<init>(ActionScriptCompletionProposal.java:151)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.getTypeProposal(ActionScriptCompletionProcessor.java:691)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.createProposalsFromDefinitions(ActionScriptCompletionProcessor.java :952)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.createLocalProposals(ActionScriptCompletionProcessor.java:786)
        at com.adobe.flexide.as.core.contentassist.ActionScriptCompletionProcess or.computeCompletionProposals(ActionScriptCompletionProcessor.java:114 2)
        at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompleti onProposals(ContentAssistant.java:1836)

    ...

     

    Giz

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2009 8:24 AM   in reply to Jason San Jose

    A more surgical workaround that allows you to keep your workspace settings:

     

    1) Quit FB

    2) Delete this folder: .metadata\.plugins\com.adobe.flexbuilder.codemodel

    3) Restart FB

     

    Cleaning out the caches works for most people, but others are still reporting the same issues after the workarounds. We're continuing to track this bug here http://bugs.adobe.com/jira/browse/FB-21566.

     


    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 28, 2009 5:52 AM   in reply to Jason San Jose

    This works for me.

    Thank you!

    Carmen

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2010 8:31 AM   in reply to Jason San Jose

    It seems that the following:

     

    "Delete this folder: .metadata\.plugins\com.adobe.flexbuilder.codemodel"

     

    is the current workaround.

     

    Can someone point me to where that folder is on OSX?  I've dug and dug, and removed similar folders, but nothing fixes the issue.

     

    Thanks in advance...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2010 9:36 AM   in reply to pajr

    The default location is /Users/username/Documents/Adobe Flash Builder 4/

     

    Jason San Jose

    Quality Engineer, Flash Builder

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 1, 2010 7:30 PM   in reply to anoweb

    if you want to solve this problem.

    you have to have a well operated workspace....

    (i have several workspaces one of them is broken some of them are working well)

     

    all you need to do is copy the folder in well working workspace. (.metadata/.plugins/com.adobe.flexbuilder.codemodel)

    and then paste in to current workspace you were working on...

     

    try and hit me back if you have any question~!

     

    barty82@naver.com

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 5, 2010 7:16 PM   in reply to anoweb

    Every time I export a new swc from Flash I get this error. I don't have to replace any files in the .metadata, I just reboot Flash Builder. Anyone else having this problem?

     

    -gordon

    www.gordonpeterson.org

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points