Skip navigation
Currently Being Moderated

how to maintain aspect ratio when creating PDF (Acrobat Pro 8.1.0)

Oct 21, 2009 7:37 AM

The company I work for relies heavily on PDF creation of banners, ad units and various elements that have set aspect ratios.  The clients tend to need to see "exact sizes" when viewing the PDF, however there tends to always be an upscaling of aspect ratios when creating the PDFs.

 

For example, an ad unit might be 300x600.  No matter what program I create the files in (ie Fireworks, Photoshop, all currently CS3) when I create the PDF and compare it with the native file the ratio is larger, even when you set the page view to 100%.  75% seems to show something close but we need to have an exact representation - so the 300x600 unit would be 300x600 in Acrobat.

 

Is there a way to constrain the aspect ratio while creating a PDF?  When I checked out the options (during multiple file creation there isn't many options to choose from).

 

Any suggestions are welcome.  Thanks!

 
Replies
  • Currently Being Moderated
    Oct 21, 2009 8:17 AM   in reply to Bit Crusher

    I'm not sure what you're asking but:

     

    Photoshop maps the PPI of the image to your screen resolution when viewing at actual size (100%). So if the file is 300 PPI and your monitor is 90 PPI the image is enlarged 333.3% (300 / 90)

     

    If you view the Photoshop PDF in Acrobat it (tries) to show the actual size of the file. To view aspect ratio you would need to zoom to 333.3%

     

    Under Prefs: Page display you can set a custom zoom preference (magnification). You may or may not want to do this because it affects the files you open.

     

    You can set a specific zoom for an individual file. File: Properties: Initial View and you can set a custom magnification. Then anyone else who has the zoom preference "Automatic" will see this particular file at the specified zoom.

     

    Be careful if you do this to a Photoshop PDF however. If you edit a Photoshop PDF with Acrobat, Photoshop will probably give a warning if you open the PDF in Photoshop later on to edit. A possible workflow to deal with this issue is keeping the native Photoshop working files as PSD, and just save PDF copies (treat it like an output)

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2009 9:01 AM   in reply to Bit Crusher

    Bit Crusher wrote:

     

    huh.  well that's just odd that acrobat would base how to display a PDF on the screen resolution.

    No, this is Photoshop behavior.

     

    To understand go to Image Size in Photoshop. Click off resample and change the width or height. When you do this, Photoshop does not change the view, and it still says 100%. The view is independent of the physical dimensions of the file, it's based on the pixels.

     

    Pixels dimensions do not specify a physical size. You need pixels per unit measurement to convey a size. A 7 megapixel image could be as small as a thumbnail or as big as a football field, it's just squares until you know the size of the squares.

     

    Acrobat, unlike Photoshop, tries to display the physical size of the file. So if it is 5" x 3" it should measure close to that when you view at 100%.

     

    You have to decide if you want the client to view at the physical size or see the pixels at aspect ratio (the problem with aspect ratio though is you can't know what the client's monitor resolution is)

     

    But if you do know the monitor res you can get the same view in Acrobat that you see in Photoshop. Go to Prefs: Page Display: and look at the system setting.

     

    A couple of solutions. If you always have 72 PPI images, set to custom resolution 72 PPI, then change the Zoom to 100% (actual size). Or, leave the system setting as is (i.e. 90 PPI). 72 / 90 = .8. Set the zoom to 80%.

     

    This is a general preference. To set it for specific files you have to go to Document Properties: Initial View and change the magnification.

     

    From your snapshot it appears you screen might be around 90 PPI, so an 80% zoom would get you there.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2009 9:26 AM   in reply to Bit Crusher

    To get a PDF to display at the true size you would set the zoom to 100. Then to see that same size in Photoshop, View Print Size.

     

    The default zoom (Automatic) for Acrobat is Fit Page for landscape documents and Fit Width for portrait documents. So if you made a PDF from InDesign, the zoom percentage would depend on both the InDesign document size as well as the size of the display. I don't like the portraits at fit width so I set my pref to Fit page, but other people may like the default behavior.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2009 10:18 AM   in reply to Bit Crusher

    Bit Crusher wrote:

     

    well, I took your advice and monkeyed around with photoshop - turned off the "resample image" and then set the ppi for 100.  when I viewed the PDF in acrobat...and set the view for 100% it was pretty damn close.

    That would be the same if your monitor resolution was 100 PPI.

     

    To see the monitor res in Acrobat Prefs:  Page Display, by use system setting what is the number?

     

    It is probably 90.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2009 10:47 AM   in reply to Printer_Rick

    on a 17 by 17 monitor it would be 98.

     

    Acrobatpicture002.png

     

    This is setup for Acrobat 9 But I belive Acrobat 8 was similar.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 10:13 PM   in reply to Phillip Jones

    This problem haunted me for a long time however it's easy to fix. I'm a graphic designer and I often present work containing jpg images in a combined PDF document.

     

    Very early on I discovered that Acrobats default resolution is 98 pixels/inch, which causes it to incorrectly scale a 72 pixels/inch raster image when trying to show it at actual size.

     

    To fix the problem, go Acrobat > Preferences > Page Display.

    Then under resolution, set the Custom Resolution to 72 pixels/inch.

     

    That should fix your issue. However you may run into issues when trying to view vector documents at correct actual size. In the event that this happens just set the resolution preference setting back to 98.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points