Skip navigation
Currently Being Moderated

Acrobat v8 doesn't like Cambria

Oct 21, 2009 1:09 PM

Hi,

I have started using Cambria font in all my MS Word 2007 documents. When I try print the documents to pdf using the Acrobat plug-in, I am unable to do. Problem seems to be caused by an incompatibility with Cambria font.

Current version of Acrobat Professional is 8.1.7.

 

MS Word's "Save As PDF" addon works. Is there a fix to the Acrobat plug-in I can use?

 

Interestingly, I don't have any problems with Cambria font and Excel 2007 printing to pdf.

 

Rael

 
Replies
  • Currently Being Moderated
    Oct 21, 2009 9:05 PM   in reply to rael07

    I have not had a problem. You do not indicate what the problem is, but it is likely that you are not embedding the font. Check your job settings and be sure the Cambria is set to embed. You can also check a PDF and see if the font is getting embedded.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 5:01 PM   in reply to rael07

    Anyone???

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 3, 2009 7:49 PM   in reply to rael07

    I will try to see if I can replicate the problem on my VISTA machine with WORD 2007 and Acrobat 8.1.7. I have not had a problem with WORD there, but then it may be some of your setup. Knowing what job settings you are using would help. You can also select to produce the PDF in the job settings even if the font is not found. It may be that the font is not properly registered in Distiller (though the create PDF option in WORD 2007 works differently that previous versions apparently, but I am not sure if that started with AA9 or AA8). You can check the font list in Distiller.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 10:29 AM   in reply to Bill@VT

    Was using the default distiller settings. Cambria is listed there as a font. I have fiddled with some of the Font settings in distiller, saved the modified option file and selected to use the modified option file in the Adobe PDF printer settings. All without success.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2009 2:07 PM   in reply to rael07

    Similar problem here. I posted that also two month ago. It seems Adobe wants to sell newer releases or are they sleeping? At least their behaviour is disappointing whatever reasons they have.

     

    http://forums.adobe.com/message/2257354#2257354

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 13, 2009 7:46 AM   in reply to rael_lucid

    I ran the docx file through WORD 2007 and AA8. I had no problem. I am not sure what you mean by default. I will go back and try it with the standard setting and see what happens. Did you use the Adobe PDF printer or the PDF Maker in WORD? If the latter, you need to check the PDF Maker preference to see what job settings you did use. I am not sure how that default is set.

     

    I went back and used both the printer and PDF Maker with the standard and smallest size settings (I do not recommend either in general). In all cases the Cambria font was embedded with no problem. Apparently you have an issue with your Cambria on your system. I do not remember the system you have, but I am running VISTA for the test with AA8. It may be that the version of Cambria that you have on your system is not compatible with the font you are using in WORD. There is more to the name of a font and it may be that you have an incompatible version.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2009 9:56 AM   in reply to Bill@VT

    Hi Bill,

     

    By 'default', I mean that I did not amend any of the settings when I installed the software. It has installed with whatever settings Adobe deems to be the standard installation settings. I am running Windows 7 with Office 2007. All the latest patches and service packs. I have also not installed any software that would logically mess with the fonts - I don't have any other desktop publishing, graphic or similar software installed. But perhaps something seemingly random has messed with the fonts.

    Anyway, I have resigned myself to the problem continuing. So will either upgrade to Acrobat 9 (unlikely) or continue with other solutions.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2009 2:43 PM   in reply to rael_lucid

    What job settings file are you using in Acrobat. This is listed in the properties of the printer when using the printer and under the preferences for create PDF when using PDF Maker.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2009 9:12 AM   in reply to rael07

    I had a similar problem.

     

    %%[ ProductName: Distiller ]%%

    %%[Page: 1]%%

    %%[Page: 2]%%

    %%[Page: 3]%%

    %%[Page: 4]%%

    %%[Page: 5]%%

    %%[Page: 6]%%

    %%[Page: 7]%%

    Cambria not found, using Courier.

    %%[ Error: invalidfont; OffendingCommand: xshow ]%%

     

    Stack:

    [85 0]

    (  )

     

     

    %%[ Flushing: rest of job (to end-of-file) will be ignored ]%%

    %%[ Warning: PostScript error. No PDF file produced. ] %%

     

    I was able to resolve it by changing a one of the Adobe PDF printer settings.  When you are in the print dialog, and you have selected the appropriate PDF printer, select "Properties."  In the dialog box, there should be a tab titled "Adobe PDF Settings," and it should look like the below image.  You need to un-check "Rely on system fonts only; do not use document fonts."  I'm going to bet you created this document using XP or Vista, then upgraded to Windows 7.  I'll go further to guess the Cambria font somehow gets changed between XP/Vista and Win7.  In any case, I had a document I created using Word 2007 in Vista that I could print o a PDF.  Then, after upgrading to the RC version of Win7, I couldn't print the document to a PDF anymore.  Un-checking the box I mentioned here seems to fix the issue.  I'll reply back if I ever find a situation where this "fix" does not work.

     

    Capture.PNG

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2009 11:54 AM   in reply to p.smith0099

    Great, this Workaround works for me! Thx

     

    At least this solves all my PDF related problems with Office 2007 and W7.

    Only the IE8 (32bit at least) crash when printing a PDF of a Webpage over Page Preview left.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2009 1:05 PM   in reply to p.smith0099

    Great fix... thanks!!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2009 6:44 PM   in reply to p.smith0099

    P.Smith -

     

    Thanks.  I had the exact same problem after upgrading my Vista to Windows 7 and it was driving me nuts!  I had changed so many Distiller settings that I couldn't keep things straight. I could make PDFs from Excel and PowerPoint - just not Word.  I hope things 'straighten out' in Acrobat 9 - I'd hate to have this 'workaround' be the 'long-term' solution.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2010 6:30 AM   in reply to rls8r

    I know this is a couple of months old, but I was having the same issue. I also did the fix listed above, but went in the settings and manually selected to ALWAYS embed Cambria fonts. I am using Windows 7 with Acrobat Pro 8. Under devices and printers I went to the Adobe PDF printer, right clicked and selected Printer Properties. Then I clicked Preferences. Under default settings I chose to Edit (This is under Adobe PDF Settings). I then chose font and chose to Always Embed cambria fonts by highlighting them and clicking Add. I also saved these settings to use just in case I ever forgot how to do this fix. Hope that helps anyone else that might have still been frustrated. I can now right click on my Word docs and choose to convert again. Woohoo!

    Untitled.gif

     

    And P Smith, as to the IE crash with Adobe. I fixed that by changing my associations to my 64 bit Programs folder instead of the one in the regular Programs folder.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2010 8:07 AM   in reply to gingerly

    In my opinion, you should always embed fonts in your pdf files. You never know what fonts other viewers may or may not have.

     

    Part of the problem is Abobe's confusing user interface. There is a checklist with 5 items, three of which are positives and two of which are negatives. Good user inteface design dictates that grouped checklists should all be all positive or all negative, not a mix.

    Wouldn't it be easier if the checklist were:

     

    adobe.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2010 6:28 AM   in reply to gingerly

    I am having this problem (Win 7 64-bit) and none of these solutions works for me.

     

    I've tried unchecking "use system fonts" in the dialog and changing the settings to embed all fonts, as well as telling Distiller to ignore errors and create the PDF anyway and nothing works. Acrobat 8 still complains about Cambria.

     

    This is a huge problem because I have several hundred pages of Word Pro files that need to be PDFed. I haven't had problems with them in the past (I last PDFed them back in December and January), but there's something about the current iteration of Acrobat 8 because I tried just now on another system running XP Pro, Word 2010, and Acrobat 8 and have the same problem. It's not specifically related to Win7 64-bit/Word Pro.

     

    I would appreciate any suggestions. I'm working on rewriting most of a 500 page manual within the next couple or three weeks.

     

    Thanks,

     

    liz

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2010 4:24 PM   in reply to LizBRLA

    A possible fix (or at least a workaround). I researched free pdf creators and chose one of the highest-rated ones to install. I was able to create a PDF without any problems on two computers from files that had caused problems. Now I'm able to use Acrobat 8 to create PDFs from the same files it was choking on before. I'm not sure what was munged, but using a different PDF creator seemed to unmung it. If it's munged again, I'll just use the freebie for PDF creation and Acrobat for editing.

     

    liz

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2010 8:17 AM   in reply to rael07

    Generally

    This problem never occurs

    Can you tell me in detail exactly what happened when you did this?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2010 8:35 AM   in reply to LizBRLA

    The "fix" didn't last long. If Acrobat gives this error message, I just use the alternative and get the PDF I need. I may just quit creating PDFs with Acrobat since I am never sure when it's going to work and when it's not. The alternative works every time.

     

    liz

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2010 8:54 AM   in reply to LizBRLA

    Plz don't use free softwares available online.. Just visit adobe and choose the right one...

    This problem occurs when you use some unprofessional software & link them with adobe...

    It might not be a good answer to your question but yes.. I can help you to reach to your answer..

    Praveen

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2010 4:19 PM   in reply to rael07

    Rael07,

     

    Couldn't agree with you more about the attitude. I've been using Acrobat 8 and Cambria for quite awhile and things used to work properly. I don't know what has happened, but it's definitely broken now.

     

    Unfortunately, your solution won't work for me since I'm not printing from MS Office most of the time. I'm just relieved that I have a solution, but wonder why third-party free PDF creators work just fine but the "real thing" doesn't. That doesn't exactly speak well for Adobe, and it's not like Cambria is some sort of off-brand, non-standard, uncommon font.

     

    liz

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2010 7:35 AM   in reply to LizBRLA

    I agree: a reply from Adobe that is other than helpful is very disturbing.  I hope they are not going the way of Microsoft as far as answering the "peons" who use their products with an attitude of disdain or indifference (or both).  It would be very refreshing to know that Adobe actually values their customers' problems and jumps on it to figure out the problem, no matter how "small" the problem seems to them.

     

    I have run into this issue, now that I've upgraded from Windows XP to Windows 7.  I am using FrameMaker 8's Save As PDF menu option.  I tried the solutions provided above.  Nothing worked for me.  However, I tried something on a hunch and found a solution.

     

    I had, for some reason lost to me now, saved the Cambria fonts to a separate folder back when I first installed Microsoft Office 2007.  All are .TTF files (with one .TTC file) and all are dated August or September, 2006.  Just now, I copied those files into my Windows/Fonts folder, thereby replacing the current ones.  Voila!  Now Distiller works just fine with no errors.  I've created more than one document and so far, so good.

     

    If I run into any problems (like the issue resurfaces after I reboot), I'll post something again; otherwise, here's to hoping this is the "fix."

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 26, 2010 3:54 AM   in reply to rael07

    I have also run into this problem.  Windows 7, MS Word 2007, up to date version of Acrobat 8 is the setup.  If I uncheck the box on the print>>properties >>rely on system fonts only;do not use document fots, it seems to work.

     

    I also added the fonts in the acrobat screens as per another poster's suggestions, but the conversion process stops when Acrobat sees the Cambria font.

     

    Another poster used old fonts - perhaps I sould pull someoff another old machine and test it out.

     

    Is Adobe going to fix this?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 26, 2010 6:05 PM   in reply to Jim06812

    @Jim06812: Acrobat 8 is not Windows 7 compatible.

     

    Nothing but security fixes for any version but 9. Even version 9 fixes may be not be available for long since version 10 should be around the corner.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2011 2:25 PM   in reply to rael07

    I have almost all the problems detailed in this forum, and none of the proposed solutions solve them.

     

    I am using Office 2010, and Adobe Acrobat Pro 9 Extended on Windows XP.  When I choose "Save As" and choose pdf, my Cambria Math equations are missing pieces.  When I choose "Print" and then employ the Adobe PDF Printer, The equations are replaced by a horizontal line.

     

    I have tried to disable "Rely on system fonts only; do not use document fonts" in Adobe PDF Printing Preferences.  This does nothing.

     

    I have tried to  "Always Embed" all 5 Cambria Fonts (Cambria, Bambria-Bold, Cambria-BoldItalic, Cambria-Italic, and CambriaMath) in the Adobe PDF Settings box stemming from the "Edit" option in the preferences.  This does nothing.

     

    I have tried reinstalling old cambria.ttc, cambriaz.ttf, cambriab.ttf, and cambriai.ttf fonts from 2009 to my windows/fonts folder.  This does nothing.

     

    I have tried installing new cambria.ttc, cambriaz.ttf, cambriab.ttf, and cambriai.ttf fonts from 2011 to my windows/fonts folder.  This does nothing.

     

     

    It's impressive how there is NO solution to this problem, and I depend on creating pdfs with equations from Word.  Help?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2011 3:06 PM   in reply to mnhoff

    PDFill is the freebie product that works great for me. I continue to have the problem with Cambria, or barfing Acrobat. Never have a problem with PDFill and the files it creates are editable in Acrobat.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2011 3:20 PM   in reply to mnhoff

    Have a look at the Adobe KB article

     

    Acrobat 9 PDFMaker and Microsoft Office 2010 | Known issues

     

    Can you print to the Acrobat PDF printer?

     

    Have you tried OpenOffice.org?

     

    Does your version of the cambia font have any licensing restrictions?

     

    Math symbols may require special handling or even a special program created to deal with them. Look at a product like LaTex.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2011 4:32 PM   in reply to GKaiseril

    Thanks all for your efforts.  Unfortunately I still have the problem...

     

    -Rael, read my post #28, 2nd paragraph, to see that indeed I tried the 'Save As, .pdf', but the equations were missing pieces.

     

    -LizBRLA, I tried installing PDFill on top of Acrobat Pro 9, and it corrupted all my Word files.  I deinstalled Acrobat Pro, installed Acrobat Reader, then installed PDFill...it worked, but it doesn't fix the Cambria Math conversion problem; the equations do not survive in the final product.  For all those that are thinking of using PDFill, it is only useful if you don't have Acrobat Pro, which offers the same functionality.

     

    -GKaiseril, very good suggestions.  Printing to an Acrobat PDF Printer using Acrobat Pro OR PDFill works, but the Cambria Math equations disappear.

     

    How do I find out whether I have licensing restrictions on the Cambria font?

     

    I was hoping to avoid installing something like openoffice or LaTeX, as I have a lot of work already set in Word.  There should be a workaround where Word can still be employed.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2011 5:12 PM   in reply to GKaiseril

    Here are two solutions that have worked. It seems like it may be a problem with the equation editor in Office 2007+ on XP OS

     

    per Natasha Dsouza at Microsoft Support:

     

    Try the steps mentioned below and check if that helps:

    Windows XP > Control panel > Regional and language options > Languages tab > check the box for 'install files for complex script' and click on apply.

     

    Vista &7 should have complex script auto installed. See if that helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2011 5:27 PM   in reply to mnhoff

    Do you have XP for OS? Here is the Microsoft solution

     

    Try the steps mentioned below and check if that helps:

    Windows XP > Control panel > Regional and language options > Languages tab > check the box for 'install files for complex script' and click on apply.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2011 6:42 PM   in reply to jallisy

    WOW!!!  You solved it, jallisy!  Thank you so much, you are my savior.  Indeed I'm still on XP, but setting the regional settings killed the Cambria Math pdf problem.  Hooray!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2011 6:51 PM   in reply to mnhoff

    I read blurbs about the equation editor issue but don't work with it myself.

    So glad it helped!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points