Skip navigation
Bob TMT
Currently Being Moderated

"Cannot use adobe reader to view pdf in your web browser" error in Windows 7 and Acrobat pro 8.1.7

Oct 22, 2009 2:36 PM

I get the error "Cannot use adobe reader to view pdf in your web browser.  Reader will now exit.  Please exit your browser and try again" in Windows 7 x32 and Windows 7 x64 with Acrobat pro 8.1.7.  This happens when trying to open  a PDF file in Internet explorer 8.0.760 or when I open a PDF in Quickbooks 2008.  If I answer ok or cancel the file opens normally.  If I open acrobat 8 first then the pdf files open as expected.  I also tried a copy of Acrobat reader with no difference in the outcome.  Since this happens on two different computers one fresh copy of windows 7 x64 the other an upgrade to windows 7 x32 and they used to work before the change to windows 7, I assume there is some kind of incompatibility with windows 7 and acrobat.  Is this a known issue and will it be fixed in an update to acrobat in the near future?

 
Replies 1 2 3 Previous Next
  • Currently Being Moderated
    Nov 4, 2009 7:31 AM   in reply to Bob TMT

    You're not alone.  I have the exact same problem.  None of the Adobe updates fix this either; and not seeing any response from Adobe is making me wonder what's up.  All I know is the Boss is getting pissed at the error every time he needs to view an Internet PDF.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 7:39 AM   in reply to Bob TMT

    I am having the same problem, and after it occurs Acrobat will not open for me from the taskbar.  Any advice would be appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 8:44 AM   in reply to Bob TMT

    Exactly the same problem here. Using Windows 7 Professionnal (32b) with Mozilla FireFox 3.5.4 with Acrobat Pro 8.1.7 (bundled with my Creative Suite CS3). Except for the error message, most of time the PDF are displaying correctly into my web browser.

     

    I hope Adobe will release an hotfix soon because this is annoying and some time my PDF aren't displaying for real and I have to refresh... quit my browser... ect.

     

    Let's go Adobe, do something!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 8:48 AM   in reply to SimmZ_81

    For Windows 7 you will need Adobe Acrobat 9.1.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 8:58 AM   in reply to Bernd Alheit

    Why? Adobe clearly say on thier website than Acrobat 8 and Acrobat 9 are fully compatible to Windows 7.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 2:03 PM   in reply to Bob TMT

    I had the same problem. I checked file association for .pdf files and discovered it was associated with Adobe Acrobat rather that Adobe Reader. I changed the association to Adobe Reader, restarted my browser, opened a .pdf file online and the problem was solved.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2009 4:49 PM   in reply to saul2526

    You mean you install Adobe Reader (free version) OVER your actual Adobe Acrobat Professionnal? Because if I go inside my file association into Firefox all the choice I got in the scrolling menu is "Adobe Acrobat plugin (inside FireFox)" or "Adobe Acrobat 8 Profesionnal". There's nothing about Adobe Reader... that's why I assume you install Adobe Reader (free) over your Adobe Acrobat Pro.

     

    It's a possible solution I guess, but it's kinda annoying because I prefer to use the real Adobe Acrobat Professionnal to read my PDF because I use the advanced feature only included into the Pro. Reader version (Free) are very limited and I don't want to have to save all my PDF on desktop then open it manually into Adobe Reader Pro...

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2009 3:48 AM   in reply to SimmZ_81

    Generally installing both Reader and Acrobat is not recommended by Adobe. They may interact and create problems using one or the other. As far as the compatibility of Win7 with Acrobat versions, it would be nice to give a link to the compatibility statement that was made. In looking at the system requirements on the Adobe site for AA9 versions, there is not comment about Win7. Also, 64-bit versions have also been problematic. So specific references to the compatibility statements would be appropriate when stated.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2009 6:41 AM   in reply to Bill@VT

    I'm not familiar with Win7, but maybe You could investigate a little bit according to this good old tweak:

     

    Quote from message by Reinhard Franke - 07:48am Jul 30, 2003 Pacific:


    "[HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe]

    There you will find the full path to the program IE will use (Acrobat or Reader exe)."

     

    E.g. "C:\Programs\Adobe\Acrobat 7.0\Reader\AcroRd32.exe"

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2009 7:28 PM   in reply to Bob TMT

    Any answer on this???   The above suggestions didn't work for me. 

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2009 4:54 PM   in reply to Bill@VT

    The Windows 7 compatibility site says that Acrobat 9 is compatible.  It's silent on Acrobat 8.  I ran the Windows 7 compatibilityt checker before I upgraded and Acrobat 8 was not flagged as incompatible.  However, it did not appear in the list of specific programs that are compatible (or not).  It is certainly compatible in the sense that everything works except for getting the stupid message.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2009 5:48 AM   in reply to Bob TMT

    Same problem here.

     

    None of the above sollutions helped. To bad.

     

    I hope there will be a sollution soon as I really need version 8 to test my SAP Interactive forms (PDF within SAP Webdynpro)

    Attachments:
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2009 6:08 AM   in reply to tvandersluijs

    This is annoying - we need to keep this thread alive, maybe someday Adobe or someone will have an answer.  I  even installed Acro-Reader 9.x with my Acrobat 8.x, and I still get the "Cannot use Adobe Reader..." message.  This is not good.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2009 6:25 AM   in reply to billrp

    You're right Bill.

     

    Most internet advices on the issue regards an alternative browser and/or an alternative reader.

     

    E.g.: "Several users have been able to quickly an easily work around this issue by installing and using an alternative PDF reader. One good choice is the free Foxit Reader."

     

    Maybe You could do the testing with Foxit Reader. Or I may suggest PDF-XChange Viewer.

     

    http://download.cnet.com/PDF-XChange-Viewer/3000-10743_4-10598377.html

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2009 6:49 AM   in reply to P. Allan

    So I paid $xxx for Acrobat 8.x, yet I can't use it to view PDFs from websites.  And even the free Acroreader 9.x doesn't work.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2009 12:22 PM   in reply to Bob TMT

    Easy fix:

    1. Open Acrobat 8

    2. Go to Edit > Preferences > Internet

    3. Uncheck "Allow fast web view"

    ...

    vlad

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2009 1:10 PM   in reply to vladhazz

    Thanxs Vlad,

     

    But..... that doesn't work. Maybe after a restart.... but I have no high hopes.

     

    To bad !

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 14, 2009 9:44 PM   in reply to Bob TMT

    Here is the workaround/fix.

     

    1. Open Acrobat 8.1.7

    2. Go to Edit > Preferences > Internet

    3. Uncheck "Display PDF in Browser"

     

    Now when you click on a PDF link in a browsing session it will launch Adobe Acrobat Pro in a separate window to view the PDF instead of trying to view it inside of Internet Explorer.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2009 5:40 AM   in reply to captain-morgan

    Sorry, that is not going to work.

     

    I am a developer in SAP Webdynpro and I have to open PDF forms within the webpage. ( I interact with a server backend)

     

    So it might work for some of us. But not for me.

     

    Thanxs

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2009 5:26 PM   in reply to Bob TMT

    I simply registered the product and the error went away... I tried all of the above fixes but registering seemed to be what fixed it.  Be sure to restart your browser afterwards.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 17, 2009 5:50 PM   in reply to Bobjonez

    Ok, I just resolved this issue on my machine - running Windows 7 and Adobe 8.1.5 Professional - by just disabling the Adboe Splash Screen under Edit / Preferences / General / Application Startup.

     

    I also disabled the "Getting Started with Adobe Acrobat 8 Professional" screen that comes up when you open Adobe, by selecting the "do not show at startup" option on that window. See attached screen capture.

     

    Hope it helps you folks out there!

     

    cheers

    Attachments:
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 17, 2009 11:23 PM   in reply to jayfjunior

    Both above answers don't work for me.

     

    I don't have acrobat professional installed and splash screens are off.

    I cannot register acrobat reader.

     

    to bad.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 18, 2009 6:15 AM   in reply to vladhazz

    I've done some more experimenting, my solution (post 16) worked only because I had Acrobat open when I clicked a link to a PDF. That seems to be the trick, have Acrobat open, as impractical as that is.

    ...

    vlad

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 18, 2009 10:00 AM   in reply to Bob TMT

    I have this issue several times on various users PC's. What I've done to resolve is the following Registry import:

     

    1. Create a .reg file using Notepad

    2. Copy the following in document (all in between the hashmarks) or use registry doc i attached to this response

     

    --------------------

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\DefaultIcon]
    @="C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell\open]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\acrobat\shell\open\command]
    @="C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe /u \"%1\""

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SOFTWARE\Adobe\Acrobat\Exe]
    @="\"C:\\Program Files\\Adobe\\Reader 9.0\\Reader\\AcroRd32.exe\""

    -----------------------

     

    3. Save as something like AdobeFix.reg

    4. Run regedit and import this entry into your registry then restart PC.

    Attachments:
     
    |
    Mark as:
  • Currently Being Moderated
    Nov 18, 2009 10:40 PM   in reply to vladhazz

    Hi Vlad,

     

    Thanxs, it's inpractical yes, but this works !

     

    thanxs !

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2009 1:40 AM   in reply to blakmoon71

    People don't use blakmoon71 sollution unless you are working on a test machine.

     

    On my machine it totally screwed my adobe reader.

     

    I get more errors than ever, and no more pdf viewing inside a webbrowser.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2009 1:54 AM   in reply to tvandersluijs

    You could try a "modificated" version of blackmoons suggestion:

     

    1) In Windows Explorer change the default application for the file type pdf to the Adobe Reader.

     

    2) In the registry edit only this key "[HKEY_CLASSES_ROOT\Software\Adobe\Acrobat\Exe]" manually

    to the full path to the Adobe Reader.


    E.g. "C:\Program files\Adobe\Acrobat [version]\Reader\AcroRd32.exe"

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2009 2:12 AM   in reply to Bob TMT

    tvandersluijs - I'm sorry if that screwed up your machine however:

     

    1. What version of Adobe Reader are you using because as you can see the registry entry is for Adobe Reader 9, if ur using Adobe Reader 8 then u need to specify ur version as PAllens entry suggested - "E.g. "C:\Program files\Adobe\Acrobat [version]\Reader\AcroRd32.exe""

     

    2. I've used this solution significantly because I have come across this specific issue for multiple users.

     

    3. All the registry entry does is tell Windows what program to use by default to open/view PDF documents.

     

    My intention wasn't to screw up ur machine or anybody elses as I said I've used this solution many times however what I've should gave is the disclaimer to backup ur registry before u make mods so u can revert back in case. Also the ony other thing I can think of is that this solution was for Windows XP using registry editior 5, I'm noticing that the title of this thread is Windows 7.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2009 2:53 AM   in reply to blakmoon71

    Don't Worry blakmoon71. (yes I am using version 8, or I was using version 8... read on... read on....)

     

    It could not get any worse anyway, right ?

     

    And it actually helped at the end.

     

    First I could not use Reader 8 or 9 having the "cannot use adobe reader to......" error.

     

    After your so called fix, it was totally screwed.

     

    So I did a uninstall of 8. Restarted, did a clean of my register with CCleaner, did another restart, started Windows 7 into save mode, did another clean of my register with CCleaner, did a restart.

     

    Then I installed Adobe Reader 9 for windows 7.

     

    And guess what !

     

    The problem is gone !

     

    No more "Cannot use adobe reader to view pdf in your web browser" error !

     

    Wowowowooo !!!!!!!!!!!!!!!!!!!!!

     

    Finally it is gone. Don't know if the error would be gone if I installed reader 8 again. But for now I'm a happy person.

     

    So blakmoon71, thank you very much after all !!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2009 6:31 AM   in reply to tvandersluijs

    And I'm sure if Adobe would ever have a fix for this bug it would be to first do a reformat and reinstall of Windows.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 20, 2009 4:56 PM   in reply to Bob TMT

    Had the exact same problem on my computer running Windows 7 and Acrobat Pro 8.1. I also have both Firefox and IE 8.

     

    The solution that worked for me was really simple, just open Firefox and in the Tools menu, choose Internet options, goto the programs tab and change the associated action for PDF files to Use Adobe Acrobat 8.1.

     

    This solved the problem both in IE and Firefox. Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 21, 2009 6:59 AM   in reply to Bob TMT

    I've also been experiencing this same issue, for about three months now. (http://forums.adobe.com/thread/480371?tstart=0).  I'm not exactly an expert in these things, but I'm guessing the issues track back to the nppdf32.dll plugin.  For Firefox, it has not been updated since 8.1.3.  For Internet Explorer, the plugins appear to be from 8.1.  I opened nppdf32.dll with a hex editor, and although I couldn't find much of anything of any use to me, I did find the error message we're all seeing buried in the code.  Perhaps all that needs done is an update to the browser plugins?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2009 11:17 AM   in reply to Bob TMT

    After years of living with this problem, I finally found an easy solution!!

     

     

    This page contains a simple .reg file that fixes Adobe's PDF preview handler on 64-bit versions of Windows.

     

  • Open RegEdit and go to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{DC6EFB56-9CFA-464D-8880-44885D7DC193}

  • There should be an existing AppID value, incorrectly set to {6d2b5079-2f0b-48dd-ab7f-97cec514d30b}

  • Change the AppID value to {534A1E02-D58F-44f0-B58B-36CBED287C7C}

  •  

    Credit--> http://www.pretentiousname.com/adobe_pdf_x64_fix/index.html and Maximum PC December 2009 issue page 26

 
|
Mark as:
  • Currently Being Moderated
    Nov 22, 2009 1:26 PM   in reply to LarryCasey

    Thanks for the information, but this does not cure the issues I am experiencing with opening PDF's in a web browser with Windows 7 64-bit.  This may very well cure other issues involving preview handlers on 64-bit Windows, but I think the browser issues are related to the browser plugin and its compatibility with Windows 7, and not preview handlers.  After applying both registry edits discussed in the article, and then rebooting, I still get the "Cannot use Adobe Reader..." when trying to open PDF's in Firefox and IE8 on Windows 7 x64.

     

    I did not experience this problem on Vista x64 - only 7 x64.  Is this issue limited to 64-bit Windows 7, or are users also experiencing it on 32-bit Windows 7?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2009 4:22 PM   in reply to jrfendrick

    The original posting in this thread says the problem is in Win7 32 bit.  None of the "fixes' posted in this thread have fixed the problem for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 22, 2009 5:45 PM   in reply to Bob TMT

    Same here. None of the solutions above work for me.

     

    Actually the only workaround I found is to disable the PDF to open inside the browser's windows (instead it open into Acrobat program window).

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 23, 2009 5:27 AM   in reply to Bob TMT

    I had a similar problem using Firefox as a browser in Vista with Adobe Reader 9.2. The message says "The Adobe Acrobat

    /Reader that is running can not be used to view PDF files in a web browser. Please exit Adobe Acrobat/Reader and exit your web browser and try again"

     

    This is completely useless as advice and Adobe support is no help either. However, using the advice from this forum, I have tried various combinations to arrive at a solution that works:

     

    • Open Adobe Reader and uncheck the box "Display PDF in browser"; restart computer (only need to do this once)

     

    • Open Adobe Reader
    • Open the message website in Internet Explorer (not Firefox)
    • Go to the message; if a security message comes up as a banner, check OK to allow the file download
    • Go back to the message and it will open in Adobe Reader

     

    Not the cleanest solution but it's solved six months of headaches for me!

     

    Having read a little more, I also tried the Firefox solution from above. In my version:

     

    • In Firefox open 'Tools'
    • Open 'Options'
    • Change the option for opening 'Adobe Acrobat Document' to 'use Adobe Reader 9.2 (default)'

     

    I can now use both IE and Firefox - thanks for your suggestions!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 30, 2009 4:55 AM   in reply to Bob TMT

    After many hours of dealing with this problem, I finally got it to work.  I am using Windows 7 w/ 64 bit on a Sony Vaio.

    I had Adobe Acrobat 8 Pro and Acrobat Reader 9.2 loaded.  I noticed that when I got the error box, it was Acrobat 8 Pro that was generating it, not Reader 9.2.

     

    I checked file associations and it was associating pdf and pdfxml files to 8.1.  I changed it to 9.2.  No difference.  I went into Manage Add Ons and saw that my plug ins were mostly being used from 8.1, not 9.2.  Disabled and enabled the lot in many different ways, to no avail.

     

    I finally uninstalled 9.2 so that I only had 8.1 running anything pdf and it would work sometimes....but not without the error box first.  I basically gave up hope and was awaiting Adobe to fix their little problem.

     

    Then during the day, my Sony Vaio care went off and said it was time for a scheduled maintenance.  It cleans the registers, defragments etc etc, so I activated the maintenance.

     

    Later that evening, I decided to exercise futility once more and downloaded and installed Abobe Reader 9.2 once again to try and figure out this problem.

     

    Well....after the download, it works flawlessly everywhere it previously failed.  I rechecked the file associations in Windows 7 and they are now associated with 9.2...one of them still 8.1.  I checked the plug ins and they are still operating out of 8.1 except for one that is using 9.1.

     

    So the fix for me was uninstall 9.2, do a registry clean, re install 9.2.  I doubt if Adobe drummed up a fix between my problem and no problem.

     

    Good luck.

     
    |
    Mark as:
  • 1 2 3 Previous Next
    Actions

    More Like This

    • Retrieving data ...

    Bookmarked By (0)

    Answers + Points = Status

    • 10 points awarded for Correct Answers
    • 5 points awarded for Helpful Answers
    • 10,000+ points
    • 1,001-10,000 points
    • 501-1,000 points
    • 5-500 points