Skip navigation
Currently Being Moderated

Cairngorm 3 - getting started

Dec 2, 2009 3:56 PM

Hello,

 

I extracted the Cairngorm 3 source from svn.

 

Somewhat naively I typed

 

mvn clean package install

 

from the build-parent folder

 

That gave all kinds of missing dependencies most of which I was able to resolve using the libraries available in the svn extract

 

Currently I am still missing 2 which I can't seem to fix

 

 

1) org.spicefactory:cinnamon:swc:1.0.1

2) com.adobe.flexunit:flexunit:swc:4.0-beta-2-eventful

 

 

Is what I am trying to do not intended? Any other guidance as on how to resolve this?

 

Many thanks indeed

 

Peter

 
Replies
  • Currently Being Moderated
    Dec 3, 2009 6:47 AM   in reply to Peter.Coppens

    Hello Peter,

     

    As you guessed you need to install the swc in your maven repository.

    Locally what we have is a nexus server serving all those dependencies, unfortunately this nexus server is not public.

    Let's hope it will be one day.

     

    meanwhile the two swc you are missing should be available in the flexunit4 project swcs (on opensource.adobe.com)

    the cinnamon swc is a spicefactory project, you will find it, on their web site.

     

    Nevertheless I'll do my best to publish a decent repository at some point, I wished I had the time to do it now.

     

    Cheers,

     

    François

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 3, 2009 4:50 PM   in reply to Peter.Coppens

    Hello Peter,

     

    Thanks for the feedback I double checked, and you are right it does not make much sense and I could not figure out where this swc was supposed to be released.

    So I refactored a bit the code and now you should just depend on flexunit 4 beta 2.

    Update the source code from svn, you'll see !

     

    Cheers !

    François

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 4, 2009 12:22 AM   in reply to Peter.Coppens

    These one are lcds (LiveCycle Data Service), and so you need to download lcds 2.6.1.

    This is not open source software, it should only be needed by the library IntegrationDM.

     

    Cheers !

    François

     

    PS: Cairngorm 3 is still beta but you may also test drive cairngorm3 by downloading the released beta swc, look at the wiki

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 4, 2009 2:31 AM   in reply to Peter.Coppens

    Hi Peter,

     

    while we use Maven/Hudsion internally to build and control quality of Cairngorm 3 libraries, it wasn't our main priority at this point to also let others leverage this infrastructure. Just out of time/resource constraints we currently focus on guidelines and libraries around client side architecture. However, at a later point, we do plan to share more information on build automation and look forward to exchange ideas around this area. That said, why does this prevent you from viewing the current content i.e. around libraries?

     

    Alex

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 9, 2010 12:59 AM   in reply to Peter.Coppens

    fds-2.6.1.swc
    fds_rb-2.6.1.rb.swc

     

    Those two I found under

    cairngorm3/tags/Integration-0.2/libraries/Integration/libs/

    they were synced from SVN:

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points