Skip navigation
Currently Being Moderated

patching admin installs, license keys no longer work

Nov 12, 2009 2:47 AM

I have been having lots of problems with the patches for acrobat 9 standard.

 

Here are the steps I have performed:

 

1. I have managed to create an admin install (msiexec /a acrostan.msi) for the basic 9.0 version, mst file has license key prepopulated.  This installation works and I have manually patched the installation to 9.2.0 (not an acceptable solution)

 

2. Patched admin install to 9.1.0, then to 9.1.2 (msiexec /a acrostan.msi /p patch.msp), mst file has license key prepopulated.  This installation does not work, as the license key is now invalid.

 

3.  I tried to patch 9.1.2 admin installation to 9.2.0 (msiexec /a acrostan.msi /p patch.msp).  This fails with the following error: Error 1334. The file 'M_IA32_ppi_910.rtp' cannot be installed because the file cannot be found in cabinet file 'Data1.cab'.

 

 

Is there a way to fix the error in step 2 or 3, or some other way to get an actual 9.2.0 install source, or perhaps even a patch roll up?  There has to be an easier way to do this!

 
Replies
  • Currently Being Moderated
    Feb 18, 2010 4:00 PM   in reply to just let me post

    I read that patching causes Volume License to become Retail.  http://www.msfn.org/board/topic/138793-slipstream-adobe-acrobat-9-pro/ page__view__findpost__p__891733

     

    I can't believe this is really true and that it is that badly designed, but that would explain the license key not working.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 19, 2010 3:56 AM   in reply to just let me post

    It works perfectly fine for me.Can you please tell me :

    1.How and at what stage are you creating the mst file which has volume license key in it?

    2.How exactly are you trying to install acrobat using AIP(exact command or mechanism)?I think you must be using some command

    like msiexec /a <path of msi> TRANSFORMS=<path of mst>.Please confirm.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2010 4:00 AM   in reply to vsh07

    Hello,

     

    I've got the same problem since version 9.3.3.

    Previously I had no problem to create an AIP and to patch in order to deploy a fully updated version of Acrobat Pro, but since the 9.3.3 MSP, the process to update the AIP is going fine, but trying to install the product result in an error showing a popup that contains our licence serial number .error.

    Example of the message:

     

    1111-111-111-111-111.error

     

    To create the AIP, I'm starting from the 9.3 MSI located on the network and launch msiexec /a Acropro.msi

     

    Then, I select a folder on my local machine, and it install the AIP inside (exemple c:\Acropro)

     

    Then I apply the following patches to the AIP:

     

    AcrobatUpd932_all_incr.msp

    AcrobatUpd933_all_incr.msp

    AcrobatUpd934_all_incr.msp

     

    with the command msiexec /a "c:\acropro\Acropro.msi" /p "c:\acropro\AcrobatUpd932_all_incr.msp"

     

    I repeat this step for the 3 others patches

     

    The process is going fine, and installing the product like this si working fine too!

     

    BUT I prepared an MST, and when i add it to the MSIEXEC command line with the TRANSFORMS= command, i get the error described above...

     

     

    Thanks for your help.

     

     

    PS: installing the version 9.3.2 and then applying the patches indicidually to upgade it is working fine, but i really want to slipstream the full product.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 25, 2010 5:36 AM   in reply to Bored_User

    PROBLEM SOLVED !!!

     

    I finally succeeded to slipstream the full 9.3.4 version and get rid off this error message

     

    So, the solution that worked for me was to come back on my work and to REBUILD a new AIP starting from the DVD of the 9.0 version.

    My prior 9.3.4 AIP was based on my 9.3.0 AIP and somehow, I guess I slipstreamed inside a security patch and not only the recommended quaterly updates.

    So, I give you the list of the patches I slipstreamed that worked for me to build a working 9.3.4 AIP for Acrobat Pro.

     

    First make a new AIP with the version 9.0 from Adobe DVD.

    Then patch this AIP with the following updates:

     

    - AcroProStdUpd910_T1T2_incr.msp (depends of your language, this patch is OK for english or french)

    - AcrobatUpd912_all_incr.msp
    - AcrobatUpd920_all_incr.msp
    - AcrobatUpd930_all_incr.msp
    - AcrobatUpd932_all_incr.msp
    - AcrobatUpd933_all_incr.msp --> make a backup of your AIP at this point to be able to apply the future quaterly update.
    - AcrobatUpd934_all_incr.msp --> This is only a security patch, so by applaying it, you block the future possibility to apply a quaterly update on this AIP

     

     

    Hope this will help other people who are stuck with this problem

     

    Seb.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2010 6:01 PM   in reply to vsh07

    The problem I was having was caused by me running the MSI command from the wrong folder. I didn't think this mattered, but clearly it's really important.

     

    Once you create the AIP folder, you must apply the patches from within the AIP folder. This prevented me from getting the license error after 9.2.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2010 1:11 PM   in reply to Bored_User

    Seb,

     

    Had exactly the same problem and I followed your solution and this has also worked for me! Pretty crazy that the only fix is to completely dispose of the original AIP and start anew, but that seems to be the only resolution!

     

    Great Job!

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2010 12:07 AM   in reply to Elan

    Hi,

     

    just make a new AIP following the sequence i gave in my previous post. It will work for sure.

     

    Cheers,

     

     

     

    -- Envoyé depuis mon Palm Pre

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2012 8:36 AM   in reply to Bored_User

    I was able to fix it. Just had to move the updated *.msi file to the original Adobe install directory and move files that adobe needed.  Problem fixed for me

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points