Skip navigation
greyshark
Currently Being Moderated

AE CS4 :"locking existing frames" too long

Aug 1, 2009 11:41 PM

Hi guys! I have mentioned problem each time I save a project or even after autosaving. The time before frames begin processing in RAM Preview is about 10-15 sec. No result with changing preferences.Before 1st saving AE works perfect! Have you any ideas? Version of AE is 9.0.2.42                      Windows XP sp3 x86, Core 2 duo E6750(2x2.67), 4Gb ddr2, GF 8600 GTS

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Aug 2, 2009 1:01 AM   in reply to greyshark

    You are using multiprocessing and the disk cache, right? The delays are due to the render process having to flush frames from RAM to disk. Either not using disk cache will simply flush frames immediately or if you want to use the disk cache, not using MP will avoid the issue just the same...

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2009 6:57 AM   in reply to greyshark

    Do you have OpenGL enabled? If so, try turning it off. On systems with insufficient hardware performance it can have an adverse effect and make things slower instead of faster, which could be what you are seeing.

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2009 10:59 PM   in reply to greyshark

    I too am having this problem and its driving me crazy! I can't even preview a tiny 15 frame selection without waiting over a minute for AE to finish "Locking existing frames".

     

    Has anyone found the solution to this?

     

    I've tried turning off multiprocessing, and disk caching, and both at the same time, turning off OpenGL, etc. Nothing.

     

    I'm running After Effects CS4 on an Intel Core2 Quad CPU with 4GB of RAM, Windows XP sp3, Nvidia GeForce 7800 GT

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2009 11:41 PM   in reply to Gooby071

    Did you monitor your task manager? Is there any excessive activity from another process or AE itself?

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2009 11:55 PM   in reply to Mylenium

    AE is the only program open, and when I preview, the CPU usage spikes at a woppin 25%, Mem Usage at 800MB.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2009 2:29 AM   in reply to Gooby071

    Gooby: "Render Multiple Frames Simultaneously" requires at least 2 GB per core (and more for large Comp sizes and/or 32 bpc). The behavior you're getting is typical when this is not the case. So you can use 2 cores for MP rendering (in Preferences > Memory and multiprocessing set CPUs to leave free to "2"), or turn off "Render Multiple Frames..." competely.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2009 1:20 AM   in reply to greyshark

    That's weird. Could you provide your system info for reference (Start menu --> Programs --> Accessories --> System Utilities --> System Info)? This should not happen, so some external influence may be at work....

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2009 6:12 AM   in reply to greyshark

    Has anyone found a solution to this?  I'm having the exact same problem.  Everything is off: no multithread, no cache, no OpenGL.  It happens only after I save for the first time.  Before that, everything is just fine.  My "Locking Existing Frames" time is about 7-8 minutes.

     

    I have Core i7 920, 8GB RAM, ~600GB free, ATI 4870 HD w/ 1GB RAM, using CS4 Master Collection.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2009 9:47 AM   in reply to Mylenium

    Did you ever come up with a solution to the "Locking Existing Frames" problem?  You said it may be an external influence.

     

    The wait time is now close to 10 minutes for me. But, again, only after I save the file for the first time.  Before saving, the render starts up immediately.  This sound like a program issue to me.

     

    The reality is, this is killing my business.  No client will wait for 10 minutes while AE "thinks."  I've searched the web all over and although this problem has been around since CS3, no one has actually fixed it.  I'm hoping you have figured it out and can save me from rolling back to 9.0.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 4, 2009 11:08 AM   in reply to ShawnMichael

    What footages do you use and to what location do you save? If you use compressed media, after a save the contents of the Media Cache will be associated. Under some circumstances this may cause those infinite delays due to the program checking forever on conformed files. Other than that - yeah, of course MP, OpenGL and external influences could still be involved somehow, but unfortunately these things scream out "you must see this yourself working on the machine to diagnose". I'm really sorry, but I know of no decent way to investigate this from afar beyond the wild guesses we already provided. And apologies for not chiming in earlier. I do not have notifications on and sometimes I simply lose track of events, seeing as I post on a bazillion forums .

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2009 2:58 PM   in reply to Mylenium

    if i switch off audio the "locking existing frames" issue goes away - but then i don't get audio in the preview

     

    this problem only started a couple days ago - has there been some kind of new patch/update?

     

    i'm gonna go back and re-install CS4 - cos it was sweet until recently

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2009 2:46 PM   in reply to ed davis underbelly

    Did you recently add some audio effects?

     

    For pretty boring audio we can run it without pre-rendering  the audio stream, but I think you are limited to the volume effect and one other. Once a certain effect is applied, all audio needs to be pre-rendered before playing back. AE will try and render audio for the _entire_ work area. It sounds like you may have a pretty long wrok area. So if you expect to only be able to RAM preview a small amount, make the work area smaller and turn audio back on. Or pre-render the audio stream that has the effect (if my guess is correct) and add it back to the project with no effects.

     

    --c

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2009 3:52 PM   in reply to ChrisProsser

    hi, thanks for you input

     

    audio has no effects on it.. except -6dB - which has never been an issue before

     

    this "locking frames" issue only started happening a few days ago...

     

    length of composition shouldn't all of a sudden start mattering should it? anyway - i tried a shorter comp - and the pause is shorter - but still a good minute or so

     

    doesn't do it on freshly opened / unsaved project... or when the audio is switched off

     

    i wonder if CS4 updated itself recently and is there some way to roll back - or i might just try re-install - and turn off updates

     

    has anyone got theirs running good again?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2009 8:40 AM   in reply to greyshark

    I don't know the solution to this, but I do have a decent work around.

    When your in a project, and you get this problem, simply click File -> Revert (Make sure your project is saved as it will revert back to the last save.)

    It will be fast again until you save.

    Here is my work flow:

     

    -Work on project

    -Save Project (which makes it slow)

    -Toggle something on/off so that it registers that the project needs to be saved again.

    -Revert

     

    I actually just have a macro, so that everytime I save it also reverts and I never have to do anything.

    Hope this helps

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2009 2:02 PM   in reply to Igl0075

    A save/revert macron! of course! BRILLIANT!

     

    I uninstalled then went back to inital CS4 before any upgrades... crashes now and then but i save all the time

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 3, 2010 9:41 AM   in reply to Igl0075

    Bump....

    Has there been any better solutions to this???  It would be nice if Adobe had a FIX for this.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 3, 2010 9:45 AM   in reply to Igl0075

    Sorry, I can't say we really understand the problem, so we don't have a fix.

     

    Please send an email to aebugs@adobe.com with a more detailed explanation of what you are seeing.

     

    --chris

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 3, 2010 1:26 PM   in reply to ChrisProsser

    Thanks for the reply... I email the problem and thought it would be good to post my email here too.  I am hoping other people can try this and report their results on this forum.

     

    The  problem:

    Audio preview or Ram preview has a  delay before starting.

     

    To re-create the problem:

     

    -Start a new project, and import  200+ audio & video files. 

    (The problem occurs with less  video/audio but should demonstrate it nicely with  200+)

    -Create a composition with a piece  of audio on the timeline

    -Hit period for an audio preview…   Nice and fast hopefully.

    -Save the project somewhere.  Now  with it still open, simply do another audio preview.  SLOW  hopefully.

     

    I figured out that if you revert  back to the last save, it’s fast again.

    Smaller projects are fine.  Only  when you get enough material in the project does it start to slow down, and very  oddly ONLY slows down AFTER a save.  The more stuff the slower it will get. Very strange.  I have recreated this problem on 3 seperate PC's.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2010 1:48 AM   in reply to Igl0075

    I can approve that this behaviour is absolutely reproducible. I was periodically having that problem since I started using CS4 almost right after its release and it was driving me nuts, but I just couldn't find a consistancy in it to post it as a bug. Well now thanks to the author the bug is detected and described. Can't wait for it to be fixed.

     

    For now at least I know how to work on my project without having a perspective of kicking my computer right outta window 'cause this problem is of a kind that piss you off completely. But I'm not that happy 'cause now I'll have to turn autosaving off and avoid any precautional saving of my project and as we all know AE is not that kind of software which lets you not worry about unpredictably losing all your progress in a project.

     

    P.S. I found this post because I came into this bug once again.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 9, 2010 2:23 PM   in reply to greyshark

    Hi lql0075 and others noticing this problem... I haven't been able to repro so far (on Vista 64). I've tried with 250 and 1000 JPEG files and an MP3 or WAV file, and the delay before it started the audio playback was the same before and after saving the project.

     

    A few questions:

    -- Are the files you imported in the comp or just in the Project panel, and only the audio file is in the comp?

    -- What are the file formats of the imported files?

    -- What is the file format and duration of the audio footage?

    -- What is in the composition?

    -- Do you see "Locking existing frames" in the Info panel during this delay before it starts the audio preview? Do you see anything else there during this delay time?

    -- Is it possible for you to send us a sample project (w/o footage) so we can make sure our tests are set up in a similar way? You can send it to aebugs@adobe.com

     

    Thanks,

    Jeff Almasol

    After Effects QE

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 9, 2010 3:16 PM   in reply to Jeff Almasol

    No no no. A 1000 stills - what is it, like 40 seconds worth of footage? Too small. In my case the bug appears when i work on video-edit imported to AE from .aaf or Premiere project, which has tens of footage items, mostly at least a minute worth of length.

    Now I'll answer your questions:

     

    -- Are the files you imported in the comp or just in the Project panel, and only the audio file is in the comp?

    The files are in comp or a nested comp. No comps having audio files only. In fact the problem appears in any comp in the project - even the most primitive one.

     

    -- What are the file formats of the imported files?

    MPEG2, WAV, MP3

     

    -- What is the file format and duration of the audio footage?

    MP3, ~4 minutes

     

    -- What is in the composition?

    The biggest comp contains the edit, but it's not the only comp in the project.

     

    -- Do you see "Locking existing frames" in the Info panel during this delay before it starts the audio preview? Do you see anything else there during this delay time?

    The "Locking existing frames" appears only on video preview. It does not appear on the audio preview, but the audio preview does delay as much as video preview for about 20 seconds.

     

    -- Is it possible for you to send us a sample project (w/o footage) so we can make sure our tests are set up in a similar way? You can send it to aebugs@adobe.com

    Yes, it is. I'll send the project right away. The message will be titled "Project File for issue "AE CS4 :"locking existing frames" too long' in After Effects""

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2010 1:59 PM   in reply to Nikita Volkov

    Thanks for sending the project, Nikita. I was able to repro the delay.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2010 3:49 AM   in reply to greyshark

    I have exactly the same problem.

     

    Playback is fast without audio and also fast with audio until I make a save.

     

    I then have to reopen / revert to get the speed back.

     

    I have a high end machine and this happens on even simple scenes. It doesn't happen with older versions of AE so this is CS4 specific.

     

    Please provide a solution ASAP.

     

    Regards

    Phil

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2010 8:04 AM   in reply to Ebb

    We've taken a look at what is going on and only have a bad solution so far. I was hoping we could find a better one before posting back here.

     

    What is happening under the hood is that when you save the project we close all the footage files and toss some of the caches. For many formats this doesn't matter much (i.e. sequences and non-long gop media). But the one project we've investigated (Thanks!) has many MPEG files. MPEG files are Long-GOP and rebuilding the reconstruction caches for all the media in the comp is what is causing this. Normally this isn't such a big deal as we'll only open the files we need to render a frame. But due to a bug in CS4, the code that determines if we can play back real time audio walks the entire project, not just the active comp, and this is what is occurring during "Locking Frames".

     

    There are two workarounds you can try.

    1) Remove the audio. Remember, I said I only had bad workarounds right now .

    2) Transcode all the M2T files to something faster for AE to use. I haven't tried this one yet, but theoretically something like Quicktime Animation will use a lot more disk space, but hopefully open more quickly.

     

    --chris

    adobe

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2010 8:14 AM   in reply to ChrisProsser

    Thanks for the quick response and suggestions for workarounds.

     

    That makes sense because if I create an empty comp with just a single audio file (WAV) and no video footage I still get this problem. However, I have about 30 other comps in the project that CS4 must be crawling and they are made up of primarily PNG encoded MOVs which are pretty slow to decode (but I want a lossless codec).

     

    Anyway, I hope you manage to solve the problem and provide an update for it in the near future.

     

    Thanks again!

     

    Cheers

    Phil

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 30, 2010 2:16 PM   in reply to greyshark

    Any progress on this, guys? I'm so glad that I'm not the only one who has this problem so hopefully they'll address it soon at Adobe (and not just in CS5), because it really DRIVES ME MAD!

     

    The workaround given above (with reverting to the last save) helps in my case but still leaves at least 5-10 second delay on my system. My own workaround was a "costly" one but it helped. I had to do all the sound mixing in an outside program (in my case I'm using Sony Vegas that doesn't have such a preview delay and plays it back almost immediately). I then save it in a SINGLE track and import it into AE. That seems to really speed up this "locking existing frames" delay because AE clearly can't handle sound gracefully...

     

    Another point I want to make is that AE probably doesn't like any compressed sound (MP3, etc) and seems to handle WAVes much faster. I can vouch for that judging by my recent project that was quite extensive. The way I had it done was to do all the visuals first and then add sound. RAM previews worked smoothly until I started adding sound tracks, and there were not many of them.

     

    So, hopefully this gets fixed in the next update to CS4!

     

    Also guys, please post any latest info on this thread.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2010 9:30 AM   in reply to greyshark

    hi all --

     

    wondering if any progress has been made to his issue. we're also struggling with "locking existing frames"on a music video we're in the midst of post-production on. when you hit ram preview, you get a beach ball for 10 - 90 seconds while "locking existing frames" before the ram preview kicks in. unfortunately, turning off audio playback is not an option for us since we are trying to sync animation/footage to the music.

     

    the "Save Project / Toggle / Revert" solution suggested by Igl0075 seems to help, but is an unnerving way to work. we've also experimenting with trying "Edit > Purge > All" but that doesn't seem to solve it. multi-processing/openGL is also not a factor as far as i can tell.

     

    our audio track is 3 minutes long. we've tried converting it from mp3 to wav/aiff, didn't improve the situation. we are not using any audio effects in ae.

     

    our video footage is h.264 (from a canon 5D and 7d), ranging in length from 3 seconds to 4 minutes. in our footage pre-comps, we've pre-rendered just from the in to out points we are using (2 seconds to 40 seconds) as tiff sequences. again, didn't solve the "locking existing frames" issue.

     

    the problem doesn't seem to be how heavy a comp itself is-- if we create a comp that only has the audio file and a black solid in it, it still takes a long time "locking existing frames" before the ram preview kicks in (problem is solved if the audio is removed from the comp). it seems to have something to do with the number of pre-comps or nested pre-comps in the project file (independent of the comp you're working in at the moment).

     

    if we reduce a project down to just one shot, it improves the situation, but that's not a viable long term solution since being able to sync animation across multiple shots is necessary. our project files are broken down into verse.aep, chorus.aep, etc. - an example project file would be 60 seconds long, 1920x1080, 23.976, contains 27 shot pre-comps. the shot pre-comps range from simple (a single footage layer with audio and 1-2 adjustment layers (levels, fast blur vignette)) to more complex (42 edited footage clips with audio and 1-2 adjustment layers). "Locking existing frames" gets triggered no matter what composition you're in, even a dummy one that only contains the audio track and no visual layers.

     

    cheers,

    michelle

     

    AE CS4

    2 x 2.26 quad core xeon, 16 gb ram

    2 x 3ghz quad core xeon, 14 gb ram

    2 x 2.6ghz quad core xeon, 8 gb ram

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2010 12:27 PM   in reply to michellehiga

    Michelle: Multiprocessing in AE CS5 has been completely reworked. Those kind of delays should be minimal or not happen at all. Much faster to launch the background processes as well

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2010 7:28 PM   in reply to greyshark

    Im working with AE CS4, and had never had this problem...

    What I did was just close the project (by opening another one) and reopen it.

     

    I got this problem after saving, and it just happened in the composition I was at when I hit Cmd+S.

     

    Hope it helps!

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 8:00 AM   in reply to kev9794

    The After Effects CS4 (9.0.3) update fixes the "locking existing frames" problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 18, 2010 8:11 AM   in reply to Todd_Kopriva

    9.0.3 isn't fixing it for me I'm afraid. I've tried it in latest versions of OSX Tiger and Leopard - do you need to be running Snow Leopard for this to work? Hope not, as Snow Leopard seems to bring yet more problems with CS4 and can't afford to UPG to CS5 yet. This locking frames thing is seriously crippling my longform projects at the moment though.

     

     

    EDIT: Just tried it on Snow Leopard 10.6.4 and still not fixing the frame locking problem, it even hangs for ages when I've only just opened the project (and not saved it, as some people were suggesting was a fix) any ideas guys?!?

     

    Thanks,

    Jim.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 1, 2010 12:06 PM   in reply to greyshark

    This may be a shot in the dark but when I had the same prob, I was RAM previewing an effect that lasted only 2 frames and recieved the same notice as everyone else. After about 30mins. of " %#@$%" I found that I was skipping every 5 frames in my RAM preview. The frames skipped were the frames AE was attemping to playback thus the notice. Switched to skip 0 frames and it played back just fine! Hope this helps. I must admit I felt real stupid when I saw what I did! ....  Best of Luck!

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2011 7:59 AM   in reply to greyshark

    Dear ALL,

     

    very sad to say that even CS5.5 has inherited the Locking problem !!!!

     

    I have to go troughout all my subcomps and entirely ERASE the sound layer ... very frustrating...

     

    Someone mentioned MPG files are used... my comps have 0 MPG files... Works  superfast even with Loads of HDMXF's and zillions of particles from particular or form...

     

    Guess no need to write the system config since this has nothing to do with it.

     

    POISON.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2011 10:32 AM   in reply to poisonCY

    poisonCY,

     

    Does this problem happen when you mute audio for RAM previews and then initiate a RAM preview?

     

    Another thing to try is decreasing the Duration setting in the Previews preferences, to decrease the amount of audio being rendered for RAM previews.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2011 11:24 AM   in reply to Todd_Kopriva

    Todd,

    thanks for the swift reply.

     

    Everything is superfast when the audio is muted.

     

    Regarding the change preview duration... default was 30:00, so i tried 20", then 10"then 1" and finaly 5 frames..

    Still  the wait of  15 seconds for the ram preview to start despite the reductions.

     

    Needless to say that my audio setup in AE in terms of frequency reflect  WAV file's frequency.

     

     

    Regards.

     
    |
    Mark as:
  • Currently Being Moderated
    May 26, 2011 1:46 PM   in reply to Todd_Kopriva

    Same problem here.  Also getting occasional audio hardware errors.  Disabled the audio tracks and preview work fine.

     

    Using VOB files from a DVD.

    Windows 7 64-bit, CS5.5 updrage from CS4.

     

    - Paul

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points