Skip navigation
Currently Being Moderated

Unable to find resource 'com.adobe.flex.framework:playerglobal:swc:10-3.2.0.3958' in repository snap

Mar 29, 2010 9:39 PM

I filed a bug about the asdoc rules and I thought I'd try and fix it myself...

 

I checked out the source at http://opensource.adobe.com/svn/opensource/flexpmd/tags/1.1/

 

I cracked the terminal on OS X and went to the flex-pmd-parent dir and ran mvn package

 

After much weirdness... (I'm a maven n00b)... I ran into a problem...

 

If someone can point me in the right direction to get this to work... I'd be more than happy to write a patch for the bug I filed..

 

Thanks in advance...

 

Error below:

 

Downloading: http://fna-v2.googlecode.com/svn/trunk/fna_m2_repository//com/adobe/fl ex/framework/playerglobal/10-3.2.0.3958/playerglobal-10-3.2.0.3958.swc
[INFO] Unable to find resource 'com.adobe.flex.framework:playerglobal:swc:10-3.2.0.3958' in repository snapshot-fna (http://fna-v2.googlecode.com/svn/trunk/fna_m2_repository/)
[INFO] --------------------------------------------------------------------- ---
[ERROR] BUILD ERROR
[INFO] --------------------------------------------------------------------- ---
[INFO] Failed to resolve artifact.

 

Missing:
----------
1) com.adobe.flex.framework:flex-framework:pom:3.2.0.3958
  Path to dependency:
      1) com.adobe.ac:flexunit-theme:swc:1.1
      2) com.adobe.flex.framework:flex-framework:pom:3.2.0.3958

 

2) com.adobe.flex.framework:playerglobal:swc:10-3.2.0.3958

 

  Try downloading the file manually from the project website.

 

  Then, install it using the command:
      mvn install:install-file -DgroupId=com.adobe.flex.framework -DartifactId=playerglobal -Dversion=10-3.2.0.3958 -Dpackaging=swc -Dfile=/path/to/file

 

  Alternatively, if you host your own repository you can deploy the file there:
      mvn deploy:deploy-file -DgroupId=com.adobe.flex.framework -DartifactId=playerglobal -Dversion=10-3.2.0.3958 -Dpackaging=swc -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

 

  Path to dependency:
      1) com.adobe.ac:flexunit-theme:swc:1.1
      2) com.adobe.flex.framework:playerglobal:swc:10-3.2.0.3958

 

----------
2 required artifacts are missing.

 

for artifact:
  com.adobe.ac:flexunit-theme:swc:1.1

 

from the specified remote repositories:
  snapshot-fna (http://fna-v2.googlecode.com/svn/trunk/fna_m2_repository/),
  flexmojos-repository (http://repository.sonatype.org/content/groups/public/),
  central (http://repo1.maven.org/maven2),
  snapshot-codehaus (http://snapshots.repository.codehaus.org),
  dist.codehaus.org (http://dist.codehaus.org/),
  maven2-repository.dev.java.net (http://download.java.net/maven/2/),
  apache-snapshots (http://people.apache.org/maven-snapshot-repository/),
  apache (http://cvs.apache.org/repository/)
 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points