Skip navigation
badlittlemonkey
Currently Being Moderated

Image flattened when exporting to Photoshop

Feb 20, 2010 4:58 AM

Me again!! Not sure if this should go under Photoshop or Illustrator, but whenever I export an image to Photoshop it gets flattened and I can't do anything with it. I've checked and double checked that Write Layers, Max Editability etc is ticked but then I get a box saying "some containers in AI have been flattened". Advice in basic English please!!!

 
Replies
  • Currently Being Moderated
    Feb 20, 2010 5:10 AM   in reply to badlittlemonkey

    Illustrator tries to maintain the layers etc. It does not guarantee it will.

     

    So it depends on what you have in your file. It would be nice to see the a screen shot of the file in PS with the layers panel

    you might not want to show the whole image because of your copyright but you can place the layers panel on top of the image
    so it obstructs part of it. Just show enough of it so we can tell what is going on.

     

    You may have no choice in some cases except to copy and paste from PS to AI.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 20, 2010 6:40 AM   in reply to badlittlemonkey

    You only have one layer they have ben merge into one layer.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 20, 2010 10:29 AM   in reply to badlittlemonkey

    Oh I see I misunderstood.

     

    Again what you might have to do is copy or paste or better yet place it in Photoshop as a smart object,

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2010 9:42 AM   in reply to badlittlemonkey

    So let me get this correctly…you made a photoshop document with two layers, you copy one layer in Illustrator and you pasted it into Photoshop on ne of the layers and then you copied the other layer in Illustrator and pasted that in the second layer in Photoshop and they automatically merged?

     

    Is that correct!

     

    I have to admit I never heard of this happening before.

     

    I'm puzzled.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2010 11:03 AM   in reply to badlittlemonkey

    I think you are seeing two separate issues.

     

    First, the illustrator is not exporting your layers because you have transparent elements. When it encounters transparency, it flattens everything below that object.

     

    Second is if you are doing copy and paste between illustrator and photoshop: you need to paste as a smart object. If you don't have that as an option, your illustrator clipboard preferences might need changing [Illustrator:Preference…:File Handling and Clipboard:Set copy as to PDF].

     

    You may want to copy and paste your layers individually to photoshop. It can help to have an extra (invisible) path to help align things in photoshop (just a rectangle at the top left can usually do it, or a frame around the whole thing).

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 21, 2010 12:41 PM   in reply to badlittlemonkey

    Try that: Target each top layer and Enable KnockOut Group option in the transparency panel before exporting to PSD. You may also try the Isolate Blending option. Maybe this will allow you to export and preserve the top layer structure. But It might introduces some discrepancies between what you see in Illustrator and the exported PSD.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 25, 2010 8:31 AM   in reply to Jean-Claude Tremblay

    IF . . . you have a copy of Freehand MX, one way of retaining layers when exporting from AI (CS3) to PS (CS3) is:

     

    Save Illustrator document as Illustrator 8 file.

     

    Open exported .ai file in Freehand MX (you should see all your layers in the Freehand document).

     

    Export from Freehand to Photoshop 5 format selecting "Include Layers" checkbox in Setup.

     

    Voila.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2010 9:11 AM   in reply to Jean-Claude Tremblay

    I've tried your suggestion with the transparencies and Knockout Group but it still doesn't work. What Illustrator does is export the 1st 8 layers perfectly fine, then flattens the last 8 layers into 1 Photoshop layer. Is there a max # of layers when exporting to Photoshop from Illustrator?

    I'm using CS4 and I can't remember ever having this problem with CS3.

     

    Any help would be greatly appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 20, 2010 8:49 PM   in reply to DrewParagon

    I don’t think there are any limits. Bet you’ve got something on that 8th layer that is doing something that invokes transparency. Look for overprint, shadows… things like that.

    Try removing the layer or objects until you find it.

     

    Good luck!

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2011 4:21 PM   in reply to badlittlemonkey

    Man, you guys are something else. Don't export the Illustator document to an open file in Photoshop. Just open Photoshop and hit open and select the name of the file in Illustrator you want to export to Illustrator. That's it. All layers should show up in Photoshop. Then do what ever you want with them.

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2011 6:14 PM   in reply to lightning4433

    You are correct should should show up but not guaranteed, is that correct?

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2011 6:21 PM   in reply to Wade_Zimmerman

    Yeah, I just tried it and had problems but tried it again and it worked. A layers came up in photoshop. 

    Ronnie 

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2011 6:47 PM   in reply to Wade_Zimmerman

    Sorry for the typo  about. It should read " select the name of the file in Illustrator you want to export to Photoshop." 

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 18, 2014 9:04 PM   in reply to badlittlemonkey

    I know this issue is long since resolved, but because I encountered it myself today, and found my way to this forum seeking help, I thought I'd add the solution that worked for me -

     

    I have hundreds of layers in my AI (CS5.5) file - Typically, Export as PSD with Write Layers enabled (+ Maximum Editability / Preserve Text) renders a large file that Photoshop interprets properly, with all text in tact and fully editable - Today however, that wasn't the case: my exported PSD opened as one large flat and transparent graphic - not good when sending out to our developers for slicing / CSS - Definitely did not want to spend the additional time copying, pasting and styling all my text layers over again -

     

    Followed some of the recommended steps above - After individually deleting each of the complicated / potentially problematic layers (eg., clipping masks of grouped objects, transparent objects, etc.), it turns out the solution that worked was to:

     

    First convert any Spot Colors in the swatches palette to Process. Then Export to PSD.

     

    OR

     

    Even easier, simply disable "Embed ICC Profle" from the PS Export Options dialog. 

     

    Not sure why, but this worked instantly: all my AI layers are now inside one layer group in PS - including the suspected transparency objects and my clipping masks - Didn't notice any color shifts either - good luck

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2014 1:38 PM   in reply to impeckoble

    Just adding to the solutions here....this totally worked for me:

     

    http://fourshapes.com/articles/2007/07/29/some-containers-in-the-ai-do cument-have-been-flattened-illustrator-to-psd-problem/

     

    Wow...what a pain!

     

    All the best.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points