Skip navigation
dan.eliot
Currently Being Moderated

3D Rotation Bug fixed by MOVING .FLA?

Apr 20, 2010 12:37 PM

One of the strangest things I've EVER seen with any software.

I teach Animation at a high school.

I had my students do the following, using Flash CS4, on Windows XP SP3, with Flash 10 installed.  All software latest as of April 2010.

 

IN FLASH:

(1)  Place a clipart image on the stage.  Convert clipart to a MOVIE CLIP SYMBOL.

(2)  Place a motion tween in the timeline for the layer with the clipart symbol.

(3)  Move the clipart along a motion path.

(4)  While traveling along the motion path, use the 3D ROTATION TOOL on the clipart, rotating along X, Y and Z axis.

(5)  Scrub and play... everything is fine.  Plays just fine inside flash with the clipart 3D rotating along the motion path.

 

TEST MOVIE:

(1)  Press CTRL + ENTER to test the movie.

(2)  Motion Tweened and all 3D rotated clipart symbols in upper-left corner, centered on REGISTRATION POINT!
RESULT:  No motion path, no 3D rotation.  Symbols just sit there in upper corner of screen!

 

I was baffled for two days with this... Every time I created an SWF (real or test), there was no motion.  Tried multiple things.  Translations, different menus, different WAYS of doing the rotation.  Deleting SWF files.  Changes to the Motion Editor, on and on...

 

STRANGE SOLUTION:

(1)  Save the FLA and close flash

(2)  Move the FLA to a new empty folder

(4)  Double clicked FLA to open it in flash.  Tested SWF, and...

RESULT:  All motion paths and 3D rotations work!!!!

 

Does anybody have an idea why ****moving**** an FLA file (and doing nothing else) would fix **3D Rotation** in an SWF????

 

 

Sincerely,

Dan

 
Replies
  • Currently Being Moderated
    Apr 20, 2010 2:56 PM   in reply to dan.eliot

    There is a known issue where saving a FLA in the root location of the hard disk (and in some networked setups where this may be occuring behind the scenes) will cause ActionScript not to export to the

    SWF. Because 3D relies on ActionScript behind the scenes, that could be why this is occuring.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 22, 2010 10:35 AM   in reply to dan.eliot

    There are a couple threads on these forums -

    http://forums.adobe.com/message/2280642

    http://forums.adobe.com/message/2282049

     

    One was solved because of saving to the root directory, which was a known issue. The other issue is something to do with the computer setup specifically and perhaps/probably related to this, and they were working with Support - I don't know if it was resolved.

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2011 11:32 PM   in reply to dan.eliot

    Wow, guys, this really really helped. Thanx!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points