Skip navigation
pollymath
Currently Being Moderated

OSMF and Spark videoPlayer

Apr 29, 2010 12:04 PM

Hi

 

At the risk of a bit of a cross posting I think that it is a real issue here. the latest and 'locked down' (sprint 10) version of OSMF is incompaterble with the spark videoplayer. I now understand why FB4 ships with a considerably older version of the OSMF I posted this on the OSFM forum. Another example of how the spark components are incomplete!

 

Thanks fo Listening

 

Richard

 
Replies
  • Currently Being Moderated
    Apr 29, 2010 6:39 PM   in reply to pollymath

    hi,

     

    Thanks to how Flashbuilder works and the beauty of the open source sdk's/frameworks I don't thing it is to big an issue, FB 4 had to be locked down several weeks before release in order to get the product release ready, things like osmf and the flex 4 sdk continue to move forward and thats the right way as Flashbuilder should not slow the development pace of the frameworks.

     

    with the SDK,  OSMF, TLF etc you are always going to have points where there development cycle is not in sync but that doesn't matter as Adobe manage that for us and everynight they give us flex sdk snapshots of  its current state of sync with the other frameworks. When it gets to the point that the IDE needs to be tweaked with newer parts of the flex sdk  there would be a freeze on the SDK itself in preparation for a Flashbuilder point release. Then the cycle starts all over again.

     

    So if you see a freeze on something like the OSMF its a safe bet that you will see a stable build of the flexSDK including that OSMF in the not to distant future.

     

    David.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2010 3:45 PM   in reply to David_F57

    Flex SDK 4.1 has now been released.

     

    Can anyone from the Flex team comment if the underlying implementations of spark.components.VideoDisplay and VideoPlayer been updated to bring them in synch with OSMF v1.0?

     

    fyi ... I scanned through the following link and I do not see anything saying that updates to these components have been included in the Flex SDK 4.1 release:

    Issue Navigator — SDK: Bugs Fixed in 4.1

    https://bugs.adobe.com/jira/secure/IssueNavigator.jspa?mode=hide&reque stId=14217

     

    Can anyone explain how we (the Flex development community) would ever know which version of OSMF is being shipped with any given release of the Flex SDK?

     

    Thanks for your great work!

     

    g

     

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 20, 2010 11:15 PM   in reply to greg•hamer

    bump

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2010 12:16 AM   in reply to mdmave

    Unofficial, but I hear Flex SDK won't get updated to use OSMF v1.0 until later this year (2010).  By then OSMF likely will be at a new release that Flex SDK won't get until next year (2011).

     

    Seems a lag time of several months is required on the handoff from the OSMF team for Flex team to get updates into the SDK  :-(

     

    What to do until then?  See cross post here (which in turn has links to other posts):
    http://forums.adobe.com/message/2981712#2981712

     

    hth,

     

    g

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2010 9:47 PM   in reply to G*Man

    Hi Folks -

     

    Flex 4.0 shipped much earlier then OSMF 1.0. We debated the issue of shipping a pre-release (but stable and thoroughly tested) build of OSMF and decided it was clearly a benefit to our customers to utilize the OSMF media player in our new Spark video component. Based on the overwhelming positive attitude towards OSMF, I think we made the right decision


    We were not able to update the version of OSMF shipped in Flex with the Flex 4.1 release. In the future, you will see more alignment between the OSMF and Flex schedules and releases, but we were not able to reach that synergy just quite yet.


    We will be shipping the OSMF 1.0 build in the next version of Flex, codenamed Hero. We are close to publicly sharing a preview build of Hero with this support.

     

    Thanks,

    Deepa Subramaniam

    Flex SDK Product Manager

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 10, 2011 12:28 PM   in reply to deepa subramaniam (adobe)

    Ok so Flex 4.1 didn't ship with OSMF 1.0

    Then Flex 4.5 did (and my application works fine with it).

    But Adobe requires that we use Flex 4.1 to build applications for TV

    But for that we need OSMF 1.0

     

    How are we supposed to combine these two ?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points