Skip navigation
Currently Being Moderated

IMPORTANT - numerical parameters don't work

May 7, 2010 12:01 PM

Hello Adobe.


I've recently downloaded the Flash CS5 and we wanted to upgrade license, but we experience VERY bad problem.

 

Steps:

1. Create blank FLA AS 3.0 movie.

2. Add to first frame (stage), for example, TextArea component and name it "xxx".

3. Set in "Properties" window in "Component Parameters" tab:

text - "hello world"

maxChars - 10

4. Add script to first frame with next code:

trace(xxx.text);

trace(xxx["text"]);

trace(xxx.maxChars);

trace(xxx["maxChars"]);

xxx.maxChars = 20;

trace(xxx["maxChars"]);

trace(xxx.maxChars);

5. Test movie. You will get next output:

hello world

hello world

0 - WHY THIS IS NOT 10!!!!!!!!!!!!!!!!!!!!!!!

0 - WHY THIS IS NOT 10!!!!!!!!!!!!!!!!!!!!!!!

20

20

 

SO NUMERICAL PARAMETERS DON'T WORK! I not a new to Flash. Have worked more than 5 years with this. Also we've tested such behaviour with latest (downloaded today and yesterday) packages from OFFICIAL www.adobe.com website. They are:

DESIGN PREMIUM CS5

FLASH CS5 PRO

we've tested this behavoiur on different machines, with different operating systems. THE SAME - NO WAY!!!!

 

PLEASE FIX THIS ISSUE ASAP! and please reply to this thread with DATE of FUTURE FIX! thanks!

 
Replies
  • Currently Being Moderated
    May 7, 2010 12:39 PM   in reply to infeter

    Hi there!

    I have faced the same problem with any component on different operating systems.

    The same result - the numerical parameters are always equal 0.

    Please reply!

     
    |
    Mark as:
  • Currently Being Moderated
    May 7, 2010 8:32 PM   in reply to infeter

    Hi,

     

    We are unable to reproduce this on either Mac or Windows.  Are you using the UI components that ship with Flash CS5 or custom components?  Can you post a sample FLA that has this issue so we can investigate?

     

    Thanks,

    Nivesh (Flash Pro QE Lead)

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2010 1:58 AM   in reply to nrajbhan

    Hi nrajbhan! Thank you for your help.

    I found this problem using custom components. At first I've thought that it's my faute.

    But then I tried to test standard flash components. The same result.

    example

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2010 3:57 PM   in reply to ju.undelalune

    Hi,

     

    I can reproduce this when I do Test Movie with your FLA.  However, if I re-enter the same numbers myself in your FLA, it works fine.

     

    Are you using a localized version of Flash?  If so, which locale?  Do you use an Input Method Editor (IME)?  If so, which IME do you use and with what settings?  Also, are you on MAC or WIN?

     

    Do you have an older version of Flash on the same machines?  If so, when you save this FLA as a previous version and Test Movie using that version, do you still get 0/null or the correct values?

    Thanks for helping us narrow down this issue.

     

    Thanks,

    Nivesh

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2010 3:08 AM   in reply to nrajbhan

    Hi Nivesh!

    - "Are you using a localized version of Flash?  If so, which locale?"

    - en_US

     

    - "Do you use an Input Method Editor (IME)?  If so, which IME do you use and with what settings?"

    - No, I don't

     

    - "Also, are you on MAC or WIN?"

    - Windows XP ( SP3 )

     

    -"Do you have an older version of Flash on the same machines?  If so, when you save this FLA as a previous version and Test Movie using that version, do you still get 0/null or the correct values?"

    - Yes, I have Flas CS4 as well. I did some tests and here is the result:

     

    Flash CS5. Drag to stage NumericStepper. Set maximum = 100. Test this movie : maximum = 0. Save this fla as a previous version.

    Flash CS4. Open this fla. Test this movie. maximum = 0. Goto the component inspector and look for the maximum values. Attention! maximum = 100,00 ( not 100, not 100.00, not 0 ) Set maximum = 100.5 and test . Result : maximum = 100.5. Save this fla. ( By the way, if I do "Save and compact" then I see  "Filed to open document" pop up )

     

    Flas CS5. Open our file. Goto the component parameters and see (Attention!) maximum = 100,5 ( not 100.5 ). Test the movie. Result : (Attention!) maximum = 50. Set maximum = 100.55 and press Enter. (Attention!) this value is replaced by 100,55. Test movie and see maximum = 55.

     

    So I guess it can help you to detect the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2010 1:52 PM   in reply to infeter

    Hi,

     

    When I open this last file on my machine and do a test movie, it works fine.  What language version is your OS?  I wonder if this has something to do with how some languages use "." and some use "," for decimal point.  Thanks for helping us narrow down this issue.

     

    Thanks,
    Nivesh

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2010 1:57 PM   in reply to nrajbhan

    Hi Nivesh!

     

    "What language version is your OS?"

    - Russian

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2010 4:31 PM   in reply to infeter

    Hi,

     

    I can reproduce it when changing locales too.  It looks like the Components Parameters section has an implicit precision level of 2 decimal digits even if it doesn't display it.  That's causing numeric values to get converted to include ',' behind the scenes, causing the components to fail.

     

    On Windows, you can work around this by changing your locale's number format to use '.' instead of ',':

    Control Panel -> Regional and Language Options -> Regional Options -> Customize... button next to your locale -> Numbers tab -> Change Decimal symbol from ',' to '.'

     

    On Mac, it's a bit more complicated.  I found that solution 4 on this site works - http://www.macfreek.nl/mindmaster/Decimal_Seperator_in_Mac_OS_X#Soluti on_4:_Manually_change_the_settings_in_the_preference_files

     

    Thanks for helping us narrow down the issue.

     

    -Nivesh

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2010 11:25 AM   in reply to infeter

    Hi,

     

    The  Components Parameters section in Flash CS5 has an implicit precision  level of 2  decimal digits even if it doesn't display it.  When you save as a CS 4  FLA, the data saved out contains the 2 decimal digits.  It should be  saved as 100.00, but since the panel is incorreclty converting . to , for some locales, the data is being saved as 100,00.

     

    -Nivesh

     
    |
    Mark as:
  • Currently Being Moderated
    May 18, 2010 9:28 AM   in reply to infeter

    Wow, I just downloaded CS5 and installed it to test its new features and stumbled upon this bug.

    Glad to see it's not my (and my components') fault but really hope Adobe fixes this, I can't believe I can't work with CS5...

     

    Any update, anyone?

    This bug is HUGE, we need a fix soon, folks.

     
    |
    Mark as:
  • Currently Being Moderated
    May 20, 2010 1:54 AM   in reply to infeter

    Does anyone know if this bug has been reported to Adobe?

    I mean, in a bugbase or something?

     

    If not I think we should do that, right?

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2010 6:16 AM   in reply to infeter

    Hi,

     

    I have this issue too, with custom components too.

     

    Basically :

    - You can only enter Number with 2 digits max in a Number component parameters field

    - '.' are replaced with ','

    - If you enter an integer, it returns 0

    - If you enter 12.1, it returns 10

    - If you enter 12.26 it returns 26

     

    So, in the end, I suppose that Flash CS5 returns the 2 digits of a Number component field and returns it.

     

    Do you know if that issue will be fix soon?

     

    Thanks.

     

    My configuration :

    Web Premium CS5 FR, Flash CS5 Pro FR, WIN XP SP3 FR

     
    |
    Mark as:
  • Currently Being Moderated
    May 27, 2010 12:16 PM   in reply to ToucheEtoile

    Hi,

     

    If your OS is set to a locale to follow regional settings for date, time, currency, numbers, etc. then you should use the same format when entering numeric values.  Instead of using '.' for decimal, you should use ',' since that's what you have specified on your OS.

     

    You can also change your locale to follow English/US conventions or to change just the numeric standard by following the steps I posted above.

     

    However, there is still an issue that saving these files as CS4 versions should convert the ',' back to '.' in the CS4 version since CS4 does not respect locale/regional settings.

     

    Thanks,

    Nivesh

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2010 5:31 AM   in reply to nrajbhan

    Hi,

     

    The change in the regional settings did the trick (with my FR system). However, it's very inconvenient for people outside US who install Flash CS5 to have to change these settings, and it may have serious side effect (with MS Excel for instance).

     

    Plus, we still can't set more than 2 decimals...

     

    Hope that'll be fixed/changed/improved (delete as appropriate) in the future.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 13, 2010 2:15 AM   in reply to infeter

    I cannot set the stepsize of numeric steppers to float values..that's really a problem for me and neither "," or "." won't work.

    Setting windows to use "." instead of "," won't work either. (ITA xpsp3)

     

    Adobe ??

     

    UPDATE:I had to delete NumericStepper component from the library and using a new one from the component list. I had to change windows "," to "."

     

    btw it should be fixed asap.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points