Skip navigation
Currently Being Moderated

Disabling flash player 10.1 sleep mode

Jun 15, 2010 2:44 PM

I have a hidden swf which needs to run in full framerate. Although it is documented that the "sleep mode" due to which flash player goes into 4fps is only for mobile devices. I see that when my swf is not displayed (hidden or in a different tab", I can only get events in multiples of 250ms. Is there a way I can disable this feature for my swf?  I can see that this is a great feature, but I just need to disable this for my app.

 
Replies
  • Currently Being Moderated
    Jun 27, 2010 8:11 PM   in reply to syellamr

    we have the same problem here.

    we are developing a mmoprg flash game.

    it seems that there's no way to turn the sleep mode off.

     

    sad to share the bad news, hope that adobe know that it's serous problem.

    the manual said that there's only sleep mode in mobile device.

    but why pc device still have it and you can't even turn if off....

     

    Hope adobe flash team can fix this problem or we have tons of fla to fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 11, 2010 12:57 AM   in reply to keromiou

    We have same problems, our trading platform is going in sleep mode... and this occur lots of troubles... need a fix!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2010 7:53 AM   in reply to Skeddio

    Have a look at this thread which discusses FullFramerateWhenInvisible.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2012 8:48 AM   in reply to kasmit44

    any update on this issue? The link for FullFramerateWhenInvisible is not accessible for some reason.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2014 10:02 AM   in reply to kasmit44

    I could not access the "FullFramerateWhenInvisible" link. It just shows the message:

     

    "It appears you're not allowed to view what you requested. You might contact your administrator if you think this is a mistake."

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2014 8:22 AM   in reply to Scott Moore Flex

    Any updates on this.  Being able to disable should have been in the feature.  It is wreaking havoc on how we are using the flash player. 

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2014 6:11 PM   in reply to mpgdev28

    Hi all,

     

    Please log a bug with us using https://bugbase.adobe.com

     

    So far, we have been unable to reproduce the problem. It would greatly help us if you could provide us with the following information:

     

    - Your system's sleep settings

    - Steps to reproduce

    - A copy of your SWF file if possible

     

     

    Thanks,

    Preran

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points