Skip navigation
Currently Being Moderated

Adobe App's won't quit.

Oct 8, 2010 5:05 AM

Suddenly all of my Adobe app's, (Illustrator, Photoshop, Acrobat), refuse to Quit.

When I choose Quit, they all just hang indefinately, so then I have to 'Force Quit', which works but I then I get that dialogue box asking if I want to report the problem to Adobe. Anyone else getting this? and is there a fix?

Mac G5, OSX 10.5.8, Adobe CS4 Suite.


  • Currently Being Moderated
    Oct 8, 2010 6:07 AM   in reply to James Blonde

    Run Disk Utility (in application/utiliites) and repair permissions.

    Mark as:
  • Currently Being Moderated
    Oct 12, 2010 11:50 AM   in reply to James Blonde

    Ha! I've been ranting about this aspect of Adobe programs since December of 2008!

    Mark as:
  • Currently Being Moderated
    Oct 13, 2010 3:42 AM   in reply to James Blonde

    Out of curiosity have you tried a new user acount?

    Mark as:
  • yepexactly
    5 posts
    Dec 16, 2011
    Currently Being Moderated
    Dec 16, 2011 3:15 PM   in reply to James Blonde

    This has been happening for years


    Adobe applications take minutes to quit, refuse to quit, on "Force Quit" they will become inaccessible  but they won't show as inactive.  Meaning you can't access them, but they still show in the dock as though they are launched and you have to restart to be able to launch them again. 


    The worst are Adobe Acrobat and InDesign followed by Photoshop, Illustrator some and Bridge is typically pretty good.  It's a much more common complaint than you see on the boards here.  It has been and is ongoing.  I have encountered it on various Mac platforms and with various versions of CS. 


    Adobe will claim it is a system error or an install error, etc. . .   The problem is that it is ONLY Adobe applications that I have every encountered this with.  And it is always the SAME Adobe applications. I do find that it is even worse when the computer is connected to a server. 


    I am a huge fan of all of the Adobe products, but this is and has been a problem in the applications and I never see any discussion from Adobe about actually trying to figure it out.  Russell Goodman -above- is correct it has been going on for years.


    Get it fixed.

    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 12:12 PM   in reply to yepexactly

    We were having this issue in CS5 as well and I was actually trying to resolve another CS5 issue with MIni Bridge when I stumbled across something that worked for us. Your mileage may vary. In our case it seems that some permissions got flakey and this was causing the applications to hang on Quit.


    Look for /Library/Application Support/Adobe folder. This is NOT the one in your user folder, but the main Library folder.

    Using Terminal I used the following to change the permissions on this folder. (Using Get Info to change permissions didn't seem to do the trick, but Terminal did.)


    cd /Library/"Application Support"

    sudo chmod -R 0777 Adobe


    This changes the permissions to read/write for all users on all the subfolders and files in the Adobe folder.

    After that our Adobe applications closed fine on Quit.


    Hope this can help someone else.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points