Skip navigation
RudiAcikgoz
Currently Being Moderated

EmailService default connection

Oct 18, 2010 4:37 AM

Hi,

 

I used EmailService in my process and I also tried to use default settings for sending email (by checking box labeled as Use Global Settings). But I got error below, and I could not find where I should enter the appropriate values as default email connection settings?

 

2010-10-18 14:11:19,822 WARN  [com.adobe.workflow.AWS] com.adobe.idp.dsc.email.ConnectionFailedException: Failed to connect to email server: null. Reason: Could not connect to SMTP host: localhost, port: 25
    at com.adobe.idp.dsc.email.EmailServiceImpl.sendMessage(EmailServiceImpl .java:473)
    at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithMapOfAttachments(Ema ilServiceImpl.java:433)
    at com.adobe.idp.dsc.email.EmailServiceImpl.sendWithDocument(EmailServic eImpl.java:344)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl. java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces sorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)

....

 
Replies
  • Currently Being Moderated
    Oct 18, 2010 6:55 AM   in reply to RudiAcikgoz

    Hi

    The error message you are getting is: "Could not connect to SMTP host: localhost, port: 25"

    Do you have an email server installed on the same box as your LiveCycle server?

     

    Diana

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 18, 2010 8:28 AM   in reply to RudiAcikgoz

    Then you need to connect to that server/service.

    If you are using gmail for example your host will have to be: smtp.gmail.com.

     

    Diana

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 19, 2010 12:52 PM   in reply to RudiAcikgoz

    Hi

    The Server Settings located in adminui are not the ones used for Global Settings on the Email service.

    (The ones set in the adminui are used for notifications of Workspace Task Assignments.)

     

    Here's where you need to set the Global Settings:

    1) In Workbench, choose Window->Show View->Components.

    2) Expand the components.You will see 2 components titled Email.

    3) Choose the second one. Expand Active Services. You should see "EmailService:1.0."

    4) Right click on the EmailService:1.0 and choose "Edit Service Configuration".

    5) Add your values and then Stop/Start the service.

     

    These values will be used in your Email Service if you select Use Global Settings.

     

    Hope this helps.

    Diana

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2010 11:37 AM   in reply to RudiAcikgoz

    Glad to hear that it's now working for you.

     

    I will be adding this to my blog post.

    I will also request that this information be added to the documentation.

     

    Diana

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points