Skip navigation
Currently Being Moderated

Configuration Error 5

Apr 30, 2010 7:37 AM

Hi,

 

I've installed Flash Builder 4 downloaded from Adobe.com and activeted with a student license.

 

The installation went okey, but i cannot launch the application.

 

Every time I try to run it it throws a configuration error 5:

 

 

---------------------------------------------------------------------- -----

 

Configuraion Error

 

Please uninstall and reinstall the product.

 

If this problem still occurs, please contact Adobe techinical support for help, and mention the error code shown at the bottom of this screen.

 

Error: 5

 

http://www.adobe.com/supor/

 

---------------------------------------------------------------------- -----

 

I've already installed and unninstalled ten times, searched adobe.com support sites, I even call the support center but i can't get it to work.

 

I'm running Windows 7 64bit

 

Adobe Flex Builder 3 runs perfectly.

 

Thanks in advance,

Alexandre Monteiro.

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    May 6, 2010 3:09 AM   in reply to Alexandre_Monteiro

    I am having the same problem on CS5 Master collection MAC.


    Did you find any solution?

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2010 10:46 AM   in reply to Alexandre_Monteiro

    Hi,

    I was experiencing the same problem, but I found a fix (Mac only, might also work on Windows):

     

    - go to /Library/Application Support/

    - delete the Adobe directory (completely remove it!)

    - reinstall flash

     

    I had Photoshop too, and it gave an error too (but it still worked) and it didn't require a reinstall.

     

    Flash somehow had everything backed up and all my preferences were still intact.

     
    |
    Mark as:
  • Currently Being Moderated
    May 17, 2010 12:59 PM   in reply to robin1232

    For the errors reported above, please see if you find any log files named "oobelib.log" or "amt3.log" if you look in your temp folder.

     

    On Win, you can find the temp folder this way:

    - open a command window, and type "set" to view the environment variables

    - navigate to the folder defined by the envvar named TMP

     

    On Mac, you'll generally find the temp folder here:

    /private/tmp/

     

    If you find one (or both) of those log files, zip them up and attach them to this thread. If you have any trouble attaching them, try sending them to me via private forum message instead.

     

    Thanks,

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2010 4:05 AM   in reply to C. Agruss (Adobe)

    I have a similar problem. I had CS4 installed. I wanted to remove everything except DW, Device Central, and Extension Manager.I used the Uninstaller and removed what I could but the following are left behind and I can't figure out how to get rid of them:

     

    • Adobe Drive CS4
    • Adobe Flash Builder 4
    • Adobe Flash CS4
    • Adobe Illustrator CS4
    • Adobe Photoshop CS4
    • Adobe Soundbooth CS4
    • Adobe Soundbooth Scores

     

    Also, Flash CS4 won't run; which is ok, but I really want to delete all of these. I wanted to attach the file requested previously, but  I don't see how to attach the files to this thread.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2010 9:35 AM   in reply to mbierman

    I've installed the trial of eLarning Suite 2 on an i7 x64 box running Win7 (brand new install) and I get the error:5 when I try to run Captivate 5 from the suite. No trouble with Dw, Br, Psx64, Sb . . . I've unsintalled, reinstalled, uninstalled using the WinCS5Cleanupscript (although no trials were ever installed prior) - still get the same results.  Please help.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 9, 2010 1:35 PM   in reply to MrStephenHarris

    One cause for this error can be permissions on the various Adobe folders. There's a KB article about that here:

    http://kb2.adobe.com/cps/827/cpsid_82744.html

     

    That solution doesn't work for everyone though, so if you still get this error after trying those suggestions, please zip and attach the amt3.log file from your temp folder.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2010 3:08 AM   in reply to Alexandre_Monteiro

    Hi

     

    After installin the eclipse plug-in on abode flash builder 4, while launching the shortcut "Adobe Flash Builder 4 Plug-in Eclipse Launcher"

     

    getting the error message as configuration erorr:5,

     

    Could you please help me how to solve this.

     

    Regards

    R_s_giri

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2010 8:47 AM   in reply to r_s_giri

    Hi r_s_giri,

     

    Are you on Mac or Win?

     

    There's a general troubleshooting matrix by error number on this page:

    http://kb2.adobe.com/cps/834/cpsid_83481.html

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2010 2:22 AM   in reply to C. Agruss (Adobe)

    I am installing on Windows Xp.

     

    Regards

    R.Seshagiri Rao

    Workplace Packaging

    Invesco Hyderabad

    VOIP 7132148918

    Direct +91 40 6604111 X1252

    Mobile +91 9177791678

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2010 11:21 AM   in reply to r_s_giri

    One possible cause of that error is that some core libraries didn't get installed successfully.

     

    Try running this subinstaller on its own, and see if that helps:

    C:\Program Files\Adobe\Adobe Flash Builder 4 Plug-in\install.support\AdobeFlashBuilderPluginSTIWrapperWin\Set-up.e xe

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2010 6:20 AM   in reply to C. Agruss (Adobe)

    Hi Chris,

     

    Thanks for reply.

    I installed "Adobe Flash Builder 4 Plug-in" silently by keeping the file "installer.properties" in which I mentioned INSTALLER_UI=silent.

    This was worked.

     

    Now how to uninstall this plug-in silently? Please help me on this.

     

     

    Regards

    R.Seshagiri Rao

    Workplace Packaging

    Invesco Hyderabad

    VOIP 7132148918

    Direct +91 40 6604111 X1252

    Mobile +91 9177791678

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 8, 2010 1:59 AM   in reply to Alexandre_Monteiro

    i'm having the exact same problem ... thing is i've already used this trial a couple of times and i only have 10 days left . why is it suddenly not working ? i use windows vista if that matters .

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 8, 2010 2:04 PM   in reply to r_s_giri

    > Now how to uninstall this plug-in silently? Please help me on this.

     

    Normally, if you install silently then the uninstaller will run silently too, automatically.

     

    That can be confusing though if you double-click the uninstaller, because there will be no visual indication that anything is happening until the uninstall completes.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 8, 2010 2:09 PM   in reply to Chermayne

    Chermayne, have you already tried using the troubleshooting matrix here?

    http://kb2.adobe.com/cps/834/cpsid_83481.html

     

    If that doesn't help, please zip up those log files mentioned above, and we'll take a closer look.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2010 1:42 AM   in reply to Alexandre_Monteiro

    Good Moorning everybody,

     

    I had the same probleme and i use FLEX Builder 4 on Window 7 64bit.

    In order to remake it  work  i re-installed Flex Builder on the current intallation without disintalled this one and  it work.

    I hope it will work for u.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 19, 2010 11:38 PM   in reply to Alexandre_Monteiro

    Hi, I'm getting this one as well on Win7 (64bit).

     

    I  already have Flash Builder 4 installed (commercial license). Then I  tried installing Flash Professional CS5 (trial) and got the  "Configuration Error 5" when trying to run Flash after install. I  uninstalled and ran the Adobe CS5 clear script. I did this twice, same  error. I tried downloading Adobe Creative Suite Master Collection instead, same result with that one.

     

    I verified the permissions for both the Adobe PCD folder and the SLStore folder, to no avail.

     

    Any other hints?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2010 1:15 PM   in reply to Bjørn Børresen

    Hi Bjorn,

     

    The best way to isolate the error you're seeing is to capture the log files described in this KB article:

    http://kb2.adobe.com/cps/834/cpsid_83481.html

     

    If you zip up those logs and send them, we should be able to spot the specific problem.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 20, 2010 10:39 PM   in reply to C. Agruss (Adobe)

    Chris, here are the log files I found:

     

    http://dev2.bybjorn.com/cs5logs.zip

     

    Thanks for looking into this.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2010 1:43 PM   in reply to Bjørn Børresen

    Thanks for sending those logs Bjorn.

     

    I looked through those logs, and there are a lot of errors evident, so those should provide the right clues for identifying a solution. I'm sending these logs over to my colleagues on the Flash Pro and Licensing teams, for help with diagnosis, and will report back soon.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2010 5:07 PM   in reply to C. Agruss (Adobe)

    Hi Bjorn,

     

    Our licensing engineer replied with this info:

     

    "Either there is no pcd.db, or they can't read it, or the data from the installer is not there. Can you ask for the pcd.db file?"

     

    He's asking to look at this particular database file, so if you could zip it up and post it alongside your logs, that would help. You should find that here:

    c:\Program Files (x86)\Common Files\Adobe\Adobe PCD\pcd.db

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2010 11:46 PM   in reply to C. Agruss (Adobe)
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2010 8:58 AM   in reply to Bjørn Børresen

    Thanks Bjorn - I've forwarded your pcd.db file to our licensing team for diagnosis, and will keep you posted.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2010 6:19 PM   in reply to C. Agruss (Adobe)

    Hi Bjorn,

     

    Our inside man took a look at that db file, and only found one product installed (Flash Builder), so if you thought that Flash Pro CS5 was also installed, there's something wrong there.

     

    Are you sure you re-installed Flash Pro successfully after uninstalling it earlier?

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2010 3:18 AM   in reply to C. Agruss (Adobe)

    Here's a screenshot of my start bar when searching for "flash": http://imgur.com/7u6KG.jpg

     

    If I click the "Adobe Flash Professional CS5" icon there,  it will give me the error message in the title of this topic, like this: http://imgur.com/4gypU.jpg

     

    So I'm sure it is installed, yes.. but it doesn't work. Are there anything else I can try here? I know the last resolution is to reinstall Win7, but I'm pretty hesitant to go there as it will cost me a days worth of work.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2010 9:10 AM   in reply to Bjørn Børresen

    @Bjorn,

     

    Reading back to your original message, I see that you already tried uninstalling/reinstalling Flash Pro more than once, sometimes on its own, and sometimes with the CS5 Suite Trial. My hunch is that something about the Suite Trial installation was conflicting with the individual Flash Pro Trial installation (or vice versa).

     

    Since Flash Pro was still not showing up as installed in the Product Configuration Database (pcd) you sent last week, you could give it one more try:

    - uninstall Flash Pro CS5, using the Uninstall control panel

    - reboot, and make sure Flash Pro CS5 is no longer present in your Program Files folder

    - run the CS5 Clean tool, and if Flash Pro CS5 is still showing, use the tool to remove it

    - install the Flash Pro CS5 trial on its own (not from one of the CS5 Suite trials).

     

    If you still get an error trying to launch Flash Pro after re-installing as described above, please send me your install log. You should find the install log under \Program Files (x86)\Common Files\Adobe\Installers\, if needed.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 4:06 AM   in reply to C. Agruss (Adobe)

    Ok, uninstalled, rebooted, cs5 clean, rebooted, installed Flash CS5 only, same problem.

     

    Here are all logs in the \Program Files (x86)\Common Files\Adobe\Installers\ folder in addition to the "Adobe CS5 Cleaner Tool.log" file:

    http://dev2.bybjorn.com/adobe_logs.zip

     

    Thank you for your continued support on this.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 4:16 AM   in reply to Bjørn Børresen

    Thinking that maybe my Flash Builder 4 installation was causing the problems I tried to uninstall it - just to get this error: http://imgur.com/xCNRL.png

     

    Tried to reboot, uninstall again, but still got the error. It says to use the CS5 Clean Tool - but that can't be used to remove Flash Builder, AFAIK ..

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 10:41 AM   in reply to Bjørn Børresen

    Hi Bjorn,

     

    Yes, you can use the CS5 Clean tool for removing FB4.

     

    Reading back through this thread, another thing I noticed from your original post is that you're using an educational license. Normally that's fine, but I've seen a few cases where invalid SNs were distributed for Edu, so another thing we could check is whether your FB4 SN is valid. If you send it to me via a private forum message, I can make sure they gave you a good one.

     

    I looked through the latest install logs you posted, and Flash Pro CS5 is reporting a fully successful installation, with nary a warning or error. Perhaps post your latest amt3.log as well, so I can see if it's still failing in the same place, or if it's shifted at all as a result of your changes.

     

    I'm about stumped now, but will run it by the Flash Pro team to see if they've encountered anything like this before.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 10:50 AM   in reply to C. Agruss (Adobe)

    Here's the latest amt3.log: http://dev2.bybjorn.com/amt3.zip

     

    I'm not using an edu license .. the FB4 license is a commercial one, and I'm trying to install a trial of Flash Pro (ie no SN). I'll send you the FB4 SN in a message .. FB4 is working fine though ...

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 11:15 AM   in reply to Bjørn Børresen

    Oh, right. I was confusing Alexandre's original posting with yours - sorry. Since FB4 is still working fine, I won't worry about that.

     

    Looking at the new amt3.log you posted, it's showing the same error with the pcd that you started with. I thought of something we haven't tried though - sometimes Win Virtualization will kick in and interfere, even though we disable it. When that happens, you can wind up with a mismatched shadow copy of the pcd in your virtual store.

     

    Here's how to check that:

     

    See if there's a folder like this in your virtual store:

    C:\Users\yourUserName\AppData\Local\VirtualStore\Program Files (x86)\Common Files\Adobe\Adobe PCD

     

    If so, delete that folder, and then try launching Flash Pro CS5 again.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 11:36 AM   in reply to C. Agruss (Adobe)

    My C:\Users\bjorn\AppData\Local\VirtualStore folder is empty ..

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 11:43 AM   in reply to Bjørn Børresen

    I'll ask a colleague on the Flash Pro team to take a look at your logs, to see if any of this looks familiar.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 11:57 AM   in reply to C. Agruss (Adobe)

    Thanks, yeah sorry I guess I posted this in the wrong forums. This was just the first thread that showed up when googling the error.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 2:30 PM   in reply to Bjørn Børresen

    No worries - when we find the solution, it will probably be useful for both products.

     

    I just heard back from the licensing team, after further experiments with the pcd.db file you posted last week, and here's what they recommend:

     

    ---

    "My observation is that the pcd.db shared by the user is corrupt and in a bad state.


    I replaced this PCD on my machine and ran the CS5 Flash Pro installer and it failed to
    make any entries into it. I then ran a simple SQL insert query in the domain_data table
    and that failed too.

    Given this and the fact that the user appears to have only Flash Builder on his machine
    We can ask the user to do the following
    1. uninstall FB (de-select the deactivate option as FB is already activated)
    2. delete the pcd.db (Not the cache )
    3. Re-Install FB and Flash Pro CS5"
    ---
    From your most recent posts, I think you've already uninstalled everything except Flash Pro, so for step 1 you'll probably want to uninstall that instead, along with any other Adobe apps you may have on that machine now.
    Let us know how it goes,
    -Chris
     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 2:45 PM   in reply to C. Agruss (Adobe)

    Ok, so I uninstalled all Adobe software on my computer except FB4 .. I'm not able to uninstall FB .. it still gives me the error I posted in an earlier message http://imgur.com/xCNRL.png

     

    I tried to run the CS5 Clean tool, but I don't see any choice to uninstall FB in it, so the closest I get is CS5 -> Clean All. Done that but it makes no difference .. FB is still installed, and clicking uninstall won't work.

     

    I guess I could go through all the Adobe folders and delete them manually but it seems kinda hacky.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 3:03 PM   in reply to Bjørn Børresen

    My hunch is that the corrupt PCD is what was preventing successful uninstallation too, so it's a bit of a Catch-22.

    Since you've already run "Clean All" from the CS5 tool, that should be good enough. You can manually delete the FB4 folder after that, so you'll be ready for a fresh start after removing the PCD.

     

    -Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2010 1:40 AM   in reply to C. Agruss (Adobe)

    IT WORKS! :-)

     

    Here is what I did to fix this:

    -----------------------------------

    * Uninstalled every Adobe software on my computer in the Control Panel (everything; Adobe Acrobat, AIR, Flash, etc.). Flash Builder could not be uninstalled though (got an error telling me to use the CS5 Cleaner Tool)

     

    * Used the CS5 Clean Tool and selected "Clean All" http://www.adobe.com/support/contact/cs5clean.html

     

    * Using cygwin I deleted the following folders:

    - C:\Program Files (x86)\Adobe\

    - C:\Program Files (x86)\Common Files\Adobe

    - C:\Users\<myusername>\AppData\Local\Adobe

     

    * Rebooted

     

    * Installed CS5 Master Collection Trial. Was able to input my existing FB SN there, so I'm running FB commercial and Flash Pro trial which was what I wanted.

     

    Thanks a lot to Chris & his colleagues for walking me through this :-)

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points