Skip navigation
invisibleBlade
Currently Being Moderated

Launch Error - This file cannot be launched

Oct 29, 2010 6:57 AM

Hi all,

I renamed a class file in a flash build and now every time I try to debug my project (cmd+F11) I get an error window saying Launch Error - This file cannot be launched.

I have tried wiping the project and moving the files in to a new one and also restarting FB4 but with no luck. I have also tried setting up a brand new blank project and this will not launch either.

The problem seems to only be with Flash projects as a new Flex project runs ok.

 

I am running Flash Builder 4 , Flash CS5 on a Mac 10.6.4 and debugging in Google Chrome 7.0.517.41

 

Any suggestions?

Cheers

 
Replies
  • Currently Being Moderated
    Oct 29, 2010 7:02 AM   in reply to invisibleBlade

    Open Windows task manager-> find adl.exe -> if it is there means terminate that process

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 29, 2010 8:04 AM   in reply to invisibleBlade

    In Finder, on the left pane, click on Utilities.  Then open up Activity Monitor.app.  Locate the adl and click on 'Quit Process'.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 29, 2010 11:51 AM   in reply to invisibleBlade

    What type of project are you using? An ActionScript project? What type of file are you trying to launch? Try right-clicking on the file and selecting RunAs. Cmd+F11 doesn't always work if you don't have your launchable file as the active tab.

     

    - Jason

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 3, 2011 11:54 PM   in reply to Jason Szeto

    I am having the same problem. I have an Actionscript project and I renamed the project, the default class and the references in the as class file. I did these changes via the package explorer and now however I try to compile this project I just get an error saying "This file cannot be launched"

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 4, 2011 12:06 AM   in reply to zoho88

    I  made a new project and transfered verything over and set it all up again. This one works. Think possible something gets missed or broken when using package explorer to rename projects.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2011 3:40 PM   in reply to invisibleBlade

    I got this error when I had multiple projects open and I had the incorrect project selected in "Package Explorer" when building.  If you are working with multiple projects make sure you are building the correct one. In my case one project was "library" code so it had no Application to run.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points