Skip navigation
Currently Being Moderated

SpryMenu 2 Upload Problem

Sep 22, 2010 8:01 PM

Hi,

 

It might not be new problem! Everything works on the local host on all the major browsers. When uploading the test page to server (Bluehost), it gives me these two errors:

 

SpryMenu.js requires SpryWidget.js!

 

and then:

 

SpryMenuBarKeyNavigationPlugin.js requires SpryMenu.js

 

I couldn't figure it out based on the previous posts, that's why I'm posting this similar question.

 

FYI, I have done styling, moved the css files to a unified location, Spryxxx.js files are in the defined Spry-UI-1.7/includes/... location. And here's the start of html file:

 

<link href="css/style.css" rel="stylesheet" type="text/css" />
<link href="css/SpryMenuBasicSkin.css" rel="stylesheet" type="text/css" />
<link href="css/SpryMenuBasic.css" rel="stylesheet" type="text/css" />
<link href="css/style-slideshow.css"  rel="stylesheet" type="text/css"  />


<script src="Spry-UI-1.7/includes/SpryDOMUtils.js" type="text/javascript"></script>
<script src="Spry-UI-1.7/includes/SpryDOMEffects.js" type="text/javascript"></script>
<script src="Spry-UI-1.7/includes/SpryWidget.js" type="text/javascript"></script>
<script src="Spry-UI-1.7/includes/SpryMenu.js" type="text/javascript"></script>
<script src="Spry-UI-1.7/includes/plugins/MenuBar2/SpryMenuBarKeyNavigationPl ugin.js" type="text/javascript"></script>
<script src="Spry-UI-1.7/includes/plugins/MenuBar2/SpryMenuBarIEWorkaroundsPl ugin.js" type="text/javascript"></script>

 

Appreciate your feedbacks.

 
Replies
  • Currently Being Moderated
    Sep 23, 2010 2:44 AM   in reply to loobia

    Without the ability to view your online version, I assume that the file called SpryMenu.js has been corrupted during upload. Please upload again.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 23, 2010 7:45 AM   in reply to loobia

    It is SpryWidget.js that is corrupt. Please upload again.

    // SpryWidget.js - version 0.16 - Spry Pre-Release 1.7//// Copyright (c) 2009. Adobe
     
    |
    Mark as:
  • Currently Being Moderated
    Sep 23, 2010 8:13 AM   in reply to loobia

    Maybe your local version is corrupt as well.

     

    Copy and paste the code from here http://safeshop.com.au/Spry-UI-1.7/includes/SpryMenu.js

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2010 9:23 AM   in reply to loobia

    I'm having the exact same issue this morning...  Tried downloading the widget again from the Widget Browser, but no difference.  Last week, I couldn't get the widget to download at all.  Is someone working on the Spry MenuBar 2.0?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 19, 2010 1:15 PM   in reply to loobia

    I figured out my problem a few weeks ago but hadn't got around to posting my fix...  The reason the widget was working on my local machine and not on the server was because my FTP program (Filezilla) was set to upload in "Auto" mode and it was apparently uploading the javascript files (SpryMenu.js, SpryWidget.js, SpryMenuBarKeyNavigationPlugin.js) in ASCII mode automatically.  So, I set the transfer mode in my ftp program to "Binary", uploaded the files, and everything worked perfectly! 

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 16, 2011 5:07 PM   in reply to ojbravo
    "I figured out my problem a few weeks ago but hadn't got around to posting my fix...  The reason the widget was working on my local machine and not on the server was because my FTP program (Filezilla) was set to upload in "Auto" mode and it was apparently uploading the javascript files (SpryMenu.js, SpryWidget.js, SpryMenuBarKeyNavigationPlugin.js) in ASCII mode automatically.  So, I set the transfer mode in my ftp program to "Binary", uploaded the files, and everything worked perfectly!"

     

    Thanks mate that solved my problem..

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 20, 2012 2:40 AM   in reply to ojbravo

    Hi Still not working if I upload the js files via Dreaweaver..

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2012 11:28 AM   in reply to zh_heute

    I am having this problem as well. Tried to upload a new SpryWidget.js file (for Spry-UI-1.7) and am still getting the same errors after re-uploading the file via DW 5.5. Any other ideas?

     

    Also tried/didn't work:

    > Using Filezilla and changing the mode to binary

    > Tried going back & uploading using DW CS3

     

    This is very frustrating, the page used to work just fine and still works fine on my local machine. Any help is appreciated.

     

    Message was edited by: Austlander

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2012 4:14 PM   in reply to Ben Pleysier

    Hi I'm having the same problem with a presumably corrupt SpryWidget.js file. For a final project in my Dreamweaver class, I had to create a website and host it. I've read all the posts but don't know where to paste the non-corrupted version. Previously, you viewed another questioners site. Would you mind looking at mine? Its www.nancyshalenphotography.com.

     

    Thanks.

     

    Phil Shalen

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2012 5:30 PM   in reply to prsnrs

    Phil,

     

    Please start a new topic and place a working link to your site.

     

    Gramps

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 3:59 AM   in reply to Ben Pleysier

    Phil -

     

    You will need to replace the SpryWidget.js file that is located on your server here:  http://www.nancyshalenphotography.com/Spry-UI-1.7/includes/SpryWidget. js

     

    Godspeed,

    Omar

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 8:41 AM   in reply to ojbravo

    Omar,

     

    Could you please be more specific as to where I should insert this file?

     

    Thanks.

     

    Phil

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 12:27 PM   in reply to prsnrs

    Sorry Phil, it's actually impossible be more specific than this absolute URL...  http://www.nancyshalenphotography.com/Spry-UI-1.7/includes/SpryWidget. js

     

    To be more vague:  Put the SpryWidget.js file in the "includes" folder that is in the "Spry-UI-1.7" folder that is located in the root directory of the nancyshalenphotography.com website.

     

    Make sure that the Transfer Type on your FTP software is set to Binary when you upload the file.  Otherwise, it won't work.

     

    Hope this helps!

    Omar

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 4:53 PM   in reply to Ben Pleysier

    I did start a new topic

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 19, 2012 4:53 PM   in reply to ojbravo

    I did as you recommended and it really messed a lot of stuff I know you meant well

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2012 7:55 AM   in reply to Ben Pleysier

    Im having this same issue.

    I really dont want to relly on Adobe's website to have my SpryWidget function.

    Ive tried diffirent FTP programs and i receive the same "XXXX[[SpryWidget]]XXXX.js requires XXXX[[SpryWidget]]XXXX.js

    Ive tried Filezilla, WAMP, DW, WinSCP, and manually uploading them to my website. I also changed the settings to Binary for only the SpryWidgetr and also tried binary for the whole site once i realized that it didnt work.

    any ideas???

     

    The uploading again {the file is corrupt} issue does not work for me.

     

    does anybody have an asnwer?

     

    Thank you

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2012 7:56 AM   in reply to VexaHex

    This email is no longer in use.  My friends and family can contact me using my gmail account...

     

    Godspeed,

    Omar

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points