Skip navigation
Sp0nge0
Currently Being Moderated

CS5 - Strange problem, canvas is not visible?

Nov 6, 2010 3:39 AM

Hi,

 

I have installed Adobe Photoshop CS5. When clicking File -> New and creating a document, or when importing other files/opening old PSDs there is no canvas showing up, just the grey background, I am able to draw on the invisible canvas as I can see it updating in the layers tab, however there is nothing on the screen. Usually I can find a solution to a problem like tihs on google but it doesn't appear to be common.

 

Does anybody have a solution to this?

 

System Specs:

 

  • Windows Vista x64
  • 12GB RAM
  • Intel i7 920
  • 2x GeForce 9800 GT

 

Happy to provide any other information necessary.

 

Thanks

 
Replies
  • Currently Being Moderated
    Nov 6, 2010 4:46 AM   in reply to Sp0nge0

    This sounds as if the image window is off-screen. Have you disconnected a second monitor, or changed desktop resolution, or tweaked some other display setting?


    Make sure you have installed the patch for CS5 from here: http://www.adobe.com/support/downloads/detail.jsp?ftpID=4733

     

    And update your video drivers from the card manufacturer's web site.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2010 10:42 PM   in reply to Sp0nge0

    Sounds like you installed 64 bit version of CS5. I don't have a direct solution, but only a workaround, which helped in my case.

    (see thread below): Install 32 bit version of CS5 and hope with a later patch from Adobe the problem will disappear, however not very likely for Vista.

     
    |
    Mark as:
  • Noel Carboni
    23,459 posts
    Dec 23, 2006
    Currently Being Moderated
    Nov 7, 2010 8:33 AM   in reply to bakka.waruta

    The 64 bit version of CS5 works just fine.

     

    If it is not working fine, then you have a video driver problem.  For your nVidia card, visit this site to check for updated drivers:

     

    http://www.nvidia.com/Download/index.aspx?lang=en-us

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2010 1:39 AM   in reply to Noel Carboni

    Answer to Noel Carboni:

    Thanks for your suggestion. I installed the most recent driver, but it did not help.

    If I open a psd file the background is empty unless I set the zoom scale to 25%. For any other zoom ratio I get an iakiramemashitamage only as long as a move the file with mouse. If I stop and deppress the mouse button it disappears. Never seen such strange behavior. The 32 bit version works normally.

    akiramemashita (japanese)= I've given up.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2010 3:14 AM   in reply to bakka.waruta

    Try disabling SLI. If that doesn't help then go to Edit->Preferences->Performance->Advanced Settings and try changing the Mode dropdown. If that doesn't work then you'll probably need to disable OpenGL Drawing from Edit->Preferences->Performance.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points