Skip navigation
vishal nagota
Currently Being Moderated

OSMF 1.5 - VerifyError: Error #1014: Class org.osmf.media::MediaFactory could not be found.

Nov 24, 2010 2:16 AM

Hi

 

I'm compiled osmf 1.5 player - OSMFPlayer project for http streaming, using chromeLlibrary and OSMF.swc. I generated OSMFPlayer.swf without any errors, but when I'm trying to use this file I get a lot of errors with

 

VerifyError: Error #1014: Class org.osmf.media::MediaFactory could not be found.

VerifyError: Error #1014: Class ILayoutTarget could not be found.

VerifyError: Error #1014: Class org.osmf.layout::LayoutTargetSprite could not be found.

 

etc..

 

Can anyone please explain anything I need to do at compile time to get these errors fixed.

 

Thanks

--

Vishal

 
Replies
  • Currently Being Moderated
    Nov 24, 2010 3:34 AM   in reply to vishal nagota

    Hi Vishal,

     

    You probably need to remove the reference to the older osmf.swc from within the Flex SDK.

     

    select File >

    Properties > Flex Build Path > Library path, select osmf.swc under Flex 4.1 SDK on the Library

    Path panel, and click the Remove button.


    -Andrian

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2010 3:38 AM   in reply to Andrian Cucu

    Vishal,

     

    You might be interested in using Strobe Media Playback, instead of the OSMFPlayer example, which is slightly outdated and might get deprecated/removed from the OSMF samples in future.

     

    You can get the the Strobe Media Playback source code, with a preconfigured copy of the OSMF here https://sourceforge.net/projects/smp.adobe/files_beta/ .

    Simply import both OSMF and StrobeMediaPlayback projects into your Flash Builder and start coding.

     

    -Andrian

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2010 4:33 AM   in reply to vishal nagota

    Hi again,

     

    You are probably still referencing an older version of the osmf.swc, and not the OSMF project source code from the Strobe Media Playback download zip.

     

    Are both OSMF and StrobeMediaPlayback projects imported in Flash Builder? Can you check that your Flex SDK does not reference an older version of the osmf.swc?

     

    -Andrian

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 24, 2010 4:36 AM   in reply to vishal nagota

    Ahh, ok.. i can see that you use Flash Builder 3

     

    You can try to create new project files, instead of importing the project files created by Flash Builder 4. Simply create new projects and copy the source code (without the FB project definitions).

     

    Just a thought...

     

    Andrian

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2010 2:03 AM   in reply to vishal nagota

    In the compile settings, set CONFIG::FLASH_10_1 = false

     

    Hope it helps

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2011 8:49 AM   in reply to Andrian Cucu

    I had the same issue and removing old osmf.swc from the project Build Path worked for me- thanks.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points