Skip navigation
This discussion is locked
Currently Being Moderated

Conforming & Indexing of Files

Sep 22, 2010 6:51 PM

Tags: #premiere #cfa #pek #conforming_audio #indexing_files

Wil Renczes, from Adobe, just posted a great outline of what happens with Conforming and Indexing of files on Import. He was replying in the PrPro forum, but you can substitute PrE for PrPro in his post, as they are the same here. He also addresses why/how Conforming can not take, and the program will do this every time that the Project is opened, though the processes have already taken place before.

 

Wil writes:

 

PPro generates two potential sidecar files for audio - PEK and CFA files.  The PEK file is simply a quick data pass of the audio data that allows the app to draw waveforms (ie it should be pretty quick) - the CFA files are required if the file source is either too slow to decode the audio in realtime (like some MPEG long GOP, for instance), or if there's a mismatch in the sample rate depth.  The idea is that the conform files will match your sequence's audio bitrate settings so that the app can play & mix audio in realtime.

 

How does PPro track these additional files?  Every file that is imported is stamped with XMP, which is how we handle metadata on source files.  XMP creates a unique ID which the app uses as a lookup value when it wants to find the PEK & CFA files that it generated for a file.  So, usually, if you have a project where certain clips constantly reconform, it has something to do with XMP.  Why? Usually it's because XMP can't write to the file.  So, every time you launch PPro and open the same project, the media file has no XMP data, so it tries to generate a new ID, so any old CFA/PEK files have an ID mismatch and the app thinks it needs to generate new ones.

 

Typical cases why XMP can't stamp files:

 

- the media file is read-only.

- the media's hard drive is read-only.

- the file itself is corrupted/malformed, and XMP takes the safe route & decides not to try to write any additional data to the file.  (I've personally witnessed this occur with WAV files captured by a Tascam field recorder.)

- someone deleted the XMP files by hand (certain media types have it as a sidecar .XMP file instead of embedded).  (Don't laugh - I recently encountered a case where people had instituted a server folder rule to delete all files on a network share that weren't .mpg. )

 

A workaround you can try:

 

There's a preference setting to turn off injecting XMP into your media.  If that setting is in effect, PPro will not rely on the XMP ID for the CFA/PEK files.

 

One other note, if your problem is specific to MPEG files:  it might be that PPro isn't able to index the file properly.  If it can't index, it might be trying to re-index on each launch;  audio conforming always triggers after indexing.   So watch for it constantly indexing - if that's the case, all the XMP stuff I described above has nothing to do with the problem.  It's a side effect of something in the MPEG stream that we're barfing on.  If you do see it constantly re-indexing MPEG files, it would be really helpful to send in a sample so that we can examine the stream.

 

Cheers Wil

 

If someone is having problems with continuing Conforming, though it completed earlier, think about what Wil has said.

 

Good luck,

 

Hunt

 
Replies
  • Currently Being Moderated
    May 18, 2011 10:30 AM   in reply to Bill Hunt

    If you do see it constantly re-indexing MPEG files, it would be  really helpful to send in a sample so that we can examine the stream.

     

     

    Where would I look to see this indexing?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 1, 2011 10:39 PM   in reply to Bill Hunt

    Could you please explain exactly how to get to the Preference about injecting XMP data and turning it off?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)