Skip navigation
PagesOfJoy
Currently Being Moderated

Problem with sending email.

Oct 20, 2010 10:07 PM

Hi

 

I am working on a process in which i need to send a reference mail to the initial user (ie. process initiator).I am using gmail as the email serevr for outgoing messgaes.I have configured the email setting in the server settings of adminui.But when the process comes to email service its showing an error like "unable to connect to the smtp port".

Can Anyone say what could be the problem?

 
Replies
  • Currently Being Moderated
    Oct 21, 2010 7:23 AM   in reply to PagesOfJoy

    Hi

    Couple of questions...

    1) Are you using the email service in your process to send an email?

    2) Or are you using the Task Notification feature of Process Management that sends email notifications to users who are assigned tasks on the user service?

     

    If you are using the email service, you don't need to configure the server settings in adminui.

    You simply set the connection settings in the email service on the Connection settings tab. (Make sure you have the All button selected in the Process Properties or you won't see the connection settings tab).

     

    If using gmail, I believe they typically require SSL connection.

    The port for that would be 587.

     

    Diana

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2010 7:47 AM   in reply to PagesOfJoy

    Considerations:

     

    1) Do you have LC configured for Gmail SMTP port 465?

     

    2) Are you using SMTP authentication?

     

    Reference http://mail.google.com/support/bin/answer.py?hl=en&answer=13287.

     

    3) Are you going through a firewall? A firewall may block outbound traffic on well-known SMTP ports.

     

    Steve

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2010 8:41 AM   in reply to PagesOfJoy

    Have you tried port 587?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2010 7:40 AM   in reply to PagesOfJoy

    Other people are successfully using gmail but I'm not sure why it's not working for you.

    The screenshot of the error message you attached....when exactly do you see that error?

    I notice that the information returned in the error dialog seems strange....failure to connect to email server:

    adobealreon@gmail.com@smtp.gmail.com

     

    We support most mail servers.

    You could try setting up your own email server...something like James mail server.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2010 7:21 AM   in reply to PagesOfJoy

    Hi

    Is it possible that you are having firewall issues?

    Ports 465 and 587 may be blocked by your company or service provider.

    That seems to be a common thread on forum posts when you Google this issue.

     

    You could install James mail on your computer and connect to that.

    See this blog post: http://blogs.adobe.com/livecycle/2008/10/configuring_apache_james_as_l i.html

    This is a lightweight email server that many developers use.

    You would have to make sure that your Virus Scanner is not blocking port 25 (SMTP default port).

     

    Diana

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 3, 2010 11:40 AM   in reply to PagesOfJoy

    Hi

    Go into your C:\WINDOWS\system32\drivers\etc\hosts file.

     

    You will need to add a host name for your machine.

    For example: 127.0.0.1     sampleorganization.com

     

    When you add the email address to the server settings page you will put rgreen@sampleorganization.com

     

    Diana

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2012 7:13 PM   in reply to Diana Densmore

    Hi all,

     

    I"m having a similar problem. The thing is that the regular email service allows you to indicate that the outbound smtp is SSL, while the task notification screen in AdminUI does not. I can set the port but not the SSL setting so it does not go through using task notification, which I want. If I send via the send email service, it works fine.  Where can we tell task notification to use SSL?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points