Skip navigation
Currently Being Moderated

Audio gets cut off at start and end of slide.  Gets worse as project size increases.

Oct 23, 2010 3:02 AM

Hi,

 

I am using Captivate 5 to create some e-learning content that is a mixture of slides with animated images on them and application/video demonstrations.

 

Each slide generally has several text captions which follow each other with a seperate piece of Audio, recorded iin Captivate 5.  Each project generally has between 10 and 120 slides in it - The projects with a higher number of slides are mainly due to several frames of 'video'/recorded content.

 

The problem I am seeing is that audio cuts off, sometimes at the beginning, but more often, at the end of a slide and this behavior is more obvious when the project gets larger.


Interestingly, the problem seems to be much more prominent when viewing the published project by running the .swf file directly compared to when the .swf file is run via the.htm file !?!  When running from the .htm file the problem is far less extreme/noticeable.  I do not see the problem when previewing within Captivate.

 

I am aware of the various workarounds (to add gaps in the audio at the end of slides) but these are exactly that, workarounds - and very timeconsuming workarounds at that!

 

Is Adobe looking into why audio and video get out of sync as several customers have reported?  Can we expect a fix?  These flaws in the product significantly detract from the otherwise very good product that it is.


Cheers,


David

 
Replies 1 2 3 Previous Next
  • Currently Being Moderated
    Nov 5, 2010 4:12 AM   in reply to dparkeruk

    Are you using the Neospeech voices? I've had this issue (with speech cutting off at the end of the slide) with the Kate and Paul voices--yea, the only way to fix that is put that code at the end, which is a pain.

     

    But I have not noticed the problem with the Loquendo Simon voice or with IVONA voices.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 12, 2010 12:24 AM   in reply to dparkeruk

    Hi David,

     

    We are in process of investigating this issue, we are collecting projects from different people to boil down to a particular root cause of the issue. It will be great if you can share your project with me. You may choose to upload the project to acrobat.com and mail the download link to ashwin at adobe dot com.

     

    Thanks

    Ashwin Bharghav B

    Adobe Captivate Team.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 10, 2010 6:18 AM   in reply to AshwinBharghavB

    Same issue here. Audio cutoffs.

    There are a number of outstanding  issues. How about a patch?

     

    Yeah, I know this a user forum...

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 10, 2010 8:02 AM   in reply to JackAnz

    Hi there,

     

    We have released a patch with fixes to the audio cut issue. You can check the release notes and details about the patch here :

    http://www.adobe.com/support/captivate/downloads.html

     

    You can either choose to download the patch from the above mentioned location or you may install it from the application.

     

    Steps to install it from the application.

    1. Launch Adobe captivate 5 and in the menu item follow Help >> Updates.

    2. Update manager searches for updates and lists the patch available.

    3. Close captivate and install the patch.

     

    Check the release notes about the fix realted to the audio cut issue in the above location.

     

    Let us know if the audio cut issue is resolved for you.

     

    Thanks,

    Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 10, 2010 8:36 AM   in reply to AshwinBharghavB

    The patch - is it language dependent? Or may it be installed over an non-English version of CP5? Thanks for your answer.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 10, 2010 8:43 AM   in reply to Tom Tantalus

    No, The patch is not language dependent. Please go ahead and install the same.  But the release notes are currently available in English only. Localized versions of release notes will be available soon.

     

    -Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 10, 2010 9:40 AM   in reply to dparkeruk

    Hello David,

     

    It is not available as for other Adobe apps. Please check this link:

     

    Patch for Captivate 5

     

    After installing the patch you should have version 5.0.1.624

     

    Lilybiri

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 1:24 PM   in reply to AshwinBharghavB

    The patch didn't help me, and I have added the AudioOptions.ini file as per described in http://blogs.adobe.com/captivate/#main__Using_the_AudioOptions_ini_fil e_to_obtain_the_fix_for_the_audio_issue

     

    I'm getting them cut off at the end -- meaning the slide stops (or, moves to the next slide) when there is about a half-second left on the last word.  BUT... even if I drag out the timeline, it still cuts off, or even if I add silence at the end. BUT ... it cuts off only the first play. If I rewind, the next play is fine.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 10:27 PM   in reply to Tim Murray

    Hi Tim,

     

    Can you share your project with me to investigate further on the same ?

     

    You may choose to upload the project to acrobat.com and share me the download link.

     

    Thanks

    Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 14, 2011 12:53 PM   in reply to AshwinBharghavB

    I'm still having the issue as well, even with the patch, and setting the ini file correctly. I've tried adding space at the beginning of the slide, end of the slide, etc. Still cuts off the last part of the last word. The problem seems to affect the slides at the end of the project more than the earlier slides.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 14, 2011 1:00 PM   in reply to joebor1776

    Try reducing the frame rate.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 17, 2011 8:39 AM   in reply to JackAnz

    Thanks, but that did not fix the issue. I tried changing the frame rate from 30 to 20. Should I change it more

    drastically than that?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 17, 2011 9:40 AM   in reply to joebor1776

    Can you share your project with me to investigate further on the same ?

     

    You may choose to upload the project to acrobat.com and share me the download link.

     

    Thanks

    Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 17, 2011 8:37 PM   in reply to AshwinBharghavB

    Can you share your project with me to investigate further on the same ?

     

    I'm going to try, but I'm swamped with work and with a wife in and out of the hospital.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2011 2:22 AM   in reply to joebor1776

    Hi Joebor1776,

     

    Will it be possible for you to share the captivate file with us? If yes, you could do so by zipping the file -> uploading on acrobat.com (its free) and share the link with me at maanand@adobe.com.

     

    -Manish

    blogs.adobe.com/captivate

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 19, 2011 6:06 AM   in reply to M_Anand

    I can share it, but I don't think it would help. I realized today that the issue only occurs when we play the swf through our html page. If I open the swf directly, or open it using the Captivate-generated .htm file, the audio cut-off problem does not happen. But when I view the swf through the html page that will launch it in our documentation project, the problem occurs.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 2, 2011 5:45 PM   in reply to joebor1776

    Hi all,

     

    If you are facing Audio cut issue even after installing the patch then read further for a fix for the same.

    We did a thorough investigation on the Audio cut issue and have SOLVED it.

     

    1. Open the project having Audio cut issue in Captivate 5 with Patch.

    2. Select the first slide .

    3. Scroll to the last slide and "Shift+Select " the last slide. Make sure that all the slides in the project are selected.

    4. In the Slide PI change the "Slide Exit" action from "Go to Next Slide" to "No Action"

    5. Publish the project with "AudioOptions.ini" file in the Installed folder of captivate.

     

    Notice that while setting the "Slide Exit" action from "Go to Next Slide" to "No Action" the slide progress to the next slide will not be stopped in the published output but it would continue to play the project.

     

    Please try out the steps mentioned and let us know.

     

    Thanks,

    Ashwin Bharghav B.

    Software Quality Engineer.

    Adobe Captivate Team.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2011 11:56 AM   in reply to AshwinBharghavB

    I am having the audio cut off issue as well...

     

    I have updated to the latest release.

     

    I have started a project in this latest release of Captivate.

     

    I have selected slides with the audio cut off problem (my narration, not test-to-speech)

         and selected "NO ACTION" for slide property "On Exit"

     

    The last bit of audio is cut off. Sometimes it is cut of, sometimes it isn't cut off.

     

    I tried your suggesting of selecting all slides in the project, and selecting 'NO ACTION" on slide Exit in the properties, BUT

         the ability to select this is not available, it is greyed out.

     

    My project has demo, training, and assessment software simulations.

     

    ====

    This is not contructive, but nonethiess, I will say it:

    <rant>

    It is very frustrating to spend time dealing with this issue when trying to complete projects. This should be basic stuff we do not waste time on.

    </rant>

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2011 9:01 AM   in reply to xg95

    Try selecting all slides except the quiz slides. You cannot change the On Exit property for quiz slides.

    I was also having this issue - this seems to have fixed it, but we'll see in the final product...

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2011 9:30 PM   in reply to klepi_8

    On quiz slides, the OnExit action is really controlled by the OnSuccess or OnFailure actions that you can set up for the question after it gets submitted.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 25, 2011 9:47 PM   in reply to RodWard

    Well, thanks for all the workarounds. Whew.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2011 10:17 AM   in reply to xg95

    I just came back from Adobe Summit in Orlando, FL.  In a session about audio/video, the facilitator also said that not allowing for a little bit of silence at the beginning/end of the audio can result in this problem (has to do with progressive loading, and isn't necessarily just the first or last slide).  Recommendation was to allow at least .5 seconds of silence at beginning/end of each individual audio file.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2011 10:52 AM   in reply to SandyTucker

    Been, there, done that. I've added five seconds just to see if it would work, but it didn't.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2011 12:03 PM   in reply to Tim Murray

    Hi Tim,

     

    Please upload the project showing the Audio-cut issue to Acrobat.com and share the download link with me ( ashwin at adobe dot com). I will look into it.

     

    Also let me know if the project was natively created in Captivate 5 or was it created in older versions of Captivate.

     

    Thanks,

    Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2011 1:15 PM   in reply to AshwinBharghavB

    Please upload the project showing the Audio-cut issue to Acrobat.com and share the download link with me ( ashwin at adobe dot com). I will look into it.  Also let me know if the project was natively created in Captivate 5 or was it created in older versions of Captivate.

     

    It's been fixed and I no longer have the old slides.  The solution to select all the slides and change the "on exit" behavior fixed most bad slides. Remaining bad slides would not be fixed by adding "silence" to the audio track or by manually stretching the ending time out further. For these, I added real audio, such as saying "quick brown fox", saved, then chopped it off later.

     

    What I found quite interesting in all this was that the cut-off would happen on only first play. If I rewound then replayed, it was okay.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2011 1:35 PM   in reply to AshwinBharghavB

    Hi Ashwin,

     

    I've been reading through this thread as we too are experiencing audio being cut off in the published captivate file... using version 5. I've tried the various solutions provided, including downloading the patch and ini file, but unforuntatley, have been unsuccessful. Is there any other suggestions you might offer?

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2011 9:16 AM   in reply to dparkeruk

    Hi guys,

    I too have this issue on several projects. These work-arounds mostly helped, but there are still a few times that this happens. I have found that it is possible to see what is happening during this.

     

    If you look at the slide's audio track in the timeline you can see, if you hover the mouse over it, that there is a shadowy highlight, BUT you can see at the end of the slide, that the highlight doesn't go all the way to the end of the audio waveform. You will also see, if you play the slide, that the end of the waveform gets shorter after it plays the entire thing.

     

    If you click on the audio track and "shake it" back and forth, or move it a little on the timeline, it will go away and fix the problem. You can see when the waveform snaps back into the highlighted area.

     

    I do have screen shots of this, if it will help out at all.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2011 10:57 AM   in reply to SMattox

    Hi there,

     

    We were able to successfully fix the audio being cut off by creating a new project and copying the slides from our original project into the new one. But I would be intereseted in trying your suggestion if this problem ever arises again. I think I understand what you are explaining, but if you have screen shots you could share, that would be great.

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2011 11:08 AM   in reply to SSchwa

    Here is the best picture to show it. Notice how the darker shadow on the audio track in the timeline doesn’t cover the whole track.

     

     

     

     

     

    You can also see in files #1 & 2 (attached) the wave before playing (1) and after playing (2). It visibly shortens while you watch.

     

    Hope it helps!

     

     

     

     

     

     

     

     

     

    cid:image001.png@01CBF463.F26B5090

     

     

     

    Shanie Mattox, CTS-I, DMC-E

     

    Crestron South Ext 13014

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2011 6:32 PM   in reply to SMattox

    Thanks... but sorry, I can't seem to access your images.. getting a message telling me that the web page can't open. Can you send the images another way maybe?

     

    Thank you!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2011 10:47 PM   in reply to SSchwa

    Hi S Schwa,

     

     

    Can you try the following and let me know if this solves the audio cut issue.

     

     

    1. Open the project having Audio cut issue in Captivate 5 with Patch.

    2. Select the first slide .

    3. Scroll to the last slide and "Shift+Select " the last slide. Make sure that all the slides in the project are selected.

    4. In the Slide PI change the "Slide Exit" action from "Go to Next Slide" to "No Action"

    5. Publish the project with "AudioOptions.ini" file in the Installed folder of captivate.

     

    Notice that while setting the "Slide Exit" action from "Go to Next Slide" to "No Action" the slide progress to the next slide will not be stopped in the published output but it would continue to play the project.

     

    Please try out the steps mentioned and let us know.

     

    Thanks,

    Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2011 6:11 AM   in reply to AshwinBharghavB

    I did try that as well. Between the two fixes, they helped for most of the problems. But the audio is still where I have the most problems.

     

    Don't know if it's related, but I also get a lot of gaps in the audio. I'll edit the slide markers very carefully between phrases, but then it seems like the audio shifts in the timeline and doesn't take the slide markers.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2011 6:12 AM   in reply to SSchwa

    Try this

     

     

    Shanie Mattox, CTS-I, DMC-E

    Crestron South Ext 13014

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2011 6:23 AM   in reply to SMattox

    Hi SMattox,

     

    Can you please mail me at ashwin at adobe dot com to take the discussion forward.

     

    Thanks,

    Ashwin Bharghav B

    Adobe Captivate Team

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2011 10:15 AM   in reply to AshwinBharghavB

    Hi Ashwin,

     

    Yes, we did try these steps as well .... changing the slide exit option to 'no action' didn't help, but copying the slides in to a new project did work!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2011 11:02 AM   in reply to AshwinBharghavB

    Hello Ashwin

     

    I also have a 'faulty' captivate file I can send you.

     

    Originally captured on Cap5

    Audio imported into slide and then distributed

     

    Terry

     
    |
    Mark as:
1 2 3 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points