Skip navigation
Currently Being Moderated

Cannot select or deselect objects in Fireworks CS5

Nov 22, 2010 11:40 AM

I cannot seem to select or deselect objects in fireworks by clicking on them. I have to click and drag in order to select an object and click and drag to deselect. Does anyone know what I might be doing wrong or how I can fix this? Thanks.

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Nov 22, 2010 1:32 PM   in reply to CalinR

    Check your layer options and make sure that Single Layer Editing is not selected.

     

    Check also to see if you've accidentally locked all the layers.

     

    Another option might be the active tool. You won't be able to select vector objects if a Bitmap tool is active, for example.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2010 2:35 AM   in reply to CalinR

    Got the same problem.

    Also can´t zoom (z) + mouse click

     

     

     

    Also tried to reinstall FW - did not solve the problem.

     

    I restarted my computer (Osx) . Started Fireworks and opened different Fireworks png working files. I also tried on a new fresh document. Note this - Did, at that time (after reboot), manage to select on or two objects (object border got selected - blue border). But after a minute or less objects wont respond when clicking on them (red border

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2010 9:53 AM   in reply to CalinR

    Very strange. Never had this problem! Always can easily select objects in Fw by simply clicking on them...

     

    (I am on Windows.)

     

    Can you try contacting any of the Adobe Fireworks engineers?...

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 2:31 AM   in reply to Michel Bozgounov

    I tried to use the zoom option in the right bottom corner. Set zoom to 80 then to 100, then save document. Restart FW. Do not zoom using the Z comman key.

     

    Edit.

    - It worked for a minute then it started again. Can not select or deselect.

     

    This is really troublesome. Starting a monday like this with a tight client delivery schedule. How does one get in contact with the ADOBE CREW?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 3:09 AM   in reply to CalinR

    This same problem is driving me crazy too! It started suddenly and I haven't made any changes by myself and it affects old and new files. I did run the Adobe updater last week, but don't remember if Fireworks was updated.

     

    Single layer editing is not on and nothing is locked.

     

    I'm running CS5 on Mac OSX.

     

    Help!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 3:22 AM   in reply to newuser_211

    I forgot to say that a friend of mine got the same problem last week when he opened a FW-.png-file of mine. It´s spreading ...the Adobe Fireworks virus

    How do we get the attention of the Adobe dev Team?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 3:38 AM   in reply to monsterkyckling

    I don't promise anything, but I'll try to contact some Fw Team gurus to help with the issue...

     

    You can also try reporting it here:

    https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

    -- provide as many details as possible and probably someone will contact you.

     

    Fingers crossed!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 3:48 AM   in reply to CalinR

    I sent a bug report

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 3:52 AM   in reply to CalinR

    Like to drop in and confirm I have the same problem. This is costing precious time AND money. Hope we won't have to wait until a CS6 release this time to get a decent bugfix. (and pay an insane price for it too). Shame on you Adobe!

    btw I'm running on MacOSX, the problem occured before but could normally be fixed by restarting. This morning that didn't help, so I rebooted and did the latest OSX update which was still in que but nothing worked.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 3:56 AM   in reply to CalinR

    Exactly the same problem. This is very annoying and prevents me from working

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:00 AM   in reply to CalinR

    I have also reported a bug to Adobe!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:04 AM   in reply to monsterkyckling

    Thanks for reporting the bug!

     

    The bug report should receive the attention from someone from the Fw Team. I hope so

     

    (I never saw this bug but I am on Windows...)

     

    Since Fireworks CS5 has not been updated recently, I suppose that a MacOS X minor udpate might have caused the issue. Or maybe an update in another CS5 application that somehow touched Fireworks (a shared library of some sort?); or maybe Adobe Flash player update? I really don't know just making some guessings...

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:08 AM   in reply to Michel Bozgounov

    Maybe. I use MacOS 10.6.5, anyone else?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:09 AM   in reply to calderonportillo

    Me too

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:11 AM   in reply to CalinR

    This has also started happening for me this morning 20th december 2010, I however am using CS4 and not CS5.

     

    I am also running 10.6.5 but that was installed on the 24th November and Ive been using Fireworks for weeks without a hitch.

     

    ?????

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:13 AM   in reply to Yarham1972

    For me it started last friday (Dec 17 th)

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:15 AM   in reply to niclasglimnell

    Are you able to use keyboard shortcut keys for any operation like nudging?

     

    Can you try cleaning your preferences?

    Location: \Users\<username>\Library\Preferences\Adobe Fireworks CS5\

     

    Can you share your OS version? 10.5/10.6?

     

    ..Sarthak

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:17 AM   in reply to CalinR

    FIXED....

     

    Its Spotify.... Close it and try again.. Worked for me....

     

    Grrrrr... I blame Xmas and all the offices for having music on.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:20 AM   in reply to Yarham1972

    Bingo!

    I was about to ask for other applications which are installed on the machine.

     

    ..Sarthak

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:22 AM   in reply to Sarthak Singhal

    I've tried that and reinstall. Nothing works.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:23 AM   in reply to CalinR

    It started to work when I closed Photoshop CS5...

     

    Edit...

     

    and now it´s back again. Only have FW started.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:23 AM   in reply to CalinR

    Whatta..... Closing Spotify fixed this for me too! I opened Spotify again and the problem occured again. Closed Spotify and no problems. Weird!

     

    Thx!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:25 AM   in reply to CalinR

    Oh my god. Fix it! And send a report to Spotify!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:31 AM   in reply to CalinR

    OMG I also run Spotify and closed it and tadaaaa problem fixed. One hell of a nasty program that is!

    Apologies to Adobe

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2010 4:39 AM   in reply to calderonportillo
     
    |
    Mark as:
  • Currently Being Moderated
    Dec 21, 2010 2:59 AM   in reply to calderonportillo

    Quitting Spotify worked for me to.

     

    Thanks for this – have reported it here too.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 23, 2010 2:11 AM   in reply to JohnSkinner

    I have almost the same problem - can only select an object, if I first have selected a layer. I don`t have installed Spotify or an grooveshark-application. Can anybody help?

     

    Thanks,

    Anja

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 2:43 AM   in reply to CalinR

    This is the code in Spotify that is interfering with Fireworks: https://gist.github.com/764542

    The version that is live does not have Fireworks in its whitelist, nor does it pause the event tap (return early after the @synchronized{} block in -[setShouldInterceptMediaKeyEvents] to emulate old behavior).

     

    Would love to know how my code can interfere with mouse input in Fireworks.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 2:58 AM   in reply to nevyn (Spotify)

    Thanks Nevyn. Just checking if you are the official person whom we can talk further to resolve this issue? If yes, can you send me a message with your mail ID?

    We appreciate your initiative to make both the apps happily coexist on user environments.

     

    ..Sarthak

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 3:07 AM   in reply to Sarthak Singhal

    Sarthak: I've sent you my email as a private message.

     

    Note that the code I posted should fix any incompatibilities between Spotify and Fireworks at the sacrifice of media key integration when Fireworks is running, and will be live with the next version of Spotify.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 3:15 AM   in reply to nevyn (Spotify)

    And when can we expect this new version?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2011 4:33 AM   in reply to Pieter070

    That's not up to me, but if everything goes as I'd like, there might be a version on http://www.spotify.com/download/previews/ today or tomorrow

     

    UPDATE: You can get a preview build with the fix at http://www.spotify.com/download/previews/

     

    Message was edited by: nevyn (Spotify)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2011 12:56 PM   in reply to CalinR

    I also got this error while running OS X 10.6.6.

     

    In my case the app which caused the mouse to stop working in Fireworks CS5 was Soundcloud (downloaded through new Mac app store).

     

    What the F**k is going on here ?! How can there be so many apps which can cause an existing Adobe production app to just break basic functionality?

    (and is it coincidence that they all happen to be free musics listen apps ?)

     

    Someone from Adobe - can you please tell us more about this issue so we can hopefull have music AND do work at the same time ?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2011 9:13 AM   in reply to CalinR

    I had the same problem and have been tearing my hair out about it - thanks to whoever worked out that it was external program causing the issue.

     

    In my case I have both Spotify and Soundcloud running. Soundcloud seemed to be the culprit and now that its no longer running I am not having any issues.

     

    Also I am running CS4 version, so its not just CS5.

     

    Seems like an Apple/OSX issue to me...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2011 9:36 AM   in reply to CalinR

    Oh @Adobe

     

    Can you guys notify your support teams about this. I wasted 30 minutes on the phone with one of your Netherlands Customer Service guys earlier trying to diagnose the issue (without any progress)

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points