Skip navigation
Currently Being Moderated

Android Camera really choppy on Samsung Galaxy Tab

Nov 17, 2010 9:42 AM

Hi guys,

I'm building an AIR Application for Android devices and I'm using the Camera.

 

I found a really strange behaviour. When I first start the app and the camera initializes, I get around 1fps(!).

If I then press the home Button and klick on the app icon again, it's all good and I get the full framerate.

This same behaviour also occurs within the Tour de Mobile Flex app when I start the Raw Camera part.

As soon as I press home and then return to the app, everythings fine...

 

Anybody out there having the same issues and maybe a soulution?

 

Help is highly apreciated.

 

Gabor

 
Replies
  • Currently Being Moderated
    Dec 22, 2010 7:50 AM   in reply to Stellars_Jay,

    Just so you don't think you're the only one, we've created an app as well with Adobe Air and we're using the Galaxy Tab as well, and we're getting worse framerates than you!  We're getting about 1 frame every 15 seconds.

     

    I can do the same as you.  I hit the home button, and bring the app back into the foreground, and we get the full framerate back as well.  I do not have a solution either.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 27, 2010 6:30 AM   in reply to DavidAndroidDev

    I got the same trouble !

    No way to make it run better than 1fps with horrible slows and lags on the application !

    Regards

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 27, 2010 6:32 AM   in reply to yarus3

    I have a feeling that this is a Samsung issue more than Adobe.  I've deployed this app to my EVO 4G and to a few Motorola Droids as well, with no slowdown whatsoever.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2011 3:00 AM   in reply to Stellars_Jay,

    I'm having exactly the same problem. This is not good as I'm working to get an enterprise application rolled out very soon. Is there a way to elevate this somehow to get the attention of someone at the flash team?

     

    I tried changing CPU/GPU modes and that didn't help. I played with the FPS and that didn't change anything either.

     

    Mike

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2011 3:19 PM   in reply to MichaelCizenski

    This bug is marked fixed (very recently) in the Adobe AIR bug database. The fix should be available in the next release of AIR.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2011 3:27 PM   in reply to Joe ... Ward

    Fantastic! Now that's how customer service should be done!

     

    Mike

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 7, 2011 3:56 PM   in reply to Joe ... Ward

    Thank you so much!

     

    Kindest Regards to the Adobe Team!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2011 12:29 PM   in reply to Joe ... Ward

    I'll chime in to for a great big thanks also!  Love it!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 15, 2012 2:06 AM   in reply to Joe ... Ward

    can you post a link to the bug in the bugtracker? i cant find it, and i have the exact same problems on my galaxy tab and galaxy s2

     

    cheers.robin

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points