Skip navigation
Currently Being Moderated

copying from pdf comes out in single column

Jan 7, 2011 7:48 AM

Hi,

I recent turned 3 word documents into PDFs using the "Print" feature on my mac from within Word. Two of them came out great. The third one LOOKS great, but when you try to copy the text from the PDF and then paste into a Word document (or notepad or anywhere!), it appears with one word per line, like one long column.

It

ends

up

looking

like

this!

The other two PDFs copy and paste just fine. We do want our users to be able to copy and paste parts of these documents, and I can't figure out what is different about the third PDF. Even if I just highlight two words in the middle of a sentence and try to paste those, they still show up in a column format with one word per line.

 

Any ideas how to get rid of this without actually retyping the entire Word document?

Thanks so much in advance!

 
Replies
  • Currently Being Moderated
    Jan 7, 2011 8:30 AM   in reply to ellie88890

    You may want to ask this quesiton in the Mac forums (apple.com). It's probably not Adobe REader doing it but more of something in the

    creation process which is all Apple.


     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2011 2:42 PM   in reply to ellie88890

    I'm having the same problem on Windows XP. This is not just a MAC problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2011 8:35 PM   in reply to ellie88890

    Here's something that works for MS Word files, but it doesn't work for Text files. if you copy a block of text from a pdf and paste into a Word doc, and it pastes as one word per line, you can do the following:

     

    1. select the pasted text in the Word doc.

    2. use the Replace function, select replace all,  ^p with ^s

     

    This will convert one word per line back to a normal text paragraph.

     

    I still don't know what I did to cause spaces to be interpreted as line returns by default when copying pdf text to Word, text, or Excel files. This did not happen in the past. How annoying.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2011 8:37 PM   in reply to ellie88890

    Here's some more info for someone to resolve this issue:

     

    The one-word-per-line problem only seems to occur when copying text from a pdf that was created using "MAC OS X 10.6.6 Quartz" .  I have two pdf documents from different sources that had been created using this application that had the "one-word-per-line problem". I have six other pdf's that were created with various "non-Apple" pdf producer software that did not have this problem. So, this issue looks like it is related to Apple's pdf producer software. BTW, you can check the pdf creation softwware by selecting File/Properties in the pdf.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2012 12:11 PM   in reply to rrich3

    You just saved me hours of frustration and unnecessary work, rrich3!!  Thanks a ton!!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 1, 2012 10:50 AM   in reply to ellie88890

    I have been having the same trouble with the text being displayed as a column of text when I copy paste it from a pdf into TextEdit. From my detective work it seems to be connected to when a pdf is made of a document containing the font Calibri. Don't know what the solution is other than not to use Calibri in a document that is at some point going to be reformatted to a pdf.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 11:38 AM   in reply to ellie88890

    Amazing to see this problem is STILL alive and well!

     

    I am having the exact same problem on BOTH a Windows 8 system running Adobe Reader 10.1.7  and a Mac OS 10.7.5 system running Acrobat Pro 9.5.5.

    I was attempting to cut from a PDF and paste into a WordPress site via Firefox, and also tried to paste into MS Word 2013.  Always saw the same results using the same and various PDFs, and the lady in the cube next to me has the same problem.  Both of us tend to have lots of windows open in lots of apps.

     

    Interestingly, I did not have this problem yesterday on the Mac performing the exact same task from the same PDF on the same computer.

     

    The 'solution' is:

    Shutdown then power up the computer, then open ONLY the programs you NEED (Acrobat and the destination of the paste).  This worked on both the Win 8 and Mac computers!!

     

    IMHO, the best solution is to never use any Adobe products!! 

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 7, 2014 3:43 PM   in reply to Harley Dave 123

    This is still occurring. I'm using Acrobat XI Pro, and Mac OSX 10.9.

     

    If you have trouble copy/pasting out of a PDF in Acrobat or Acrobat Reader, just use Preview instead. Producing a PDF on a Mac and then reading / copying / pasting from Preview works as expected.

     

    The "every word on its own line" problem only occurs when copying from an Adobe PDF-reading product.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points