Skip navigation
wjwm
Currently Being Moderated

Apple Magic Mouse and ID

Nov 10, 2009 7:58 AM

I've recently purchased the lovely Apple Magic Mouse and am finding it quite difficult to use with InDesign CS4 - other ID versions would be the same I imagine. With this mouse you scroll by stroking its top surface, rather like a trackpad. This is excellent in other applications but in ID, because the pasteboard area is so large and the sensitivity of the mouse so high (even when scrolling is turned down to the minimum in its preferences), it's very easy to make your document shoot sideways off the screen. I expect Illustrator would have similar problems.

 

Is there a way in which the ID pasteboard can be resized or constrained? Maybe someone will come up with a prefs panel to control the new mouse's scrolling more precisely - but not yet.

 

Thanks for any ideas.

 

John Mallinson

 
Replies 1 2 3 Previous Next
  • Currently Being Moderated
    Nov 10, 2009 9:06 AM   in reply to wjwm

    I'm not writing because I know the answer, but to follow your thread. I've been thinking about buying the mouse, but want to hear how it works with ID, etc.

     

    I'm suprised it doesn't let you control the speed, since the macbook track pad gives pretty reasonable controls. I looked at the video and saw a scrolling with momentum with other options in the drop box. Do those do anything?

     

    Any other pros/cons you can mention specific to ID?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2009 11:48 AM   in reply to wjwm

    I wonder which sort of mouse you used before the "magic" mouse?

     

    I was very impressed with the earlier "mighty" mouse when it was released, because of the ability to scroll horizontally, and to quickly fly about like hell on wheels using the little ball thing in the middle. But it took a lot of "preference adjusting" to get it to work the way I really wanted it to.

     

    But then later, I got a Logitech mouse whose scroll wheel can be tilted/clicked (nudging what's in the screen horizontally, click-by-click with much more precision than the mighty mouse).

     

    I still use the "mighty" mouse, on another computer, with affection. But there is always a problem of predictability. I wonder if the "magic" mouse can get over those difficulties? -- My guess is that the controlling software needs to be updated, and probably will, quite soon.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 14, 2009 8:11 AM   in reply to wjwm

    Not that it's any consolation, but I've got the same problem. Exact same thing happens with Google docs spreadsheet as with ID: sudden page jumps, unreliable clicking locations, and superfast scrolling. People suggest it's Bluetooth, or ID, or the mouse driver, so that doesn't leave us with much to go on. Mouse setting adjustments definitely do NOT help, as I've tried them all.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 29, 2009 12:22 AM   in reply to wjwm

    Could so few people have this problem? I'm using a Magic Mouse with 10.6 and, yes, CS3 ID is also out of control with the wildly sensitve mouse. Worse yet, the scrolling occurs when ID isn't even the active app, so you can come back to the document but not where you left it. It's an extremely annoying attribute of an otherwise sensational improvement in pointers.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 29, 2009 5:46 AM   in reply to rexprints

    Same here. I think it's because ID scrolls a lot with each 'tick', compared to the pixelwise scrolling in browsers and regular text documents.

    Photoshop appears to scroll like one would expect. (Just a mo') And so does Illustrator.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2010 7:28 AM   in reply to wjwm

    I would also like to add myslef to the list.

    I have found posts on the apple forum for 3rd party drivers but none of them seem to work.

    Any help would be great.

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2010 7:00 PM   in reply to wjwm

    Having the same problem here—the Apple mouse scrolling in ID and Illustrator is insanely bad.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 12:00 AM   in reply to thinkingmanhawaii

    Someone posted (I don't remember who), that if you turn off "momentum scolling" (or whatever it's called) in the mouse preferences, that solves the problem...

     

    Harbs

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 12:48 AM   in reply to Harbs.

    Thanks for the advice - however I haven't found this to be the case (just

    tried this and it didn't work—will try at home on the Mac Pro to see if it

    works there with that one's M. Mouse) - Mahalo, Adam

     

    Adam Prall

    [signature removed]

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 12:50 AM   in reply to thinkingmanhawaii

    I have not yet used a magic mouse myself, so I don't have further comment.

     

    In the future, please remove your signature before posting. You really don't want your email address posted on the web...

     

    Harbs

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 8:27 AM   in reply to Harbs.

    I've seen this suggested in other forums. It doesn't work, at least not to solve the problem with ID, Google maps and docs, and Excel. I have found it a little easier to control if I keep both fingers atop the mouse when scrolling around; that seems to eliminate stray and unintentional clicking.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 10:26 AM   in reply to Harbs.

    I've had the same email address for over 12 years, I'm pretty comfortable with it wherever it's posted...

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 10:32 AM   in reply to Peter Goodman 123

    I've had the same email address for over 13 years, I'm pretty comfortable

    with it wherever it's posted... anyway, back on topic, I've been looking

    around I haven't seen any controls for scrolling sensitivity in these

    programs, which obviously use their own hooks into the mouse driver. If

    anyone comes across a patch or hidden preference editor, at least for ID, it

    would be helpful to post it here—I'll poke around the ID plist and see if

    there's anything in there).

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 11:23 AM   in reply to thinkingmanhawaii

    It's supposed to be in system preferences...

     

    Harbs

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 12:35 PM   in reply to Harbs.

    It is in Sys Pref's but it means you'll lose a valuable functionality of the Magic Mouse for everything else you do, a classic example of pitching out the baby with the bath.

      I've tried a few of the plug-ins and met new aggravations, but probably as a matter of personal preference, not worth burdening the forum.

      Let's just say pointing with gestures has a long way to go. To some extent the gestures should be App or even Doc level pref's, but not inconsistent across the System.

      As disappointing as this is to the few in these threads, I'm surprised this isn't a bigger issue. Any thoughts?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 2:34 PM   in reply to rexprints

    It's annoying, but I quickly learned to control it (somewhat) -- mainly by not resting my fingertips idly on top of the mouse, but grabbing it left and right to move and let my clicking fingers hover above it; and by not operating it when under the influence of too much caffeine.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 2:38 PM   in reply to thinkingmanhawaii

    Part of the problem may lie with Adobe. They have made some weird decisions with regards to how they deal with input over the years. Sometimes they are not the correct ones at all for OS X. For example, I loathe and revile their decision in CS4 to steal the shift scrollwheel shortcut for accelerated page up/page down scrolling. OS X, system-wide it is scroll left/scroll right on Macs. It may be that CS5 has better support for the Magic Mouse now they know it exists.

     

    For now, one option might be a script that tunes your settings for InDesign work. When you know you're going to do ID for a long stretch of time, trigger the script. When you're done, trigger it again to go back.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 3:28 PM   in reply to heavyboots

    Thanks @heavyboots; turning down scrolling speed to minimum does help

    InDesign—the only problem is that it’s not really doable for most people

    (like me, unfortunately!) who switch rapidly between apps and use scrolling

    speed extensively. I have a feeling Adobe will release a patch for this

    soon…

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 4:46 PM   in reply to wjwm

    I agree, it's far too sensitive. The core problem is that we have become so accustomed to resting our fingers on the surface of mice, because they always require a *definite* press, or scroll action. Now the magic mouse is so sensitive to ANY touch that it reacts to touches meant to push the mouse or were not meant to contact the surface of the mouse.

    At first I liked it a bit, but the more I use it, I think it's Apple's worst mouse ever. Puck included (at least you could buy a housing to put them in). This mouse doesn't "seem" to track the same as all other wired mice I've ever used. The touch interface is great for vertical scrolling, but as pointed out here, far to sensitive in circumstances where such scrolling is not desired. Perhaps this could be rectified with a *very* comprehensive preference panel, ie one that lets a user specify the amount of scroll or movement required to initiate a swipe/scroll. The Wacom tablet panel has such prefs, for each program and an overall control as well (ie all unspecified apps). My other major complaint against the mouse is the overall shape. It is simple not comfortable or natural. I prefer a more bulbous mouse, since like many of you I imagine, I end up using the back of my palm to "push" the mouse around or rest my fingers on it. The Magic doesn't lend to resting on it at all. I also need to lift it up, or scroll it farther to the side of the screen than the room I have on my mouse surface. With my Mighty Mouse I pick it up by the sides and put it back down somwhere in the center of my mouse area. I have a dual screen setup, and my coworkers all have 24" iMacs, so it can still be a lot of screen space to traverse.

    My Magic Mouse was a gift, but I still feel the $70 for it was a waste. I use it primarily because the scroll ball on the Mighty gets dirty fast and does not respond, and at that I rest the Magic next to my keyboard to scroll but still use the Mighty 95% of the time. If Apple would have made the exact same Mighty Mouse but only made the center area where the ball is, a touch sensitive surface, I would be in mouse heaven (they could delineate the area with a small inscribed line or something).

    IMHO big Apple Fail.

     

    Chris

    aka SuperMacGuy

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2010 5:13 PM   in reply to SuperMacGuy

    I teach this stuff so I should know that it's a mistake to think "it's my fault." I'm afraid the magic is wearing pretty thin for me too. I have  to use a track ball due to a life over-moused, but it's sad how the evolution of the mouse has gone. The white/clear ones failed due to broken connections where the USB wire went into the hard plastic housing. The little wheel on the next version clogged with whatever that disgusting clogger goo is. Now this.

      Anybody else have any luck with the third party drivers? Dare I ask if there's an app for that?

      Anybody know what percentage of users use Magic Mouse what percentage of the time? It would help to know if one were to press Adobe to fix Apple's problem.

      True that this isn't inventing anything. Tablets set preference all the way down to the tool level, on the fly. Setting pref's only at the OS level is a terrible idea for most users, I'm sure.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2010 12:04 AM   in reply to rexprints

    I actually like the Mighty Mouse. A little water (or alcohol) every 

    once in a while takes care of the scroll ball problem.

     

    Harbs

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2010 3:25 AM   in reply to SuperMacGuy

    In spite of the over-sensitivity I love the Magic Mouse. Excellent for web-browsing and programmes that support the two-finger swipe for navigation. I use MagicPrefs to add a three-finger click for Exposé and that seems to work pretty well. Unfortunately MagicPrefs does not include per-application preferences which is what we seem to need to deal with my original problem. Surely someone, somewhere must make this possible soon. I'm not holding my breath for Apple or Adobe to solve the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2010 3:09 AM   in reply to wjwm

    I too experienced the problem described by others in this thread. I'm using InDesign CS4, and Mac OS X, 10.6.3 (Snow Leopard). The solution, which works quite well, is to use a 3rd party mouse driver, called MagicPrefs. This utility allows you to extensively configure the Magic Mouse, including the ability to specify the region which is recognized on the surface of the mouse. By specifying that the mouse ignore input on the right 1/3rd (or so) of the mouse, you will no longer send InDesign input that instructs it to scroll horizontally unintentionally.

     

    Best of all, it's free! Get it here: http://magicprefs.com/

     

    I'm very happy with this solution, and recommend it to other InDesign users.

     

    Dave

     

    David Dell'Aquila
    Ux/Interaction Designer

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 8:19 AM   in reply to davedellaquila

    Where are you able to disable the touch surface for the right 1/3rd of the magic mouse like your post explained.  I can't stand using the magic mouse in CS5 and I really need to get this to work.  You mentioend that if you ignore input on right 1/3rd it will fix INDD problem. 

     

    Please explain to me how to do that with MagicPrefs

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 9:49 AM   in reply to lukeabeck_cs5

    I'm using CS4 (but I guess CS5 is similar). My major problem has been the side to side skidding of the document because of the width of the pasteboard and the over-sensitivity of the mouse. This can be killed with MagicPrefs by going into its Configure Scrolling dialog and disabling horizontal scrolling. I have a big enough screen so I can easily edit A4 spreads without zooming but if you have to, and want to scroll horizontally then use Alt-Spacebar-L mouse button to drag the document around.

     

    It's a pity that Apple haven't given us more control in their preferences panel.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 10:13 AM   in reply to lukeabeck_cs5

    Yes, I was able to fix this problem!

     

    1. First, make sure MagicPrefs is installed, etc. I'm using v1.9.2. Once installed, click the 'Configure Scrolling' button:

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 1:58 PM   in reply to wjwm

    Unfortunately this doesn't work for me as I rely heavily on Magic Mouse features. But I have noticed that with the latest round of updates, scrolling seems to be somewhat improved. There's still no control for it (that I've taken the time to find, at least!) but the issue seems to be not as insanely out of whack as it was. I'll keep this post updated.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 13, 2010 1:15 PM   in reply to wjwm

    Use BetterTouch Tools...

     

    Add an appliction > Adobe ID

    Add new gesture(s)

    -- Single finger swipe down

    -- Single finger swipe up

    -- Two finger swipe down

    -- Two finger swipe up

     

    Set the Predefined action to No action.

     

     

    This will essentially kill all scrolling within ID using the swiping. I find scrolling within ID annoying to begin with and having issues with it and ID so I have killed all scrolling using the MM. I typically use the hand tool or page up/down to move within ID.

     

    - e

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2010 12:29 PM   in reply to benwa02

    i downloaded the BTT, and followed your instructions, but it's not working...am i missing something??? i REALLY HATE the scrolling in ID...

     

    thanks,

     

    JD

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2010 1:58 PM   in reply to Jd_Johnson8

    JD,

     

    I'm not sure what to tell you. The solution I describe works well for me. You might need to play with the "dead zone" region a bit to get the best results for you.

     

    Dave

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2010 9:35 PM   in reply to Jd_Johnson8

    This may have something to do with Adobe licensing. I had another problem with this (using MagicPrefs), and then a simultaneous message on our machines (within a day of each other, which is how far apart CS5 was installed on them). We had to reenter our serial numbers, and all was OK after that.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 14, 2010 5:30 PM   in reply to Jd_Johnson8

    I've had the exact same problem and have finally made it work!

    After downloading the BTT I could not open it but I found out how in another forum...

     

    the shortcut to open the program is control+option+command+O, and there it is, finally appearing before our eyes!

     

    From this screen you may want to click on the General Settings tab and click the button 'Add BTT PreferencePane to your System Preferences' so you can open it from there instead of using the shortcut each time.

     

    Then go to the Gestures tab and do as benwa02 said.

     

    Add application (indesign), and make sure you click the option wheel at the bottom of the Select Application box (with ID selected) and select 'Disable single finger scrolling for selected app'.

     

    There you have it! No more feelings of wanting to pummel your beautiful mac anymore

     

    Brendo

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2011 3:40 PM   in reply to wjwm

    Same thing for me ID CS5 is UNUSABLE with an Apple Magic Mouse. I always go to my System Preferences and disable scrolling with the mouse while I'm using ID. Same goes for Microsoft Excel. It's a great mouse for web browsing and other apps but apps with horizontal scrollbars are a nightmare. ID is the worst so far for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2011 3:31 AM   in reply to wjwm

    I'm loving my Magic Mouse, even in InDesign. It took me a little while to figure out that the phantom scrolling and jerking was because of my middle finger resting on the mouse, and also to train myself to control the scrolling by not lifting my index finger. But now I'd struggle to go back, I think. I do like the weight as well. After a long day at the computer, though, my finger sometimes gets a twitch from holding it so carefully in position for so long.

     

    Just thought a fan should weigh in.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2011 8:36 AM   in reply to Graham van de Ruit

    Glad to hear somebody doesn't mind the problem, but really, having the user fix the problem isn't the best solution, especially if it makes them twitch!

      I dodge in and out of various jobs all day on various machines with various versions and settings, so patches, plug-ins, and preferences don't take the place of a basically good product.

      On the other hand (literally) the MM has advantages the recent un-Magic Mouses don't. As a graphics professor, I can tell you that little twiddle wheel won't roll long in student paws. The previous mouse got its tail/neck broken too easily where it exited the body of the mouse without reinforcement. The Magic Mouse hasn't been installed because I suspect its first bit of magic will be disappearing.

      I do agree that retraining your hands not to accidentally hover, swipe, or click is helpful. I try and hold the top corner by the edge because tactile feedback reminds me it isn't an old style mouse. That helps.

      The button-less mouse is a great breakthrough design. Next: The working mouse. Mouse action is actually backwards. You should be able to rest your hand on the mouse (90% of the day) and just lift it to signal. Ahhhhh. Humans weren't meant to maintain tetanus for a living. Leave that to the egrets.

      It's been a long time bother and its a relatively big problem (not compared to global warming, granted). This is a husband-and-wife that lands between Apple-and-Adobe. Would one or both of you please sort this out?

    --

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2011 7:52 AM   in reply to rexprints

    This problem doesn't seem to be limited to the Magic Mouse. I've found the same problems with ID CS4 and CS5 using my Mighty Mouse... and don't even get me started on how horrible the scrolling is with the Magic Mouse.

     

    I use a mighty at work, and CS3 scrolls smoothly with no jerks or skips whatsoever... but as soon as I switch over to CS5 (I have both installed on my work computer, so it's easy to compare), the scrolling control  is abysmal. I'm pretty confident the problem is with the apps, not the mouse.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2011 9:28 AM   in reply to wjwm

    I have this same issue with ID CS5 and the magic mouse. It's driving me insane, to say the least. BTT is a somewhat acceptable solution, though it would be nice if Apple gave us more than a handful of options for the mouse in system preferences.

     
    |
    Mark as:
1 2 3 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points