Skip navigation
Currently Being Moderated

Installing AIR SDK on Ubuntu?

Jan 21, 2011 5:13 AM

Hi everyone,


I am about to pull my hair off. I have tried to spent the complete  morning to install the Adobe AIR SDK on my Ubuntu machine and it just  won't work.


The runtime version is already installed and have verified it to be working with various  apps.


I have Googled like never before to get a solution by myself,  before asking here and have so far been able to find two tutorials (this and this) which I've followed the instructions of to end up with the same result;



Typing adl in the terminal ends up with Runtime not found being thrown.


What can I do?



  • Currently Being Moderated
    Jan 22, 2011 3:00 AM   in reply to industrial3


    Are you sure that the SDK has been downloaded properly?


    One way to get SDK working on Ubuntu would be:

    1. Download the SDK to a folder ( say: /home/sundeep/AIRSDK )

    2. Launch the terminal (gnome-terminal) and change directory to the above folder using the following command:

    cd /home/sundeep/AIRSDK

    3. Untar the tar ball using the following command:

    tar -xvf AdobeAIRSDK.tar


    4. Go to bin folder :

    cd bin

    5. Launch adl:




    Hope this works for you.



    AIR Team

    Mark as:
  • Currently Being Moderated
    Jan 24, 2011 2:12 AM   in reply to industrial3


    To be able to use ADL and ADT commands from anywhere you have to modify your $PATH variable to include the directory where you have downloaded the SDK.


    1. Launch terminal

    2. Open .bashrc file for editing:

    vim .barshrc

    3. Scroll down and add the following line:

    export ${PATH}:/home/AdobeAIRSDK/bin

    4. Save the file

    5. Close your terminal and launch again.


    Hope that helps !



    AIR Team

    Mark as:
  • Currently Being Moderated
    Jan 24, 2011 2:51 AM   in reply to industrial3



    Strange! For me adding the following lines is doing the trick:


    > export PATH=$PATH:/home/AdobeAIRSDK/bin/


    Let me dig deeper in and see if I can find something that can be causing the issue on your machine.


    After you have modified the PATH variable can you share what the ouput of the following command is:

    >echo $PATH




    AIR Team

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points