Skip navigation
Muggets
Currently Being Moderated

Web Services name clash with AS top level class

Jan 24, 2011 1:48 PM

Some context:

  •     New to Flex
  •     Using Flash Builder 4
  •     Flex 4.1

 

I'm trying to connect to a web service and I get the following error:

 

An error occurred while attempting to resolve the existing model.

 

ERROR : ActionScript generation is not supported for entities whose names clash with this top level (no package) ActionScript classes.
Entity "Error" clashes with an AS top level class.

 

Any pointers on how to resolve conflicts with the WSDL object names and AS classes?

 

Thanks!

 
Replies
  • Currently Being Moderated
    Jan 24, 2011 11:09 PM   in reply to Muggets

    This has been resolved in the upcoming version of FB.

     

    A workaround could be to replace the Error in the wsdl with a different word and use the WSDL to generate appropriate classes.

     

    After this you could use the convertResultHandler property (by pointing to your custom function) in the WebService class to actually convert the result to appropriate classes.

     

    By default FB uses a result handler function convertResultHandler defined in com.adobe.serializers.utility.TypeUtility in serializers.swc

     

    Hope this helps.

    -Sunil

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2011 3:30 AM   in reply to Muggets

    I'm also encountering the same problem with Flash Builder 4.5.

     

    I'm connecting to a web service that also has an "Error" object defined.

     

    Is there any way to resolve this issue?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2011 6:57 AM   in reply to Muggets

    You might want to look at your database field names and make sure you're not using names that match Actionscripts reserved name types.  There's possibly an illegal name in your database field list.

     

    In my case, I had a field called 'classes' in my database that produced the same error. When I changed it to 'myClass' the error was resolved.

     

    I'm not sure if this is useful.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2012 2:19 PM   in reply to SunilAdobe

    I am importing a Partner WSDL from SalesForce.com and am still getting the same error. Has this ever been fixed?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points