Skip navigation
Currently Being Moderated

QTP not able to spy on the Acro objects

Dec 28, 2010 10:53 AM

We're trying to validate PDF content using QTP 10.0 and the Adobe PDF Tool Kit (Aptt).

Our issue is that QTP is not able to spy on the Acro objects nor can we add then to the Object Repository.

We tried a bit of troubleshooting and these are our observations so far.

The AcroQTP Add-in is loaded and I can see the object classes in QTP but none of the objects are being recognized

Tried to run the demo tests which came with the Aptt. QTP is not able to identify the PDFDoc object from these tests either.

We've installed Acrobat Pro X (and uninstalled Reader)

Tried all of the above on 2 separate machines (Windows XP with SP3)

Would you please help us out with this? Have we missed anything?

  • Currently Being Moderated
    Jan 12, 2011 12:57 PM   in reply to JoMathew


    I have encountered something similar to this problem and had written this note to myself:

    To resolve this problem, I changed QTP's Record & Run Settings to only look at the Reader application.   This might have been the trick but I also needed to restart QTP and/or Reader to record a checkpoint [or otherwise spy on objects] correctly.


    The Record & Run Settings are specific to each project (each Test in QTP), so if you create a new Test/project in QTP, you will need to redefine these settings.


    Hope that helps.

    Mark as:
  • Currently Being Moderated
    Mar 16, 2011 5:59 AM   in reply to JoMathew

    Hi Mathew,


    Did you find any solution?It clearly says APTT suppports Acrobat 9.2 and QTP10.0.




    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points