Skip navigation
Currently Being Moderated

BlazeDS and Tomcat 7 (Java 6)

Jan 13, 2011 8:26 PM

Is anyone aware of BlazeDS being supported on a Tomcat 7 installation, specifically for running against Java 6?  I am hosting Java code in a war file that will only build successfully against Java 6 and need to have BlazeDS deployed into a Tomcat 7 installation.

 

Thoughts / ideas?

 

Thanks

 
Replies
  • Currently Being Moderated
    Jan 28, 2011 6:11 AM   in reply to Wembley76-Mbzl9l

    BlazeDS 4 requires Tomcat 7, which requires Java 6.  Tomcat 7 is more secure, runs faster and requires less resources than Tomcat 6.

     

    Mike

    http://www.slinnbooks.com/books/serverSide/index.shtml

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2011 7:16 AM   in reply to mslinn

    BlazeDS has no hard dependancy on its servlet container.  It is also worth noting that we don't "support" BlazeDS at all - you must buy LiveCycle Data Services to get an officially supported platform.  The current release version of LCDS (3.1) does not suport Tomcat 7.

     

    All that being said, we developed BlazeDS on Tomcat 6.  Tomcat 7 is too new for us to have even tried it.

     

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2011 7:28 AM   in reply to tomj

    Thanks, Tom.  I'll follow up with the FB team to see if this is a bug.

     

    BTW, I attended a Tomcat 7 security seminar yesterday, and it seems that

    Tomcat 7 is much more secure, faster and smaller than Tomcat 6.  Apache

    is recommending that Tomcat 7 replace Tomcat 6 in production.

     

    Mike

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points