Skip navigation
BugsBn
Currently Being Moderated

where are swcs and bin directories?

Dec 20, 2010 11:47 PM

am also getting these errors (in  additon to others reported before) after latest SVN checkout (19495) and  importing insync sample project:

where are the bin directories?

cannot find them anywhere in the installation.

find . -name Module.swc -print;

nothing here...

find . -name Module\* -print;

doesn't show any bin dirs either.

 

do we need to build all this using Maven?

if so, what about all the build errors reported before?

 

 

----------

Description    Resource    Path    Location    Type
unable to open '/Module/bin/Module.swc'    insync-modularExtended-api        Unknown    Flex Problem
unable to open '/Observer/bin/Observer.swc'    insync-basic        Unknown    Flex Problem
unable to open '/Observer/bin/Observer.swc'    insync-basic        Unknown    Flex Problem

 
Replies
  • Currently Being Moderated
    Dec 21, 2010 3:00 AM   in reply to BugsBn

    Hi Gary,

     

    I'm trying to reproduce your issue, have you imported the projects located in the libraries folder as well?

     

    /Module/bin/Module.swc,  '/Observer/bin/Observer.swc'  relates to projects that should be located in your workspace.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 21, 2010 4:32 AM   in reply to BugsBn

    You should declare the M2_REPO in your workspace linked resources: Preference->General->Workspace->Linked Resources.

    The M2_REPO variable should point to your local maven repository.

     

    Regarding the bin folders, you can either import the other projects in your workspace or copy the generated libs that you built with Maven (and rename them if you want).

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 22, 2010 1:59 AM   in reply to BugsBn

    It seems that you do not have the ant plugin install on your Flash Builder. Which version of the builder are you using?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2011 2:50 PM   in reply to BugsBn

    I'm in exactly the same situation. I'm using Flash Builder Standard 4.0.1 (build 277662) along with the 4.1 Flex SDK. I've checked out the project http://opensource.adobe.com/svn/opensource/cairngorm3/trunk/samples/in sync/insync-basic and when I try to build it I get the error "unable to open '\Observer\bin\Observer.swc'".

     

    I think I have the Ant plug-in installed. That is, if I try to install from Ganymede Update Site \ Java Development \ Eclipse Java Development, I get the message "Eclipse Java Development Tools will be ignored because it is already installed."

     

    Other things I've tried:

    1) Setting up Maven (it works).

    2) Getting http://opensource.adobe.com/svn/opensource/cairngorm3 to my local folder C:\Program Files (x86)\Adobe\Adobe Flash Builder 4 Plug-in and setting the environment variable M2_REPO to C:\Program Files (x86)\Adobe\Adobe Flash Builder 4 Plug-in\cairngorm 3\maven-repository.

     

    This really should not be so hard.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2011 2:30 PM   in reply to scotchfasterr

    I eventually got this to work by creating a brand new project and copying in files. A description of what I went through and a ZIP file containing the fixed project can be found here:

     

    http://journeysinflexland.wordpress.com/2011/01/28/wwcbd/

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points