Skip navigation
Currently Being Moderated

Disable ALL snapping??

Mar 1, 2011 8:31 AM

I have seen a couple of people post a similar question in these forums with no real response:

 

It seems there is no way to stop illustrator (CS5) from snapping to the edge of the artboard.  Even if you hide the artboard, it still snaps to the invisible artboard.

 

is it possible that the brilliant folks at adobe missed this one and there is no way to disable this snapping to the artboard?

 
Replies
  • Currently Being Moderated
    Mar 1, 2011 8:58 AM   in reply to MilkyTech

    Nope. You're correct. The artboard bounds always snap. It's annoying. I've filed a couple feature requests about it.

     

    The only solution is to move the artwork or adjust the size of the artboard so you aren't working at it's edge.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 11:01 AM   in reply to MilkyTech

    In CS4 I can turn off preferences >> smart Guide >> alignment Guides(OFF), and that turns of snapping for me to the artboards. Unless they changed this for CS5 would believe this would work for you too.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 11:05 AM   in reply to Mike Gondek

    Doesn't seem to make a difference for me in CS5, Mike.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 12:14 PM   in reply to [scott w]

    I tried this at different zoom levels in CS4 , and with snap to point on, and a snapping tolerance of 4pts.

     

    Strange thing is that once I get to 1600% or greater zoomed in snapping stops, whether I have the alignment guides checked or not. You may want to try being zoomed in CS5 to see what happens. That aggravates me, cause when I am zoomed in I really want snapping to work.

     

    If I try to snap at a distance, I may see smart guides flash intersect drop it but every once in awhile miss one of the coordinates and don't notice till I zoom in. I often see people trying to snap with a wacom tablet, am I wrong for thinking that the wacom is the wrong tool to use when snapping?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 12:16 PM   in reply to Mike Gondek

    The tablet shouldn't matter. I've been using a tablet 100% of the time in all applications for at least 5 years. Never really had an issue with it. How you drag a handle or object doesn't matter. It's all dragged the same within the app.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 12:18 PM   in reply to MilkyTech

    OK I tried the 32px artboard, and it still did not snap with the smart guides >> alignment guides off in CS4.

     

    Picture 2.png

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 1:01 PM   in reply to MilkyTech

    Ahhh.. I figured it out.....

     

    Set the Preferences > Smart Guides > Alignment Guides to unchecked.

    Then

    Turn ON smart guides (I normally have them off).

     

    No snapping.

     

    So you must have smart guides on, and the alignment guides unchecked.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 1, 2011 1:08 PM   in reply to [scott w]

    Also turn off align to pixel grid in CS5 if you have that on in the transform palette.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 1, 2011 3:38 PM   in reply to MilkyTech

    Oh my god guys you saved my macbook, I was about to throw it from the window after an hour of unsuccessful attempts to move a couple of lines around, this snap was ruining it again and again and I was really pissed off after turning out all snapping options in the program and still having this snap to artboard.

     

    Thanks for helping with this annoyance!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2011 3:12 PM   in reply to [scott w]

    Thanks scott...

     

     

    I had this frackin' artwork with a stroke aligned to middle and the frackin' thing was snapping to the INSIDE of the stroke, couldn't change the stroke to align to inside or else artwork would get screwed... trying to make the artwork the exact size as the artboard there so had to do it manually since it was snapping at the wrong spot. NOT SO QUICK... had to run troubleshooting just to get a piece of artwork to line up to the edge of the artboard properly and have been doing this graphic design stuff for half my life. NOT COOL.

     

    Update: so it took 20 minutes to resize a piece of art the exact size of the artboard. Phew!!!!!! Now for something REALLY challenging!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2012 12:22 PM   in reply to dale223223223

    EVERYthing I try, does NOTHING! this is outrageous. Snap to whatever is still persistent with illustrator CS 5.0.

    What an unreliable feature! When you need it to snap, it fails.

    I have often zoomed in due to an acute lack of confidence.

    And sure enough, my selected object did not do what it lead me to believe it would do.

    Is this product now a victim cheap offshore child labourers?

      This brutal flaw wastes SO MUCH of my time each, and, every day.


     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2012 10:15 AM   in reply to MilkyTech

    Its a very bad thing because illustrator is one of the most used apps for design, is in the top of gamma for this design market and someway Adobe have a monopoly in this, for many designers how us, we can´t do anything, just most adapt. In this moment, (how many other), I have the same problem, and I most transform my vertor draw 400% for this problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Aug 26, 2012 2:58 PM   in reply to MilkyTech

    I'm new to CS6...upgraded from the very old CS3 and I had trouble moving object in tiny increments without it snapping back to where it originally was.

     

    I too had turned off all the "snapping" stuff under Preferences and under Window...but nothing worked...

     

    MY SOLUTION... turn off the anit-aliasing feature hiding under the transform window.

     

    Note: I plan on turning this back on again once I'm done creating this artwork, since I am using it on websites and have learned that the anti-aliasing makes the type appear crisper when converting to a PNG.

     

    Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 19, 2013 10:36 AM   in reply to swissmisses

    Under View menu,  make sure "Snap to grid" and "Snap to point" are both unchecked.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2013 5:13 PM   in reply to MilkyTech

    Guys, I had given up on Illustrator because of this.  I had been doing all my vector work in PS.  I'm using CS6, and NONE of the above worked for me.  But I figured out:  When you create a new document make sure you turn off "align to pixel grid IN THE NEW DOCUMENT DIALOGUE!   (apologize if web shouting is offensive to some, but some of us are in a hurry and quick glances are more effective like this!) 

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 17, 2014 12:57 PM   in reply to CreatePersuasion

    None of the suggestions here worked for me. However, if I turn Smart Guides ON, then I am able to align two existing points very close to the edge of the artboard without it snapping to the edge of the artboard. I did have to be zoomed in.

     

    CS6

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points