Skip navigation

Profiler stopped once intstalling flash player debug 10.1

Jun 11, 2010 2:41 AM

  Latest reply: Anand Gaurav, Mar 10, 2011 2:42 AM
Replies 1 2 Previous Next
  • Currently Being Moderated
    Aug 26, 2010 7:15 AM   in reply to ylluminate

    Thanks Flashbabaika  for the detailed description. A bug has been filed with the player team for the same.

     

    ylluminate,

     

    >

    > Had the problem fixed with 10.1 for about a month with statically setting the ip to 127.0.0.1, however now we're back to a point of failure it seems.     

    > Previously only IE would work and now IE is failing as are all other browsers.

    >

     

    Any changes in the system which which could have triggered that you could recall ? Since you were able to get it work before by statically setting the ip to 127.0.0.1 ?

     

    Let me try manipulating the IPs at my end to reproduce the problem. It would also be helpful if somebody on the forum could try the above option(statically setting the ip to 127.0.0.1) and let us know if it affects the working of Profiler in some +ve way ?

     

     

    Anand Gaurav.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2010 12:28 PM   in reply to SonicImagery

    Hahaha, thanks for finding my blog article and posting it on here!

     

    Today Tier 3 support called me (Kurt Mossman @kurtmossman) and had it solved in a matter of minutes. I've updated my article to have the resolution, but will post it here as well. I hope it helps some of you out.

     

    1. open a command prompt
    2. run the command “netstat -an > c:\test.txt”
    3. it creates the file test.txt with a list of all the ports open on your machine
    4. The Flash Builder 4 profiler runs on port 9999
    5. In my test.txt file I had a line that showed TCP    0.0.0.0:9999           0.0.0.0:0              LISTENING
    6. What you’ll need to look for is something similar for anything TCP listening on port 9999
    7. After identifying that port 9999 was already in use, it was a simple matter to change the port that the Flash Builder 4 Profiler uses
    8. Launch Flash Builder
    9. Go to Windows > Prefrences
    10. Go to Flash Builder > Profiler > Connections
    11. Change the port number to something that isn’t being used according to your test.txt file (we used 9997)
    12. Click Apply > Ok
    13. Close Flash Builder
    14. Launch Flash Builder
    15. Launch the Profiler
    16. WORKS!

     

    I'm running Windows 7 64-bit (which they tried to tell me wasn't supported when the website says it is), also using Flash Player 10.1.

     

    Booya!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2010 11:16 PM   in reply to __TK421

    Thanks for posting the resolution.

     

    A FB bug FB-27425 has been created to atleast show the user warning/error message when the port is already in use. Else its such a mess to find out the actual problem !

     

    Others please try this and let us know if the problem is indeed fixed with the above resolution.

     

     

    +Anand

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 31, 2010 12:15 AM   in reply to Anand Gaurav

    Unfortunately, did not work for us.

    1. Before running profiler there was no line with port 9999

    2. Anyway, changed it to 9998 with no positive results.

     

    After running profiler there appears a line with port 9999 (or 9998 after changing configuration) LISTENING

    After closing the error window the port closes (as I understand this is regular behavior)

     

    Two more details about our invironment:

    Not sure if that could help but we are working on the next two PC types:

     

    1. DELL OPTIPLEX 760;

    2. HP dc7800/7900;

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2010 7:01 AM   in reply to Lemtz

    I just had same issue and lost few hours on it.

     

    Debugging works but profiler not.

     

    Actually, the problem was the wmode=transparent in my case.

     

    Hope that helps someone here !

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2010 12:05 PM   in reply to Lemtz

    Hi,

     

    I finally found something that works for me. The new Flash Player 10.1 doesn't load the mm.cfg the same way the profiler does.

     

    It now use the HOMEDRIVE and HOMEPATH environment variable to determine the location of mm.cfg. For me, those 2 variables were set to a network drive created by a login script, because of the domain I was login in.

     

    Anyway, if those 2 variables are not the same has USERPROFILE, the environment variable that Flash builder use to get the mm.cfg, your flash player will never know that it needed to start the profiler.

     

    One very quick solution is to fisrt locate where your HOMEDRIVE and HOMEPATH points. For me, I found out that opening the command prompt (cmd.exe) will start me at that location. Then just put a mm.cfg at that location with the info to start the profiler (PreloadSwf=...) at it will work.

     

    By the way, I'm running with windows XP.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 22, 2010 8:07 AM   in reply to Lemtz

    FlashBuilder 4.0.1

    Windows XP

     

    I have gone through all the suggestions here and the only one that works is launching my app in FP 10.0. So I test in 10.1 in the browser, but when profiling I have it launch in the 10.0 standalone player.

     

    To describe the scenerio further, when profiling in FP 10.1 I am *not* presented with the Configure Profiler dialog which allows you to choose the profiling options. My app just launches, the Profile pane is empty and eventually I am presented with the "Unable to connect..." dialog. When profiling in FP 10.0 standalone everything works as advertised. Hope a FP 10.1 update is in the works to address this issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2010 10:27 AM   in reply to malab36

    Thanks, malab36 !!!

    Yes, that is finely a problem. In our domain USERPROFILE != HOMEDRIVE+HOMEPATH.

    HOMEDRIVE is set to network drive.

    setting it back to default c:/ solves the problem. But that is definitely a bug because flex is able to find mm.cfg in USERPROFILE

    and modify it with an appropriate line before launching profiler. The problem is that Flashplayer 10.1 does not look for it in USERPROFILE.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 9:15 AM   in reply to Lemtz

    Hey everyone here is one other potential solution:

    Go to Adobe Labs and downloaded the Flash Builder Burrto preview http://labs.adobe.com/technologies/flashbuilder_burrito/. I was having this exact problem and none of the suggestions worked, but Burrito did. Mmm burritos... Hope this helps some of you.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 10:19 AM   in reply to Adobe Joe Kenobi

    OK, so I just found out some bad news. I thought that it was working in Burrito, but it was because it was launching in Chrome. It does work in Chrome just not in Firefox.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 10:38 AM   in reply to Adobe Joe Kenobi

    Work-around Found!!!

     

    If you go to your profile perspective and select Profile -> Profile External Application then select the option to Launch the app manually outside Flash Builder then navigate to your app in Firefox that works. Kind of crappy to have to do it that way, but it works.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 12:41 PM   in reply to Adobe Joe Kenobi

    Kenobi. What worked for me was mentioned here by malab36. FlashBuilder is looking in an incorrect location on your machine if you have a network home drive and where that mm.cfg file is it does not have the required PreloadSwf line for the profiler to work. Below is the line I added matching my workspace and now profiling works for me with the latest version of the flash player.

     

    PreloadSwf=D:/workspace/metadata/.plugins/com.adobe.flash.profiler/Pro filerAgent.swf?host=localhost&port=9999

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 4, 2010 12:59 PM   in reply to Christopher VA

    Hey thanks Christopher! That worked. I appreciate you taking time to make that post more obvious to me!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 5, 2010 9:02 AM   in reply to Adobe Joe Kenobi

    Ok, so I don't mean to keep going on this one, but I found one other thing that might help people. With Firefox I've noticed that I get inconsistent results if I have it open already and it attempts to profile my swf in a new tab of Firefox. I read somewhere that this could cause issues and from what I've seen it does. For best results with Firefox make sure it's closed before you profile. The profiler will launch Firefox and begin to profile. Most of y'all probably know this, but if anyone else is still having issues this might be the reason why.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 2, 2010 4:50 AM   in reply to Lemtz

    I'm on a mac and have the same problem - no profiling with flash debug player 10.1

     

    When profiling, mm.cfg gets updated with "PreloadSwf=/Users/tcaspersen/Documents/Adobe Flash Builder 4/.metadata/.plugins/com.adobe.flash.profiler/ProfilerAgent.swf?host= localhost&port=9999"

     

    This points to a non-exisiting folder, actually there is no ProfilerAgent in the Documents folder at all - it resides in Applications/Adobe Flash Builder 4/and so on.

     

    Is there a way to change this path?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2010 9:57 PM   in reply to Lemtz

    This issue has been fixed in Flash builder Burrito. If you are part of CAB forum, please download the latest Flash Builder Burrito build and provide the feedback.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2010 11:34 PM   in reply to Kishan M V

    What? Does this mean that one of the major selling points for Flash Builder Professional just remains broken and the answer from Adobe is "wait for the next version"? I can't rely on beta software for doing my day job and as far as I'm aware there is no release date for Burrito.

     

    I hope I've misunderstood something here, because as it stands, it looks very unsatisfactory.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 7, 2010 1:05 AM   in reply to casper_no

    Hi,

     

    Work around for this issue are

     

    If you have configured active directory domain and  home path is set on the user network drive, manually creating the mm.cfg file http://livedocs.adobe.com/flex/3/html/help.html?content=logging_04.htm l

     

    Another work around is, you can roll back to 10.0 player.

     

    Please let us know if this solves your issue.

     

    Thanks,

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 7, 2010 1:26 AM   in reply to Kishan M V

    Hi,

     

    Thanks for helping.

     

    The page: http://livedocs.adobe.com/flex/3/html/help.html?content=logging_04.htm doesn't specifically address my issue  - I'm on a mac so the the domain and home path issues don't apply.

     

    But I tried to manually create a mm.cfg and inserting  "PreloadSwf=[correct path here]/ProfilerAgent.swf?host= localhost&port=9999". I put the mm.cfg first in Library/Application support/Macromedia and when that didn't make a difference I moved it to /user/. Where it didn't make a difference either, but got overwritten when I launched a profiling session from FB.

     

    So I'm back to square one. It seems like mm.cfg get the wrong path to profilerAgent.swf and manually editing mm.cfg doesn't help.

     

    Reverting to 10.0 would help for this project, but I need 10.1 for other so that would make for an awfully cumbersome workflow.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 15, 2010 2:31 AM   in reply to casper_no

    Does this mean that when you downgrade to 10.0 all works fine but when you are back to 10.1 Profiler doesn't work ?

    I am asking this because at first glance it doesn't seem to me like the 10.1 issue (the issue for which this thread started). Since Profiler is able to find the mm.cfg properly and is updating it implies its not the same 10.1 issue. I guess there might be some problem with the installation. Ideally the file ProfilerAgent.swf should be present in the /User/... location.

     

    What's the correct path of ProfilerAgent.swf as of now ?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2011 9:05 PM   in reply to Lemtz

    I'm having this issue as well. I tried all the suggestions here but none of them seem to work.

    My setup:

    Flash Builder: 4.5

    Flash Player: Mac 10,0,45,2

    Debug Player: Yes

    OS: Mac OS 10.6.6

     

    I downgraded from Flash Player 10.1 so now  i have 10.0 but that didn't fix the problem.... any help?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2011 10:23 PM   in reply to sanggpark

    Which browser are you using ?  If its chrome, then go to "chrome://plugins"  in the chrome address bar; expand the flash player plugin by clicking on the "details" link and then disable the release flash player.

     

    +Anand

    "angaurav at adobe dot com"

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2011 11:17 AM   in reply to Anand Gaurav

    no browser, i'm building an air app

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2011 2:42 AM   in reply to sanggpark

    Try to locate the mm.cfg file and check if its updated with something like:  "PreloadSwf=/Users/..../../Adobe Flash Builder 4.5/.metadata/.plugins/com.adobe.flash.profiler/ProfilerAgent.swf?hos t= localhost&port=9999"  ?

     

    Note: this is appear only momentarily.

     

    Send me whats it is updated with (along with other contents of mm.cfg). Also do send me the location of the FlashBuilder install on your machine.

     

    +Anand

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points