Skip navigation
simon Deshon
Currently Being Moderated

After Effects error: crash occurred while invoking rendering plug-in "Advanced 3D"

Nov 2, 2010 8:20 AM

Process:         After Effects [356]
Path:            /Applications/Adobe After Effects CS5/Adobe After Effects CS5.app/Contents/MacOS/After Effects
Identifier:      com.adobe.AfterEffects
Version:         10.0.1 (10.0)
Code Type:       X86-64 (Native)
Parent Process:  launchd [122]

OS Version:      Mac OS X 10.6.4 (10F2090)

Processor: 2.93 Ghz Intel Core i7

Memory: 16GB 1333MHz DDR3

ATI Radeon HD 5750:

  Chipset Model: ATI Radeon HD 5750
  Type: GPU
  Bus: PCIe
  PCIe Lane Width: x16
  VRAM (Total): 1024 MB
  Vendor: ATI (0x1002)
  Device ID: 0x68a1
  Revision ID: 0x0000
  ROM Revision: 113-B9710C-238
  EFI Driver Version: 01.00.417
  Displays:
iMac:
  Resolution: 2560 x 1440
  Pixel Depth: 32-Bit Color (ARGB8888)
  Main Display: Yes
  Mirror: Off
  Online: Yes
  Built-In: Yes
  Connection Type: DisplayPort

...seems to crash around a when scrubbing timeline and when rendering.
I've tried turning off 'Use OpenGL Renderer' to no avail.
any helpwould be greatly appreciated any additional info I can supply to help resolve.
Best Wishes
Simon
 
Replies
  • Currently Being Moderated
    Nov 2, 2010 9:03 AM   in reply to simon Deshon

    Try removing the OpenGL plug-in entirely. See this page:

    http://kb2.adobe.com/cps/405/kb405948.html

    Try the solutions on that page in order.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2010 9:26 AM   in reply to simon Deshon

    > If I remove OpenGL does that mean I'll be missing a trick in CS5?

     

     

    You won't miss it. Most experienced After Effects folks only use OpenGL for the OpenGL - Interactive Fast Preview mode. That's a useful little feature, but nothing huge.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2010 2:44 PM   in reply to simon Deshon

    I am getting the same error but for but "format plug-in "PNG"", "rending plug-in "Advanced 3D", effect plug-in "Slider Control" and effect plug-in "Tint"".
    It's only happening on one shot in my timeline, which is one of the more simple constructions. Also it will crash even if I place the playhead on the timeline over that shot, even at a 1/4 resolution

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2010 2:45 PM   in reply to ANDREW_GOLDSMITH

    Also, I already tried removing Open GL

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2010 2:53 PM   in reply to simon Deshon

    Well, I got desperate and tried this:
    Keeping caps lock on I navigated my way to the composition, copied all the layers, dumped them in a new comp and had to re-link my expressions. I released Caps Lock and Wallah! I didn't dare double check the old comp and just removed it from the timeline. It now sits in a naughty folder in my project.
    I don't understand why this worked, but it did. Maybe try it?

    Cheers

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2010 9:29 PM   in reply to ANDREW_GOLDSMITH

    It turns out this didn't actually fix the problem. It only allowed me to preview the comp without crashing. Kevin Camp suggested here: http://forums.creativecow.net/thread/2/955555 that one should try deleting the after effects preference folder.
    This seems to have worked for me so far and I am now pre rendering the as a safety

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 9, 2011 1:42 PM   in reply to ANDREW_GOLDSMITH

    We've been having THE EXACT same thing happening here at a studio trying to render. Constant crashes invoking seemingly innocuous things like "Levels" and "Tint". But I have also have gotten the "Advanced 3D" crash as well as "Open GL". I (of course) had already disabled OpenGL and even removed the plugin just to be safe, but even AFTER doing this I somehow still got a crash invoking "Open GL".

     

    The crashes are random and maddening. Sometimes it will render fine for 3 hours, sometimes it will crash repeatedly 4 times in a row. Ridiculous. BUG. FIX.

     

    Running OSX 10.6.6 with version 10.0.1 with 13 gigs of ram on a 3 Ghz quad-core.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2011 1:15 PM   in reply to jackthegiantslayer

    It is very uncool.
    By memory the only way I could ever work around it was by resetting/deleting the preferences -which is really annoying because then you have to readjust them all to your liking again and once you do that you'll probably have to reset/delete them again sometime soon when you try to render your project.
    From what I remember you hold command + option + shift while opening AE (ctrl + alt + shift for pc) to do this but check the link I attached above otherwise.

    Good luck

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2011 7:15 PM   in reply to ANDREW_GOLDSMITH

    At least we know we're not alone! Adobe, get the lead out, please.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 13, 2011 2:57 PM   in reply to simon Deshon

    Hi,

     

    I'm not a 100% sure this is the right answer but here is thoughts on why After Effects is crashing on you. Its crashing because of you not having a good "graphic card" on your computer. So if you don't what you need to do to stop it from crashing is In the Composition panel of after effects (the main panel) there a "lighting bolt" icon  if you click on that icon to toggle it open you'll a menu & select this in the menu "Adaptive Resolution-OpenG1 Off" this will stop it from crashing it did for me. Hope this helps you or anybody else who may be having this problem....Picture 3.png

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 9:30 AM   in reply to simon Deshon

    I have had this error twice now in the past 2 weeks,  both times it was a corrupt Illustrator file..  I had to import the project file and go through each file one by one til i found the corrupt file.. Then I just resaved the illustrator file, and the problem was gone..

     


     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 9:33 AM   in reply to jtw0728

    That's just the Previewing Open GL selections.  To turn Open GL off for rendering, go to AE Preferences.

     
    |
    Mark as:
  • Currently Being Moderated
    May 11, 2012 1:22 PM   in reply to jtw0728

    I was getting the Advanced 3D error too.  I just reloaded a .jpeg image along with a video I had in a precomp and it is finally rendering.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 31, 2013 6:32 PM   in reply to simon Deshon

    This bug has been fixed in the After Effects CC (12.1) update:

    http://adobe.ly/AE_CC_12dot1_details

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)