Skip navigation

Background PDF export Help

May 28, 2010 9:26 AM

  Latest reply: John Hawkinson, Feb 22, 2012 2:29 PM
Replies 1 2 3 4 5 Previous Next
  • Currently Being Moderated
    Sep 14, 2010 4:04 PM   in reply to webheads1835

    Hi all, this problem blows,Adobe is almost as bad as Mac these days. What happened to the days of Mac, the best, fastest, most stable machine in the industry with the Adobe programs to top it all off????  Gone are those days.

     

    ANYWAY, this doesnt fix the program error but will get you out of trouble. Print a POstscript file first, then run it through Distiller. Works every time. Remember Distiller, haha.

     

    Good Luck.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 4:09 PM   in reply to thunkup

    There have been several workaround and using distiller is the worst of the bunch.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 4:15 PM   in reply to Bob Levine

    What do you recommend?? I really need help here, I have a deadline fast approaching and your right, Im finding out that distiller isnt working like a charm

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 4:23 PM   in reply to thunkup

    Create a new book file. Add the document and export from there.

     

    Books export in the foreground.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 4:32 PM   in reply to Bob Levine

    Awesome, thank you Bob, much appreciated

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 4:39 PM   in reply to thunkup

    @thunkup, another way is this script here, I've referenced it once on this thread already (), if you're comfortable with using scripts it might be a bit faster, it's just another method of bypassing the background export like the book method does.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 5:08 PM   in reply to Stix Hart

    Thanks for your help, but what do I do with this code?? I am comfortable with HTML, but never knew I could apply this sort if thing to a program.

     

    Is it easy??

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 5:12 PM   in reply to thunkup

    Have a look at this and also the posts following this one (further up this thread).

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 5:13 PM   in reply to thunkup

    Oh, and yes it is easy, and well worth getting involved in and learning a bit about.


     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 5:15 PM   in reply to Stix Hart

    Awesome, thanks for all your help, Ill give it a go right now.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 5:24 PM   in reply to Stix Hart

    Not working, what should the extension be?

     

    I have used .jsx and .txt

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2010 5:28 PM   in reply to Stix Hart

    It worked fine once I removed all the Commented code from the top.

     

    Your a champion, thanks mate

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2010 7:28 AM   in reply to webheads1835

    webheads1835 wrote:

     

    Anyone else have problems with Packaging in CS5?  Some files when I package them for output to my printer it freezes on the last stage of the process the "open file" stage, the file is corrupt after that too.  Maybe I'll try the new book solution on that too?

    Are you upodated to 7.0.2? There were packaging issues on Mac with filenames that had "illegal" characters in them (characters not allowed on unix or Windows systems), though I haven't heard of file corruption being one of the side effects.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2010 8:07 AM   in reply to webheads1835

    Probably a third-party software conflict of some sort, then. Disable any non-Adobe plugins and see if that helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 15, 2010 8:18 AM   in reply to webheads1835

    Well, that would certainly be a problem. Please delete you rpersonal info when replying by email.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 9:12 AM   in reply to webheads1835

    Good news. The root cause of this issue has been determined. The key factor is a PSD placed such that it crosses the spline of a spread, and preflight is enabled. The Photoshop Library (PSLib) which reads the PSD data and translates it into information that the preflight can analyze, was getting stuck on the main thread. The background PDF export was then forever waiting for the PSLib to be free on the main thread.

     

    So the easiest workaround for this issue would be to disable preflight before exporting to PDF if you have PSD files spanning your spreads.

     

    More importantly, now that this is understood, we believe we will have this addressed in a future release. Stay tuned to your update notifications, or this thread.

     

    Many thanks to the community, and those who provided files, for helping us identify the cause of this problem.

     

    Sincerely,

    Matthew

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 9:19 AM   in reply to Matthew Laun

    Mathew

     

    That is good news.

     

    But I have files that won't export to PDF and there isn't a PSD in the layout?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 9:32 AM   in reply to Matthew Laun

    Hi Matthew

     

    Is this solution for a different problem than InDesign simply quitting when exporting to PDF in the background?

     

    I want to make sure I keep the various issues straight.

     

     

    Thanks

     

    Tom

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 10:32 AM   in reply to Eugene Tyson

    Eugene,

    Is your failure showing up as a hung background process? If not, then your issue has nothing to do with the issue I'm discussing, which was the start of this thread (it's gotten off on general PDF export problem tangents which don't belong here). If it is a background task hang, but there is no PSD crossing the spline, check to see if there is a transparency effect crossing the spline. I believe transparency effects also use the PSL.

     

    If not a background task hang, here's a good doc that can help to determine the scope and cause of your failure, and workaround the issue:

    http://go.adobe.com/kb/ts_cpsid_49998_en-us

     

    If you find something that you think is a product defect, please send me a private message so I can follow up.

     

    Matthew

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 11:47 AM   in reply to Matthew Laun

    That's good news, and I don't want to rain on your parade, but you should know that none of the files on which I experienced a hang had a cross-spine object that I can recall. I haven't seen a hang for quite some time, and haven't been able to repeat it on any file where it happened before.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 12:35 PM   in reply to Peter Spier

    Yes even I have not had any problems exporting yet I must say that I make it a point to open the Background Tasks panel before I start the process of exporting. Whenever I have done that the export went well and no hangups. I have had it hang up before on single page documents so I don't know if the spine/preflight solution has anything to do with the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 2:15 PM   in reply to Bob Levine

    Bob's idea of saving a PDF from a book file worked for me. Turning off Preflight didn't help, neither did upgrading to 7.0.2. Apparently, exporting in the foreground is the crucial ingredient.

     

    Each new version of Creative Suite adds new features, many of which I appreciate, but the price seems to be problems like this that can stop you cold from getting anything done. I'm not sure the tradeoff is worth it, certainly my boss doesn't think that it is.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 2:51 PM   in reply to Matthew Laun

    Thank you Mathew. Thankfully I haven't had too many problematic exports.

     

    I'll check for Transparencies and PSD stuff in future.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 28, 2010 5:01 PM   in reply to Matthew Laun

    Matthew --

     

    Your description exactly matches my experience with this issue. Ever since your first note mentioning the connection with preflight, I've had that feature disabled by default and have not had any problems exporting pdfs. Thank you for the update -- looking forward to the next dot release.

     

    Steve

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2010 1:22 PM   in reply to sboerner2

    If a document has a transparency across the spine, switching the Preflight off does not solve the problem for me. Have just lost an important deadline by 5 minutes :-(

     

    From now on I will return to my first suggestion, that of exporting only using the book panel. Otherwise too much time is wasted to export in background.

     

    I wish that Adobe never thought of background exporting. So much time has been wasted by us users.

     

    InDesign CS5 users print from the book panel and forget trying to solve the problem. It must be embedded deep in InDesign CS5. Only Adobe can solve this problem 100%! Hopefully with the next update.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2010 1:34 PM   in reply to Daniel Cilia

    Please post a sample document of the problem you are having, and I'll test it in an internal build that has the fix. If it isn't addressed with the fix, then we will investigate to see what the root case is for your case. You can post it for free on Acrobat.com, just log in with your Adobe ID, then share and copy the link and paste it in a reply here.

     

    Matthew

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2010 12:53 PM   in reply to Matthew Laun

    I'm having the same issue (PDF not exporting and hanging in Background tasks). I've removed the PSD files. There is no spine being crossed by anything. I can export the same file as part of a book. I've restarted 3-4 times in the process and had to force quit Indesign to get out. The same file worked fine an hour ago. I updated some .tif images and went to export.

     

    Is there a way to change the export pdf back to the foreground?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 22, 2010 1:18 PM   in reply to krdzine

    Uwe Laubender posted a script that exports inthe foreground here: http://indesignsecrets.com/forum/general-indesign-topics/pdf-export-pr oblems-with-cs5

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 18, 2011 12:52 PM   in reply to webheads1835

    I've a similar problem. Some but not all ID5 files that have been converted from ID4 will not "Package". The process freezes the application about 90% of the way through the process. I can rewrite it as an INDL file and reopen in ID4 and create the "'Package" with not a blink.

    Anyone else seen this?

    CS 5 on Mac OS 10.6.6

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 18, 2011 1:14 PM   in reply to inkwellbob

    Packaging problems have nothing to do with background export of PDF. Please start a new thread and provide full details of your problem, including OS and patch level of CS5.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2011 3:19 PM   in reply to webheads1835

    All,

    After not being able to reproduce a crash with some of the files I've been provided, I worked with Josh to get a crash log from his background PDF export failure. The crash log appeared to indicate an impact from the Extensis font auto-activation plug-in. If you are using any of the Extensis tools in conjunction with InDesign CS5, and are experience failures to export to PDF in the background, please disable the Extensis toolset, restart InDesign, then try to export again and see if the export is successfull. Please report results here, including the exact Extensis product[s] and version[s].

     

    Sincerley,

    Matthew

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2011 3:29 PM   in reply to Matthew Laun

    Can you tell us which version of the plugin and what font manager is involved?

     

    I have Suitcase Fusion 3 installed and haven't see this problem at all.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2011 3:35 PM   in reply to Bob Levine

    Suitcase 14.0.5 (162)

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 24, 2011 8:12 AM   in reply to Matthew Laun

    If you're having issues with export, and believe that it's the plug-ins causing it, that's not normal. I recommend contacting the Extensis technical support team with the versions that you mention, etc. so that we can appropriately diagnose the issue.

     

    http://www.extensis.com/support

     

    Jim Kidwell

    Extensis

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2011 5:40 PM   in reply to jkidwell

    I switched from Linotype FontExplorer Pro 2.5.2 to Extensis Suitcase Fusion 3 v 14.0.5 (162) for about a month without any problem. That is, until I updated OS X 10.6.6 to 10.6.7 last weekend.

     

    Among other performance issues, I could not export PDF or IDML from InDesign CS5 7.0.0.355. It crashes when the background progress bar still at 0.. I should, however, print and save as PostScript file and user Acrobat Distiller to create PDF.

     

    By doing following steps, I concluded thart sure enough, Suitcase Fusion 3 is the culprit.

     

    1. Copied the document fonts into ~/Library/Fonts.

    2. Moved ExtensisFontManagementIDCS5.InDesignPlugin out of /Applications/Adobe InDesign CS5/Plug-Ins folder

    3. Quitted Suitcase Fusion 3.

    4. Launched InDesign and opened the document.

    5. Exported as PDF successfully without any crash.

     

    Perhaps, it’s the combination of )S X 10.6.7 and Suitcase Fusion 3 that causes all the hassles.

     

    See this thread I created:

    http://forums.adobe.com/message/3578350#3578350

     
    |
    Mark as:
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points