Skip navigation
Currently Being Moderated

Please try recommended memory settings for After Effects CS5 and give feedback.

Oct 5, 2010 5:48 PM

We just posted a new set of recommendations for memory settings for optimum performance for After Effects CS5, and we'd like to know how they're working for you.

 

Please read this blog post and then respond to this thread with your results:

"Please try recommended memory settings for After Effects CS5 and give feedback."

Branched to a new discussion.
 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Oct 6, 2010 3:54 AM   in reply to Todd_Kopriva

    System Spec's :  2.66Ghz 8-core (16 threads) Mac Pro 4,1 with 24GB RAM (4x2GB + 4x4GB)

    Composition : 6400 x 720 pixels, lots of shape layers, feathering / blurring, Trapcode Particular, Fractal Noise.  NO source files or footage.

     

    Only other application running was Firefox (light usage)

     

    Results:

     

    RAM for other apps
    RAM per core
    Cores used
    Speed
    4283.13
    6273.20
    6343.00
    81145.16
    81.593.11
    826
    2.53
    8342.56
    8424.04
    10252.55

     

    This pretty much confirms teh recommendations Todd posted.  In this case a VERY small speed increase was gained by allocating 1GB less per core, probably due to the comp having no source footage.  When I get time I'll run the same tests on a footage-heavy comp.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 10:33 AM   in reply to Todd_Kopriva

    Hi,

     

    I ran some quick tests on an older project (one of the only I have without lens blur and therefore one of the only where mp is not disabled).

     

    It's 720x540, no video, all animated still images. Some fairly hi-res (2-3K), others only a few hundred px. Several adjustment layers over the whole comp for overall texture effects that really slow the whole thing down a lot.

     

    These are times it took to render one second of the project.

     

    1:44 (recommended settings)

    Screen shot 2010-10-06 at 12.08.48 PM.png

     

    1:18

    Screen shot 2010-10-06 at 12.12.41 PM.png

     

    1:05

    Screen shot 2010-10-06 at 12.15.46 PM.png

     

    So in this case the recommended settings actually delivered the worst performance by far.

    I was confused about one thing in the explaination, when you mentioned setting aside all that ram for other applications, to me it sounded a little like that 6GB of ram is actually available to the foreground process of AE but not the background processes. Is this the case or is it really totally unavailable to AE?

     

    BTW this is a 8-core Mac Pro 2.8 ghz, 16 gb ram, OS 10.6.4

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 11:15 AM   in reply to Todd_Kopriva

    I've been playing with multiprocessor settings on a number of computers, and I'm always noticing the same problem: when I try settings that seem reasonable, "Actual CPUs that will be used" drops to zero.

     

    For instance, right this very moment: I have 12gb of RAM, 3gb reserved for other applications and 2gb allocated for background CPUs. If I try upping the allocation to 3, "Actual CPUs that will be used" now says 0. Which I presume means multiprocessing is actually disabled. Unless I'm misunderstanding what that means?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 12:09 PM   in reply to Todd_Kopriva

    Does that mean that the recommendation for 12gb is to not use multiprocessing?

     

    I know "quick tests" in AE usually don't mean a thing, since each project renders differently, but I outputted a second from the project I'm working on -- some Liquify, lots of Particular, tons of precomps. With 3gb for other apps / 2gb per CPU (my go-to settings), I got a render time of 1:44. Rerendering the same frames with 4gb / 3gb, which disables multiprocessing, took 4:28.

     

    So, I'm going to go out on a limb and say the 4gb / 3gb recommendation seems... off.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 2:26 PM   in reply to Todd_Kopriva

    All layers are 1920 x 1080. 20 layers total, about half of those are PSD layers (all from the same PSD), the rest just solids. No footage.

     

    Seven instances of Frischluft (Out Of Focus), one instance of RSMB, one instance of Optical Flares, one Liquify. Two instances of Particular that are really heavy -- 500 particles / sec with 1500 particules / sec aux system.

     

    PSD layers were from an 8-bit file. Test render was a 16-bit TIFF sequence, 51 frames long.

     

    Rendering on 3 cores (2gb / core) takes about 1/3 the time it takes to render with multiprocessing off (setting 3gb / core). Which is kind of what you'd expect.

     

    Hopefully this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 2:35 PM   in reply to Todd_Kopriva

    ok, just ran some test here with a small project that includes:
    6 precomps of large images turned into 3d buildings, a couple of lights, couple of adjustment layers, camera with slow pans and moves, 1080p24 sized.

     

    rendered to default best settings and lossless.

     

    machine: early 2008 8-core 2.8GHz, 16GB matched ram, rendering to 3x750GB Raid 0.

     

    numbers mean this:(ie: 4-2-4.mov, 4GB for other apps, 2GB per BG proc, 4 cores used.

     

    MULTIPROCESSING OFF:
    2min, 12sec

     

    MULTIPROCESSING ON:
    3-1-8.mov: 1min, 16sec
    3-1.5-7.mov: 1min, 4sec
    3-2-5.mov: 1min, 4sec
    3-3-3.mov: 1min, 11sec

     

    4-1-8.mov: 1min, 15sec
    4-1.5-6.mov: 1min, 4sec
    4-2-4.mov: 1min, 6sec
    4-3-2.mov: 1min, 25sec

     

    6-1-6.mov: 1min, 8sec
    6-1.5-5.mov: 1min, 4sec
    6-2-3.mov: 1min, 11sec
    6-3-2.mov: 1min, 22sec

     

    NUCLEO PRO 3:
    1min, 37sec

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 6, 2010 7:36 PM   in reply to Todd_Kopriva

    On my 8 GB system, Win 7, I've been running 1.5GB reserved with 1.5 allocated per CPU. Uses 3 CPUs. If I reserve 2GB, I only get 2CPU which is waste on Quadcore.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2010 2:10 PM   in reply to Todd_Kopriva

    One note from our test set-up:

    Our engineers do custom installs they had to check on drivers. long and short, be sure the CUDA driver is installed (properly).

    That combined with the recommended settings ensures a real performance boost. Thanks for this Todd it was a mystery in CS4!

    We're still working on combinations and continuing with plug-in testing which is where we see huge differences. We'll post what we find.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2010 4:54 PM   in reply to Aaron Hildebrandt

    Someone asked if the "Ram reserved for other applications" included the AE foreground process. It doesn't. It's possible the recommended settings in this thread are overly conservative, but it's been established that the settings we shipped with were too aggressive. The OS, especially OSX, needs quite a bit of memory headroom. Being too aggressive with this setting can result in swapping to disk unnecessarily which takes a very long time.

     

    Aaron Hildebrandt:

     

    I agree that the 12GB settings are not ideal. Splitting the difference between the 8 and 16GB settings would be better. Off the top of my head, I'd say your "goto" settings(3GB reserved, 2GB per core) sound good.

     

    Dan Ramirez

    After Effects

    QA Engineer

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2010 4:53 PM   in reply to stephen v2

    sv2studios:

     

    I know our users want AE to use all of your cores, but try and think beyond "use all my cores" into "help me work as fast as possible". If you don't provide enough memory to your background processes, they'll be very inefficient and slower than if you used fewer cores. It's only "wasting a quadcore" when RAM AND CPU is available and unused.

     

    Thanks for all the feedback. This is helpful to us.

    Dan Ramirez

    AE QA

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 7, 2010 6:27 PM   in reply to Dan Ramirez

    Dan,

     

    I understand your point, but I get much better render times on most stuff with 3 cores vs 2 - that was my wasting comment. At least under Win 7, I don't see issues with those settings unless AE is bumping up against frame buffer. But those I render on my Quad with 16GB which works much better.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 8, 2010 5:53 PM   in reply to Todd_Kopriva

    Thanks for all the good feedback. The results reported are similar to those we are seeing in-house.

    After Effects is a deep product that gets exposed to many workflows, from web animation to IMAX film compositing. Because of this broad exposure, there is no one ideal setting for all
    rendering. The proposed memory preference settings are just a starting point with the goal of a better out of the box experience when the user first turns on Render Multiple Frames Simultaneously multiprocessing. These settings are what the user would experience with a fresh set of preferences.

    AE CS5’s current memory settings are the minimums necessary for Render Multiple Frames Simultaneously multiprocessing. We are thinking of raising the default preference settings to those listed on Todd’s blog (
    http://bit.ly/ckIriV ) so that more users get satisfactory results without having to first tweak the memory and Render Multiple Frames Simultaneously multiprocessing settings. They are not meant to be a solution for every type of project. If one is working in NTSC resolution, lower settings might be acceptable. If one is working with RED footage in complex compositions, higher settings will be necessary for best performance.

    RAM reserved for other applications:
    By reserving more memory for other applications there is also more memory reserved for the operating system buffers. This is beneficial because it stops the OS from swapping to disk during memory intensive tasks. If you find that over time as you work with a project that interactions are slowing down and taking much longer than normal, it could be that the OS is swapping to disk. Look to see if the hard drive light is flashing almost constantly. On the Mac, open the Activity Monitor  window (in the Utilities folder) and click on the System Memory tab. If the free memory is very low and the Swap used is high (over 500MB) and rising with each frame rendered, the OS is swapping. To alleviate this condition, raise the reserve memory setting in After Effects, save the project and restart the app. On the Mac, it may also help to restart the OS.

    RAM allocation per background CPU:
    We are also proposing raising the default background CPU setting from .75GB/ background CPU to 1.5GB / background CPU. The testing for these settings was done with a baseline of 1.5GB/ background CPU for
    Render Multiple Frames Simultaneously multiprocessing. This combination of reserving more memory on systems with generous amounts of RAM + higher background CPU memory allocations achieved successful, fast renders over a variety of real world HDV and HD projects.

    Managing memory for
    Render Multiple Frames Simultaneously multiprocessing is complex. Think of each background instance as a mini After Effects. There are definitely projects that are going to require more memory per background CPU than others. For example, if the project will not render well with Render Multiple Frames Simultaneously multiprocessing off on a 2GB machine, it’s not going to render well with 2GB allocated to the background processes either. If you find this is the case, raise the background CPU allocation to a level that achieves the best result. In general we have found that web and NTSC work usually can be done with 1GB/ background CPU. HDV and HD work will usually need from 1.5 to 2GB/background CPU. Higher resolution work may need 3 or even 4GB/background CPU.


    Please keep trying these proposed default settings with your projects and let us know how they work for you. Most importantly we need to know if they help reduce application slowdowns due to memory swapping, over the course of a day's work. That is the primary goal for the new defaults.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 13, 2010 4:38 AM   in reply to Dan Ramirez

    Since AE is capable of sending crash reports to you guys, why not build in the ability to send the essential render information? Size of comp, no. of layers, no. + data size of source files, render settings, system specs and render time.  Make it optional and completely secure, confidential, anonymous etc etc

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 13, 2010 10:49 AM   in reply to Aaron Hildebrandt

    This is very helpful Aaron. It could be that you get fine results with just 1.5GB/ bkgnd process. If you have time, please up the reserved memory to 4GB with the BG cpu set to 1.5GB and try that for a while. Let us know how that works both for performance and for a working, all day setting that doesn't get starve the OS when you have been working for hours with the app.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 31, 2010 5:42 AM   in reply to Todd_Kopriva

    an Forgetaboutit.

     

    Message was deleted by: craulmedia

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2010 8:25 PM   in reply to Todd_Kopriva
    (Sorry, I accidentally posted this as a reply the the blog post... reposted here for convienence)

    Thanks for this update/page. I’ve been trying to wrap my head around this issue over the past few days as I’ve struggled exporting 6 SECONDS of 720 24p footage.

    My first test was as follows:

    8-core with 24GB of Ram
    RAM reserved for other applications: 3
    CPU’s reserved for other applications: 2
    RAM allocation: 1 GB
    AE says that the actual number of CPU’s used: 15

    Render time for a (6 second, 720 24p Quicktime animation codec, RGB+, millions of colors +): 3 hours 6 min – granted there are a lot particles involved, but thats still an incredible amount of render time per frame.

    So I dug around, changed a few settings in the composition (decreased the amount of particles from 4000 to 2000 and moved the camera a tad bit to the side) and I came up with this:

    RAM Reserved for other applications: 3GB
    CPU’s reserved for other applications: 1
    RAM allocation per background CPU: 3GB
    Actual CPU’s that will be used: 5

    Render time: 16 min and 59 seconds!

    Granted, it still is only 6 min of footage, but 17 min. is a hell of a lot better than before. I’ll do some more tweaking and see if I can better the Render time, but I guess I’ve discovered the power of leaving enough RAM for each CPU to use up.

    Anywho, thanks for all the help you’ve put into this so far, I look forward to seeing what the AE team comes up with for performance boots in the next iteration.

    -Dylan

     

    I should also mention that I’m running 64-bit Win 7, and that I did not have “Use Open GL Render” checked (although would I/Should I see a performance boost with this box checked in the render settings?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 5:32 PM   in reply to Todd_Kopriva

    Anyone else have this problem?

     

    Regardless of how much I tell AE to "Leave for other applications," it never fails to use up every drop of RAM until I'm left with a stuttering desktop and 17MB +/- of RAM left. This happened before in CS4 but I used Nucleo to get around it (although that sometimes still gave me problems). Recently switched to a brand new MacPro 12 core with 26GB of RAM. I launch AE and open my file (still 19GB RAM free at this point) and hit render. Mid-way through it drops way down to __MB. Other times, I'll work for a while, hit render and walk away. Come back when the render should be finished and it is taking twice as long. At that point, I need to quit out and restart AE and do a new render, then it is back to normal. Not sure what's up as I never had any of these issues back in CS2 or before but once I went up to CS4/CS5 it has never worked right.

     

    Similar problem is during RAM previews of larger files. Hit RAM preview and it takes forever "loading projects" in the background. I read that it supposed to only happen the first time you RAM preview but it happens to me every time until I render something. If I turn off Multiprocessing, that immediately goes away. When I view the Activity Monitor, the individual render engines "aeselflink" are all open during the "loading projects" vortex so I have no idea why it continues to do it.

     

    The most recent settings when I had the problem listed above with 19GB RAM free before launching AE.

    RAM reserved for other apps: 11GB

    CPUs reserved for other apps: 4

    RAM per CPU: 2GB

    Actual CPUs used: 7

     

    Of course sometimes this happens while I'm working in other apps, but sometimes the only things that are open are Mail and Safari. I mean, I'm working with 26GB of RAM here! Shouldn't AE recognize how much RAM is available at launch and leave the amount listed in the prefs?

     

    Am I the only one experiencing this?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 5:47 PM   in reply to kenfai

    Sounds wrong for sure. Are there any 3d part effects involved? Please submit a screenshot and a sample project (without footage) that has this issue to : aebugs@adobe.com. We'll take a look and see what is happening.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2011 6:29 PM   in reply to Will Lockwood

    Some have AE 3D some do not. The problem here is that it doesn't just happen on one particular project, its been happening for years and on 2 different machines in both CS4 and CS5.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2011 8:54 AM   in reply to kenfai

    It could be that this is happening in multiple situations, but we need specifics. For example, CS4 multiprocessing is quite different than CS5. There are many vast improvements in CS5 not the least being that it is a 64bit application able to address a much larger memory space.

     

    Having concrete specific examples is the best way to address this issue and to see if developing solutions are effective. Please submit a project or projects illustrating this issue.  Also include a screenshot of the Memory and Multiprocessing preferences panel on the system.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 5, 2011 12:47 PM   in reply to Todd_Kopriva

    I doubled my RAM this morning from 12 to 24, so I decided to do another round of testing.

     

    The comp was very heavy: DNX sequences being read from the network, lots of keying, Particular, Optical Flares, and Twixtor. The recommendations for 24 seem to be bang-on:

     

    Quarter-res, Quicktime DNxHD

    12gb RAM, fastest render: 9:30

    24gb RAM, 3gb background, 2gb / instance, 7 cores used: 5:02

    24gb RAM, 8gb background, 3gb / instance, 5 cores used: 2:15

     

    Full-res, Quicktime Lossless

    24gb RAM, 3gb background, 2gb / instance, 7 cores used: 17:10

    24gb RAM, 8gb background, 3gb / instance, 5 cores used: 12:34

    I'm impressed. I really didn't expect the settings change to make such a difference, especially since I didn't have much luck with the recommended settings for 12gb.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2011 6:50 AM   in reply to Aaron Hildebrandt

    Just out of curiousity, how much of a difference would it make if you left the bg RAM at 3GB, but upped the RAM/Instance to 3GB? I'm just wondering if it is the RAM reserved for applications or RAM/Instance that is making the most difference...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2011 9:43 AM   in reply to thedillpickle

    12gb RAM, fastest render: 9:30

    24gb RAM, 3gb background, 2gb / instance, 7 cores used: 5:02

    24gb RAM, 8gb background, 3gb / instance, 5 cores used: 2:15

    24gb RAM, 3gb background, 3gb / instance, 5 cores used: 6:01

     

    Ouch. I set it back to 8gb and quickly did another render, just to see if there was something else slowing it down (like reading from the network), and I got a new render time of 1:48.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2011 4:25 PM   in reply to Todd_Kopriva

    Is there anyway to allocate more than 3GB of RAM per CPU? I've noticed that after effects RIPS through the first part of my compositions, but eventually it gets hung up and slows way way down. Granted, this is probably a function of my composition as much as it is a part of my settings, but I was just curious.

     

    FYI - This is when following the recommended settings for 24 GB of RAM (8GB reserved, 3GB resereved)... I just wonder if restricting the processors to 3GB doesn't allow them to reach their full potential for more complex compositions.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2011 6:56 PM   in reply to thedillpickle

    it does not help you anything.

     

    Ae was AND is bulit on old code, forever an ever.

    More RAM, faster Machines ... it won't help you anything. Performance will starve forever and ever.

     

    Only thing i can say is to have patience. I know there is a lot of expectation upon the new product manager and i hope that he will take alle the pressure away and concentrate on a new level of competence and power because i believe he does have a great team around him which is waiting for a good leader, otherwise they won't follow

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2011 8:05 PM   in reply to craulmedia

    Let's hope you are right. I've had nothing but problems with memory since CS4 and have yet to have anyone give me a proper solution. They even requested working files from me to test which I happily sent months ago and I have yet to hear a peep from them. Thanks for nothing Adobe.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 10, 2011 3:30 AM   in reply to Todd_Kopriva

    A recent tutorial on memory settings posted on AE's Facebook page had me poking around the Details tab in the memory & multiprocessing preferences. In the video, the presenter had 12 GB of RAM and set his RAM reserved for other applications to 3 and the RAM available for AE was 9. When he checked this out in the details tab, it showed the "Max Allowed Memory" for AE to be 9. I have 26GB of ram and regardless of whether I set the RAM reserved for other applications to 1GB or 25GB, the details tab tells me the "Max Allowed Memory" for AE is 18.4GB. This is definitely the reason why if I have more than one application open (god forbid I try that on a 12 core machine with 26GB) AE devours all RAM and leaves me with sometimes less than 10MB of RAM during renders and I can barely even check email.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 17, 2011 4:46 AM   in reply to Todd_Kopriva

    Thank you for the update. Here's the thing, I've had this problem on my current machine (MacPro, 12 core, 26GB RAM, Snow Leopard) as well as my previous machine (MacPro, 8 core, 16GB RAM, Leopard) so I'm not quite sure this is an OSX problem. Regardless, when I go to my AE settings right now and set RAM reserved for other applications to 25GB, I see that RAM Available for AE is now set to 1GB which is correct. When I click the Details tab I see that Max Allowed Memory for AE is 18.4GB, not 1. This number never drops below 18.4 regardless of my settings and CPU allowance and I'm wondering if this is the problem. I do see that there is inactive RAM, etc but taking that in to consideration, if I see that there is only 17GB of free RAM to use, shouldn't I be able to tell AE to only use 9GB and still have 8GB free? That is never the case, AE always eats up every bit of RAM.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 17, 2011 10:05 AM   in reply to kenfai

    Can you try deleting these two preferences files on this Mac?

     

    Restart the machine first. Then with no apps open, delete the After Effects 10.0 preference file ( Adobe After Effects 10.0-x64 Prefs.txt ) located in the /Users/username/Library/Preferences/Adobe/After\ Effects/10.0 folder.

     

    Delete the memorybalancercs5.xml file located in the /Users/username/Library/Preferences/Adobe/dynamiclinkmanager folder.

     

    Start the app and set the preferences.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 17, 2011 11:21 AM   in reply to Will Lockwood

    That seems to have done the trick, THANK YOU!!! Now, if we could just get Apple to fix the Inactive RAM bug, I'd be all set. With a fresh restart and nothing open during a "clean" AE render, the Inactive RAM usage is at 10GB!

     
    |
    Mark as:
  • Currently Being Moderated
    May 25, 2011 8:22 AM   in reply to kenfai

    Thank you kensai, I have been having the same problems.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 11, 2011 4:43 AM   in reply to Todd_Kopriva

    I have a mid 2010 iMac, it was shipped with 8gb and I was eager to increase its render performance by adding the 16gb limit of ram. However, after installing all this ram, my results are disappointingly similar to before ! I have forced Snow Leopard to boot in 64 bit and I’ve played with all the recommended settings found here. I also ran my own tests, even tried switching of multiprocessing, but still saw no improvement whatsoever.
    Stranger still, when I open up the activity monitor to look at the memory usage during a render, it never shows any significant exploitation of the ram, with almost 12 gb that stay desperately idle (whereas I've alway known mulitprocessing to be a real memory hog).
    Am I missing something ?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 18, 2011 12:14 AM   in reply to Todd_Kopriva

    Hi Todd!

    I have an MAC PRO 2010, 12 cores 2.93GHz, 32Gb RAM, OWC EXTREME 6G SSD

     

    I'm going to work with lot of videos in 1920 X 1080 29.97 FPS and WARP STABILIZER effect

     

    What is your recomendation in order to get the best time?

     

    Thanks for your time!

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)