Skip navigation

Photoshop CS5 Clipboard Issue (Win 7)

Jan 3, 2012 12:13 PM

  Latest reply: nothgirl, Aug 27, 2013 9:27 AM
Replies 1 ... 3 4 5 6 7 8 Previous Next
  • Currently Being Moderated
    Apr 26, 2011 6:44 AM   in reply to gbriney

    I wish I could say mine is working. Despite having reported here that my problem had disappeared, it appears I was a bit hasty. There are times when it works fine. However, there are many times when it does not work at all. I have not managed to find any specific pattern to the clipboard behavior, but I do know that I have no third party Plug-ins running - this is a plain vanilla Photoshop CS5 install here. To complicate my life even more, I just upgraded Acrobat to version X and I find that Acrobat now seems to have a similar problem - at least when I copy to the Acrobat clipboard, its contents are not available to any other programs.

     

    The Plug-in manufacturers have been taking a beating over this, but my theory is that there are a number of ways to stimulate this problem, Plug-ins being one. Otherwise, how could we have such wide-ranging reports here?

     

    Steve Cavanaugh :: Technical Writer:: Coinstar, Inc.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 26, 2011 7:19 AM   in reply to JanGeloen

    I've just been reading on a bit, since my latest post. I've spotted only one new post, where the name - rename didn't work. Correct? Also I see most of the people have fresh installs of CS5 (vanilla ---- @Mr. Benttop --- lol, cool expression), without other 3rd party plugins.

     

    So I'm going to give it a go again. Wouldn't it be possible that one (or more) of the factory plugins are messing things up for the Windows 7, 64 bit users. Reading all posts, I strongly believe this is the case. If we track down, which one, we're one step closer, right?

     

    Anyone out here who knows the default Plug-ins directory this well, that he or she could make an educated guess on which plug could get unstable, bearing "Windows 7" "64 bit" and "clipboard" in mind. The "victims" could try renaming that specific plugin and report their findings here.

     

    This should work narrowing things down for the people @ MS and Adobe. What do you reckon?

     

    Cheers to all,

    Yves

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 26, 2011 8:03 AM   in reply to Yves Horsmans

    There are quite a lot of possibilities in the Plug-Ins folder even on a vanilla setup:

     

    3D Engines

      Photoshop3DEngine.8BI

       

    ADM

      ADMPlugin.apl

       

    Automate

      CropPhotosAuto.8LI

      HDRMergeUI.8BF

      WIASupport.8LI

       

    Digimarc

        Win64

          DigiRead.8bf

          DigiSign.8bf

           

      Digiread

          cs.lproj

            Localizable.strings

             

          da.lproj

            Localizable.strings

             

          de.lproj

            Localizable.strings

             

          en_US.lproj

            Localizable.strings

             

          es.lproj

            Localizable.strings

             

          fi.lproj

            Localizable.strings

             

          fr.lproj

            Localizable.strings

             

          hu.lproj

            Localizable.strings

             

          it.lproj

            Localizable.strings

             

          ja.lproj

            Localizable.strings

             

          ko.lproj

            Localizable.strings

             

          nb.lproj

            Localizable.strings

             

          nl.lproj

            Localizable.strings

             

          pl.lproj

            Localizable.strings

             

          pt_BR.lproj

            Localizable.strings

             

          ro.lproj

            Localizable.strings

             

          ru.lproj

            Localizable.strings

             

          sv.lproj

            Localizable.strings

             

          tr.lproj

            Localizable.strings

             

          uk.lproj

            Localizable.strings

             

          zh_CN.lproj

            Localizable.strings

             

          zh_TW.lproj

            Localizable.strings

             

            Digisign

          cs.lproj

            Localizable.strings

             

          da.lproj

            Localizable.strings

             

          de.lproj

            Localizable.strings

             

          en_US.lproj

            Localizable.strings

             

          es.lproj

            Localizable.strings

             

          fi.lproj

            Localizable.strings

             

          fr.lproj

            Localizable.strings

             

          hu.lproj

            Localizable.strings

             

          it.lproj

            Localizable.strings

             

          ja.lproj

            Localizable.strings

             

          ko.lproj

            Localizable.strings

             

          nb.lproj

            Localizable.strings

             

          nl.lproj

            Localizable.strings

             

          pl.lproj

            Localizable.strings

             

          pt_BR.lproj

            Localizable.strings

             

          ro.lproj

            Localizable.strings

             

          ru.lproj

            Localizable.strings

             

          sv.lproj

            Localizable.strings

             

          tr.lproj

            Localizable.strings

             

          uk.lproj

            Localizable.strings

             

          zh_CN.lproj

            Localizable.strings

             

                zh_TW.lproj

                  Localizable.strings

                   

    Effects

      Filter Gallery.8BF

       

    Extensions

      FastCore.8BX

      MMXCore.8BX

      MultiProcessor Support.8BX

      ScriptingSupport.8li

      ScriptUIFlexPhotoshop.swf

      ScriptUIFlexServer-app.xml

      ScriptUIFlexServer.swf

       

    File Formats

      Cineon.8BI

      Dicom.8BI

      JPEG2000.8BI

      PBM.8BI

      PCX.8BI

      Pixar.8BI

      Radiance.8BI

      U3D.8BI

      WBMP.8BI

       

    Filters

      Average.8BF

      ChannelPort.8BF

      Clouds.8BF

      Lens Blur.8BF

      Lens Correction.8BF

      LightingEffects.8BF

      Liquify.8BF

      NTSC Colors.8BF

      Solarize.8BF

      Standard MultiPlugin.8BF

      VanishingPoint.8BF

      Variations.8BF

       

        Lighting Styles

          2 O'clock Spotlight

          Blue Omni

          Circle of Light

          Crossing

          Crossing Down

          Default

          Five Lights Down

          Five Lights Up

          Flashlight

          Flood Light

          Parallel Directional

          RGB Lights

          Soft Direct Lights

          Soft Omni

          Soft Spotlight

          Three Down

          Triple Spotlight

           

    Image Stacks

      statistics.8BA

       

    Import-Export

      Save for Web.8BE

       

    Measurements

      MeasurementCore.8ME

       

    Panels

     

    It might take a bit of time trying each of those for long enough to really "know" that you've found it.

     

    Steve Cavanaugh :: Technical Writer:: Coinstar, Inc.

     
    |
    Mark as:
  • Noel Carboni
    23,510 posts
    Dec 23, 2006
    Currently Being Moderated
    Apr 26, 2011 8:42 AM   in reply to Mr.benttop

    If it's helpful at all, here are lists of the actual files installed by Adobe in the Photoshop area in a new Photoshop CS5 installation, and what they look like after having been updated to 12.0.3...

     

    http://Noel.ProDigitalSoftware.com/temp/OriginalPSCS5Files.zip

     

    http://Noel.ProDigitalSoftware.com/temp/UpdatedPSCS51203Files.zip

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 27, 2011 1:09 PM   in reply to Nik Software, Inc.

    About a month ago, I bought a Wacom tablet. Up until that point, everything had been going perfectly fine in my 8GB/3Hz dual core laptop Windows Professional 64bit and Photoshop CS5 64bit world (well, except for Machine Wash filters, but that's another story).

     

    So, I thought I was going out of my mind when, the week after installing the tablet, every time I tried to copy and paste something from Illustrator to Photoshop (which I've done tens thousands of times over my professional life), it wouldn't work. The first one would, but after copying and pasting in Photoshop, I could only paste what I had copied in Photoshop, nothing else from an external program would paste in... unless I quit Photoshop and restarted.

     

    http://dl.dropbox.com/u/794472/SelToolInst.cfg completely fixed the problem. I've put copies of it in my software updates folder, with the instructions on where to put it for the next time I have to install Photoshop/Wacom on to an otherwise clean system.

     

    Thank you for posting this, I'd probably still be ripping my hair out in frustration without it!

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2011 5:04 PM   in reply to C Towsley

    I have all the Nik plugins installed on a WIN7 64bits with Photoshop CS5 64bits.

     

    When I rename the "Silver Efex Pro 2" and "Selective tools" folders, the copy-paste function is back.

    I need to rename both of them (else it won't solve my problem).

     

    Very annoying. Is there an other way around to solve this issue ?

     

    Fred

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2011 5:31 PM   in reply to gueho_fred

    Hi Fred,

     

    Did you try the .cfg file from post #88 yet? (http://forums.adobe.com/message/3353707#3353707)

     

    It has seem to do the trick specific to NIK's selective tool. We still don't have solutions for other 3rd party plug-ins, or cases where no 3rd party plug-ins are loaded.

     

    regards,

    steve

     
    |
    Mark as:
  • Currently Being Moderated
    May 5, 2011 12:42 AM   in reply to SG...

    Did you guys try this registry edit? It worked for me.

     

    1. In Windows, go to Start and then Run.
    2. Type in “Regedit” without the quotes
    3. Once in the registry editor, go to HKEY_CURRENT_USER > Software > Adobe > Photoshop > 12.0
    4. Right-click in the 12.0 folder and select New > QWORD (64-bit Value) and name it “AlwaysImportClipboard” without the quotes
    5. Double click the name and change the Value Data field from 0 to 1
    6. Restart Photoshop and paste away!

     

     

    Disclaimer: Modifying the  registry can cause serious problems that may require you to reinstall  your operating system. We cannot guarantee that problems resulting from  modifications to the registry can be solved. Use the information  provided at your own risk.

     

    BTW, I got this from http://www.atlanticbt.com/blog/adobe-photoshop-clipboard-copypaste-bug -fix/ and modified just slightly.

     
    |
    Mark as:
  • Noel Carboni
    23,510 posts
    Dec 23, 2006
    Currently Being Moderated
    May 22, 2011 8:56 AM   in reply to FrankNuberry

    That patch is bogus.

     

    It's already been shown that even the 64 bit Photoshop doesn't read a QWORD from the registry for that value.

     

    Do you know anything about programmatically accessing the registry?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2011 7:13 AM   in reply to JanGeloen

    I have been pulling my hair out on this one for a long, long time.  Very aggravating.  Slows productivity down tremendously.

     

    I moved Viveza 2 (by Nik Software) out of my plugins folder.

     

    Now, finally, clipboard pasting seems to work OK in Photoshop CS5 64-bit.

     

    At least so far.

     

    I guess I need to move Viveza back into my plugins folder when I need to use it.

     

    Pain in the butt!!!

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2011 9:55 PM   in reply to mediaman54

    The NIK configuation file for the Selective Tool (post 88) worked for me with NIKs Color Efex Pro 3 for several weeks as I mentioned in posts 118 and 157. Then I installed NIK Silver Efex Pro 2, which caused the clipboard paste problem all over again. I contacted NIK, who assured me that SEP2 did work under Win7/64, and sent me another cfg file to copy to the Selective Tool folder. SEP2 worked OK for a few days, then the ciipboard paste problem came back. I uninstalled SEP2, and the clipboard worked OK with NIK CEP3 still installed.

     

    Now the clipboard problem is back again with no changes to the system except for a rash of Win7 updates in the meantime. I'm waiting for a response from NIK who still assure me that SEP2 does work with Win7/64. Maybe I'll only connect one machine to the internet and stop getting Win updates on the other if things ever work right again...

     

    It seems to me nothing gets fixed until there's a threat to the bottom line... Clearly this problem has no effect whatsoever on Win7/64 sales, and probably virtually none on CS5. Well, maybe it's momentarily positive for Adobe -- I use PSE9 which is 32bit to run the NIK software when I need it. Maybe some other folks are doing this too. Of course there's the PIA message that I have PSE installed on more than two computers. I only use two computers for goodness sake -- unfortunately I have had a couple of HD problems lately, and so now I need to call PSE9 support yet again.

     

    Anyway NIK is the place to complain, because they realize the pinch on sales may be actually be felt when word of mouth gets out about this problem -- and once out, it takes a long time to recover when customers figure out how to do things differently...

     

    Message was edited by: gbriney - grammatical errors corrected

     
    |
    Mark as:
  • Noel Carboni
    23,510 posts
    Dec 23, 2006
    Currently Being Moderated
    May 22, 2011 6:32 AM   in reply to gbriney

    Windows Updates are virtually always a good thing.  It's not a reasonable strategy to block Windows Updates.  You have thousands of people at Microsoft working to improve the software you have already purchased, and believe me they put a LOT of effort into making sure it doesn't break things unexpectedly.

     

    I suspect you have a latent problem on your system having to do with clipboard access, that came up coincidentally.  Most folks don't see it.  I have not had a single problem with the clipboard myself, having never installed any Nik software, but I keep 100% up to date with Windows updates.

     

    Have you ferreted out all the files Nik installed into Photoshop?  You may need to compare file lists and modification dates to do this.

     

    If it can help, here's a list of the files normally installed by Adobe:

     

    http://Noel.ProDigitalSoftware.com/temp/Photoshop_CS5_Standard_Install ation_Files.zip

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2011 12:36 PM   in reply to Noel Carboni

    I thought it was apparent that I was being facetious about the Win updates, hence the wink smiley -- but hey I wouldn't want to mislead anyone to do something that's not in their best interest.

     

    Since you haven't had any problems, and would like to help, how about installing the free NIK Silver demo on your system, and let us know what happens?

     
    |
    Mark as:
  • Noel Carboni
    23,510 posts
    Dec 23, 2006
    Currently Being Moderated
    May 22, 2011 1:32 PM   in reply to gbriney

    Sorry I misinterpreted that, but the wink smiley wasn't quite enough to know you weren't serious.  A lot of people think it IS a good idea to cut their systems off from Internet access and updates.

     

    I assume you're talking about Nik Software's "Silver Efex Pro 2", right?

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,510 posts
    Dec 23, 2006
    Currently Being Moderated
    May 22, 2011 2:19 PM   in reply to Noel Carboni

    Okay, I've downloaded the trial version of the Nik Silver Efex Pro 2 plug-in on a very clean virtual machine running Windows 7 x64, which I use for testing.

     

    Test 1:  Try running Photoshop CS5.1 prior to installing the Nik plug-in.

     

    • I copied several images both large and small from another application (IrfanView)
    • I was able to successfully paste them into a document in Photoshop.

     

     

    Test 2:  Installed Nik Silver Efex Pro 2

     

    • Noted an extension panel when Photoshop was first started.
    • Copied several images, both large and small from IrfanView.
    • Was able to paste them into documents in Photoshop.
    • Ran the Nik Silver Efex Pro 2 plug-in, got the trial dialog.
    • When the Silver Efex Pro 2 dialog came up, the display was corrupted.  Wasn't able to do anything but close the dialog.
    • Was able to copy and paste more images into Photoshop.
    • Ran the Silver Efex Pro 2 plug-in again, saw a corrupted dialog again.
    • Tried hitting Return in the hopes it would take it as OK.  It did and I got a new grayscale layer.
    • Was able to copy and paste successfully into Photoshop thereafter.

     

    I don't appear to be seeing an issue with the clipboard here with this system, though Silver Efex Pro 2 itself isn't working properly.

     

    I'm guessing the Silver Efex Pro 2 plug-in just isn't compatible with the OpenGL driver VMware provides, but I'm not about to install this turkey of a plug-in on my main workstation.  It looks as though it gets pretty intimate with Photoshop, by the appearance of the extension panel, and also by the fact that it created a new layer - something a filter plug-in is not legally able to do.

     

    I made a note of the files before and after the install.  These are the ones the Nik installer added:

     

    c:\Program Files (x86)\Adobe\Adobe Photoshop CS5.1\Plug-ins\Nik Software\Selective Tool\Dfine2.config
    c:\Program Files (x86)\Adobe\Adobe Photoshop CS5.1\Plug-ins\Nik Software\Selective Tool\SelectivePalette.8li
    c:\Program Files (x86)\Adobe\Adobe Photoshop CS5.1\Plug-ins\Nik Software\Silver Efex Pro 2\Silver Efex Pro 2.8bf.lnk
    c:\Program Files (x86)\Adobe\Adobe Photoshop CS5.1\Plug-ins\Nik Software\Silver Efex Pro 2\SilverEfexPro2.config

    c:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Plug-ins\Nik Software\Selective Tool\Dfine2.config
    c:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Plug-ins\Nik Software\Selective Tool\SelectivePalette.8li
    c:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Plug-ins\Nik Software\Silver Efex Pro 2\Silver Efex Pro 2.8bf.lnk
    c:\Program Files\Adobe\Adobe Photoshop CS5.1 (64 Bit)\Plug-ins\Nik Software\Silver Efex Pro 2\SilverEfexPro2.config

     

    Anything else in particular you'd like me to test?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2011 6:39 PM   in reply to Noel Carboni

    yep that's the one!

     
    |
    Mark as:
  • Currently Being Moderated
    May 22, 2011 6:59 PM   in reply to Noel Carboni

    Noel,

     

    Thanks for doing the quick test and sharing the results -- you're a prince. For what it's worth, the 32-bit NIK applications seem to have many dedicated fans who appreciate having a new layer created labeled with the filter used -- I don't have a dog in that fight being new to SEP2.

     

    I think it would be great if you could leave NIK SEP2 installed for a while, because the problem doesn't always show up immediately. I strongly suspect that the clipboard issue is much more likely to happen when CS5 (and the OS) are stressed by CS5 with many large files open, after being open for many hours, and with many other windows open competing for memory.

     

    I realize the OS contribution may make it arguable about where responsibility lies, but my feeling is that applications getting low on resources should give an explicit warning rather than just becoming erratic and eventually crashing. Graceful decline to allow saving work is always better IMO.

     

    Best regards,

    Gary

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 1:36 AM   in reply to JanGeloen

    Update.

    I just got an entirely new machine. Again Windows 7, 64 Photoshop and 12 GB of RAM. The only difference. This is photoshop 5.5 and a clean install (No new plugins added). And yes. The clipboard issue is back. Renaming the Plug-ins folder and renaming it back will help, but this time it will not last.After a few restarts you need to the trick again. I've read a bit on since last time, but the plugins mentioned and solutions were 3rd party plugins, right? I suspect there's at least one factory plugin causing the same problem, that gets resolved by fixing the 3rd party plugin. I'm quite convinced it's a factory plugin, since renaming the plugin folder will make the clipboard work. If so. I'm planning to rename my subfolders sequentally and log on what Plugin subdirectory the issue gets fixed and narrow down from there to pinpoint the "bad" one. Has someone got a clue which factory plugin might be causing it? If so I'll start there.

    Cheers,

    Yves

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 10:28 AM   in reply to Yves Horsmans

    And yet the problem doesn't happen for everyone - so the default plugins aren't a likely cause.

    There might be some other factor involved (system locale, drive or folder names, who knows).

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 11:12 AM   in reply to Chris Cox

    To me, this is now more probably a RAM problem. When you can't paste in Photoshop, try to paste it in an other application. If you can, this is Photoshop. If you can't or the image is altered (for example, in two colors), this is your system. When you can't, try a smaller selection.

     

    Personally, I've encounter years ago problems with Photoshop not pasting while other application still did.

    Actually, when I snapshot my entire double screen, I'm can't always paste, whatever the application, but I can still copy-paste small windows.

     

    People should test further and try to paste there "clipboarded" image somewhere else.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 2:06 PM   in reply to Lacrymocephale

    You're coming into this a little late -- several months in fact, look at the preceding 4 pages or so of comments. The obvious stuff was done long ago.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 2:20 PM   in reply to Chris Cox

    It's quite clear that 3rd party plugins can break the normal clipboard function, and removing it (them) will restore normal function if it was normal before. However, fixing the 3rd party plugin doesn't guarantee normal function will last. So I'm sure it's correct to say there are multiple ways for the external clipboard paste function to fail. There are so many variations on the problem that it's necessary to characterize experience with lots of qualification, because it may change tomorrow.

     

    Internally, that is within CS5, the clipboard continues to function as always (in my experience to date) -- the connection to external applications which put images on the clipboard is lost. I believe that text may still be copied to CS5, but I'm not sure if that's always true, and even if it is, it's of little value to the user.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 2:26 PM   in reply to gbriney

    I already posted in this forum: http://forums.adobe.com/message/3204129#3204129

     

    You're just a troll.

    ...And I won't feed you more.

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 2:27 PM   in reply to Lacrymocephale

    sorry I don't go in for name calling...

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2011 5:20 PM   in reply to JanGeloen

    I narrowed down the problem on my machine to the Viveza 2 plugin from Nik.

     

    Nik sent me a "SelToolInst.cfg" file, (one for Win, one for Mac)

     

    Instructions were to replace the .cfg file in a certain folder.

    C:\Program Files\Adobe\Photoshop CS5\Plug-Ins\Nik Software\Selective Tool

     

    My folder of that name did not have this file, but I put the new one in there anyway.

     

    Seems to have solved the problem for me, so far.

     

    But judging by some of the comments in this thread, it could recur any time.

     

    Sigh.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2011 7:33 AM   in reply to mediaman54

    Hello

     

    I run PS CS5 in Windows 7 x64 and (in a laptop) in Win 7 x32.

     

    My problem isn't pasting into Photoshop CS5, but copying and pasting from CS5 into other programs. I can paste into CS5, but can't copy/paste from it, except by using a third-party screenshot app. (True in CS5 x64 and x32, in both machines.)

     

    I have worked through each of the relevant fixes suggested in this thread and its companion thread, 'Clipboard still not working? Darn you'.  I've disabled plug-ins (though I don't have any Nik plug-ins, and only 1 third-party plug-in: Mask Pro 4). I run CS5 as an Administrator. I've added AlwaysImportClipboard to the Registry as a Qword and a Dword. I've unloaded /disabled all possible startup apps.

     

    I've used Photoshop since v.7, and never had this problem before, though I understand from the posts that others have had it in earlier PS versions.

     

    I can copy and paste to/from the same files, if I open them in any other graphics app, from MS Paint to Acrobat to Omnipage.  If it's a Windows problem, not a Photoshop problem, I find it strange that it only happens in Photoshop--and for me, at least, only in CS5. I formerly used CS4 on my current computers, with all other apps/startups the same as they are now, and I could copy and paste freely.

     

    In the posts to date I haven't seen any info about Microsoft's response (if any) about the problem. Is there one?

     

    Mary

     
    |
    Mark as:
  • Noel Carboni
    23,510 posts
    Dec 23, 2006
    Currently Being Moderated
    Jul 11, 2011 9:43 AM   in reply to Mary Bernard

    In Photoshop, go into Edit - Preferences - General.


    Do you have [ ] Export Clipboard checked?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 11, 2011 9:58 AM   in reply to Noel Carboni

    Noel

     

    Aha! No I didn't, but I do now. Can't imagine how it got turned off!

     

    Many thanks for your spot-on help -

     

    Mary

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 29, 2011 2:07 PM   in reply to JanGeloen

    I have the same problem and I'm totally aggravated. My PS install is totally vanilla and it's 32 bit. All I can do is save the file and then open it in PS, copy it, and then paste it.

     

    Totally aggravating and I don't see any good solutions here.

     

    My clipboard is working fine outside of PS (or at least out of Adobe CS), so I can paste away into every other app.

     

    I can copy/paste from Adobe to Adobe...but not from anything else (Word, Web, screenshots) to PS.

     

    Help??

     

    I tried the registry hack and it worked for a short while but it stopped working almost immediately. It's hard for me to believe this is a Microsoft problem when every other app is respecting my clipboard, but for those made by Adobe.

     

    I don't have NIK or any other third party plugins installed.

     

    Copy/Paste is a critical function. And from what I've seen online, this problem has been floating around since 2009. Sucks that there aren't any reasonable competitors and I'm stuck with broken software or need to keep spinning my wheels to try to make it go.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 7:23 AM   in reply to JanGeloen

    Hey,

     

    I found a solution to workaround this issue, if you have Nik Software installed, just disable the auto lunch palette tool when PS start.

     

    windows 7 x64, master collection cs5.5

     

    Sorry for my bad english

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 9:27 AM   in reply to luxuria111

    We've also seen external applications (JDownloader) cause problems with copy/paste operations.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 10:09 AM   in reply to JanGeloen

    In response to luxuria111 :

     

    In the case of 32-bit PS, I believe the problem is related to PS "getting tired" -- that is, running out of memory resources and with (un)graceful degradation, which I guess is better than an outright crash where you would lose everything. Unfortunately I don't think there's anything you can do to restore normal clipboard operation without closing and re-opening PS. In my experience, the problem seems to happen a little more often after the system hibernates, so preventing that might help, just as taking care to minimize the number of files open in PS, as well as other applications. The problem seems to happen after I've been working for many hours -- usually if I forget and have lots of browser windows open. Of course expanding RAM to the max should help, but there's the cost and hassle of installing it. Usually before the clipboard problem happens, PS may stop responding to keyboard shortcuts, which can usually be cured by closing files without closing and re-opening PS, though as I mentioned, once the clipboard issue shows up, there's no other alternative.

     

    You might note whether the problem corresponds to the conditions I experienced before you spring for the RAM upgrade (if that's an option.)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 10:20 AM   in reply to Chris Cox

    I have a pretty vanilla, work machine. My only suspicion right now, is Windows own built in screen "snipping" tool.

     

    Chris, it seems pretty egregious that this has been going on for years and that Adobe doesn't have a handle on it. Every other app I use can access the clipboard appropriately except PS. I don't understand why this isn't a P1 bug for Adobe to figure out and fix.

     

    It is possible the registry hack has worked for me, but I don't think I should have to change my registry to support PS behaving badly. I can't accept that this is Microsoft's fault when the other apps all work fine.

     

    FYI: for me, restarting PS makes no difference. I have to reboot my whole machine. I don't think it's a memory problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 3:26 PM   in reply to luxuria111

    We've investigated, and found third party conflicts,  one Windows OS bug that we can't avoid (and MS thinks they fixed in Win7), and nothing else. Photoshop is using standard OS clipboard calls, and even double checking some of them due to other OS bugs (which should be fixed in Vista and later).

     

    If you have to reboot the machine, you're looking at an OS bug, or a bug in some other software.

    Photoshop doesn't have any persistent state for the clipboard between launches.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2011 3:48 PM   in reply to JanGeloen

    Chris, obviously, you have more info than I do. But I can't seem to get my brain wrapped around this notion that it's out of Adobe's control, since no other apps are having the same problem.

     

    If it's an OS bug, I'd expect other things that use the clipboard to have the same problem. But nothing else does has this problem.  Not Paint.NET, MS Office or even Adobe Illustrator -- they all utilize the clipboard properly.

     

    It's only PS.

     

    Based on that, I have to insist that somehow the Adobe PS team is missing something.

     

    And I apologize, but I was wrong about something. Rebooting PS does fix the problem (very temporarily.)

     

    The registry hack has not fixed this for me.

     

    I'm so aggravated. I don't know how I'm supposed to do my job with software that is so broken in this particular way.

     

    I have no plugins. I have a vanilla install. I have a machine that has almost nothing installed on it other Visio, Office, a couple of web browsers, etc. Nothing weird on my machine.

     

    I'm running a trial if that makes any bit of difference...under Win7, 32 bit.

     

    ETA: a list of third party conflicts would be helpful

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 1, 2011 11:27 AM   in reply to luxuria111

    >> no other apps are having the same problem.

     

    Thtat's bad logic.  I think you mean "no other apps that I've tried have the same problem".

     

    Photoshop uses the clipboard correctly according to Microsoft's documentation (and several debugging sessions with Microsoft engineers).

     

    It's only PS *in your experience*. But we test more apps, we work with Microsoft to debug and understand issues like this.  We've seen this happen in other apps, we've seen it happen to app B and not affect app C and D that use similar (but not identical) code.  Usually the bugs don't make sense until you actually find the root cause (misreading values on the stack and picking up random previous values, for instance -- and that was an OS bug that lasted several years).

     

    It is possible that we and Microsoft have missed something after years of looking at this code, debugging similar issues, etc..  It's just highly unlikely.  It's even more unlikely given that we keep finding other applications responsible for exactly the same behavior (JDownloader being a great example, and some third party plugins).

     

    We'll keep investigating, and keep trying to bullet proof our code.  But we can't do too much about the OS and how other applications interfere with the normal operation of the OS.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 1, 2011 11:35 AM   in reply to Chris Cox

    I'm past the point of finger-pointing and do appreciate that Adobe wants this to happen even less than I do.

     

    I have a reasonable workaround that cost me a little money but essentially nothing in the long run.

    I use Snagit, a fairly sophisticated clip application and clip manager, that can send the clip to PS, albeit in a new window.

     

    This may not be acceptable for others but works adequately for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2011 7:21 AM   in reply to JanGeloen

    Found this...using Win7 64-bit, PS CS5   ..........works for me, at least so far

     

    http://www.atlanticbt.com/blog/adobe-photoshop-clipboard-copypaste-bug -fix/

     

    Good luck!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2011 8:44 AM   in reply to Logan12354321

    I just ran across this thread today, and here's my experiences.

     

    I have no problem with pasting an image from a website, so long as they allow copy. I have seen (rarely) situations that appear to be as stateds here, but upon examonation of the clipboards contents, the object never copied, for whatever reason. If it didn't paste into PS, it also was not pasting into Paint.

     

    I ran SE2 trial as well and never had a problem like this show up.

     

    My 2c worth.

     

    Asus/AMD system

    12G Ram

    Win7 64 bit, all updates.

    PSCS5, all updates.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 16, 2011 9:12 PM   in reply to JanGeloen

    I just want to confirm that removing Nik Viveza 2 from plugins folder solved this issue for me. this is a bummer; hopefully Nik get's a handle on this soon.

     
    |
    Mark as:
1 ... 3 4 5 6 7 8 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points